[Xposed][MOD][4.0+][09-02-2021] KMod FWA v2.8.3 - WhatsApp privacy & customization

Search This thread

Kzyw

Senior Member
Sep 28, 2014
459
77
0
The colors are for the big widget, however, in the next update, I'm going to try that also applies to small widget.

Thank you very much friend.
My mother will be very grateful.
She uses clear backgrounds and always asks me about this.
I use black backgrounds and I do not have that problem with the widget, but she does.
Many thanks from my mother :)
 

fmaorui

Senior Member
Jun 2, 2012
51
15
28
I was thinking maybe a blank/opaque overlay on the screen during calls, having an option to turn on/off on privacy

---------- Post added at 11:56 PM ---------- Previous post was at 11:55 PM ----------

Thanks for researching tho:)
 

furchtlos76

Senior Member
Oct 21, 2013
176
23
0
Nice module, just some questions, what ist the best version to use it with at the moment? Is it normal, that i get popups like (translated) "your privacy settingsa could not be changed, please try again later"? The hide online status and delivered status seems not to work all the time. And i have problems that others can not hear my voice messages, showing them they are not on anymore... is this a whatsapp bug or something to do with the mod?
 
Last edited:

Gggggas

Senior Member
Dec 9, 2013
637
342
0
@Krowne Hello there amazing Dev/Team,

Your app is amazing works even on the latest beta builds. Small noticed if you haven't noticed them already:

1) When you mark to reply some text the status bar turns buck green(stock color)

2) When I select a photo to draw put stickers etc and send it to a friend , nothing is applied.

Thank you and keep up the amazing work.

Sent from my SM-G935F using Tapatalk
 

Krowne

Senior Member
Nov 23, 2012
1,162
2,835
153
what ist the best version to use it with at the moment?

It works the same in any version specified in the changelist or in the first post.

Is it normal, that i get popups like (translated) "your privacy settingsa could not be changed, please try again later"?

That's normal, that message is displayed, because you have the option to hide the last connection activated, but you can see the other one. Therefore, if you enter or have entered a conversation of one your contacts, and he have hidden your last connection, then you usually display that message.

The hide online status and delivered status seems not to work all the time. And i have problems that others can not hear my voice messages, showing them they are not on anymore... is this a whatsapp bug or something to do with the mod?

This question has two parts, which are different, and have no relation to each other.

On the one hand, the option to hide online status is independent, and if you only have this option enabled, it will always work correctly.

On the other hand, you have the option to hide received messages. I have explained in many occasions (it's a frequent question) that it's not advisable to use this option continuously, as it causes a delay in the received messages, both text and audio (if I had used the search engine there would have viewed).

I want to clarify, that this is not a bug. It's the behavior of the WhatsApp servers, by not detecting message delivery.

@Krowne Hello there amazing Dev/Team,

Your app is amazing works even on the latest beta builds. Small noticed if you haven't noticed them already:

1) When you mark to reply some text the status bar turns buck green(stock color)

2) When I select a photo to draw put stickers etc and send it to a friend , nothing is applied.

Thank you and keep up the amazing work.

Sent from my SM-G935F using Tapatalk

This error is in the list of known errors. I'm sorry, but I've explained several times that, at this bug, I don't know how to solve it. :(
 

Puff

Senior Member
Oct 25, 2012
50
11
0
Stalinogród
Hello Krowne.

Long ago I have asked about freezing gif files, etc. on my Z3. It was completely unrelated to Kmod, but since it was the first thing I have had problem with (when I discovered a bug of some kind), I asked here for help.

So, if anyone's having any issues with video / gif playback in whatsapp, here's the resolution for that:

https://forum.xda-developers.com/xperia-z2/help/video-playback-issue-t3290793
 
  • Like
Reactions: Krowne

Mangi1

Member
Jun 11, 2017
8
0
0
Bluetooth issues

When I install this mod, everything works fine except one thing. The Bluetooth loses every paired device once the phone is rebooted. Does anyone have this issue? I have an s8 g950f, magisk v.14, xposed 88.1. Please, I really want to use this great module. :(
 

Krowne

Senior Member
Nov 23, 2012
1,162
2,835
153
When I install this mod, everything works fine except one thing. The Bluetooth loses every paired device once the phone is rebooted. Does anyone have this issue? I have an s8 g950f, magisk v.14, xposed 88.1. Please, I really want to use this great module. :(

If you don't give me a bug log, I can't do anything about it, although I think it's going to be a problem with your version of Android with Xposed.
 

XenRon

Senior Member
Oct 21, 2016
236
60
0
I'm getting FC in kmod when I open it and I am getting a prompt to upgrade kmod to 2.7.4 in whatsapp although there is no such version yet.

Resurrection Remix 7.1.2
Systemless xposed 88.2 via magisk

Here's a stacktrace:

Code:
java.lang.RuntimeException: Unable to start activity ComponentInfo{kmod.xposed/kmod.xposed.KMod}: java.lang.SecurityException: MODE_WORLD_READABLE no longer supported
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2699)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2766)
	at android.app.ActivityThread.-wrap12(ActivityThread.java)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1507)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:154)
	at android.app.ActivityThread.main(ActivityThread.java:6236)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:891)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:781)
	at de.robv.android.xposed.XposedBridge.main(XposedBridge.java:107)
Caused by: java.lang.SecurityException: MODE_WORLD_READABLE no longer supported
	at android.app.ContextImpl.checkMode(ContextImpl.java:2134)
	at android.app.ContextImpl.getSharedPreferences(ContextImpl.java:354)
	at android.app.ContextImpl.getSharedPreferences(ContextImpl.java:349)
	at android.content.ContextWrapper.getSharedPreferences(ContextWrapper.java:164)
	at kmod.xposed.c.b(Unknown Source)
	at kmod.xposed.cust.a.a(Unknown Source)
	at kmod.xposed.KMod.onCreate(Unknown Source)
	at android.app.Activity.performCreate(Activity.java:6684)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1119)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2652)
	... 10 more

Awesome module btw. :D
 
Last edited:

Krowne

Senior Member
Nov 23, 2012
1,162
2,835
153
I'm getting FC in kmod when I open it and I am getting a prompt to upgrade kmod to 2.7.4 in whatsapp although there is no such version yet.

Resurrection Remix 7.1.2
Systemless xposed 88.2 via magisk

Here's a stacktrace:

Code:
java.lang.RuntimeException: Unable to start activity ComponentInfo{kmod.xposed/kmod.xposed.KMod}: java.lang.SecurityException: MODE_WORLD_READABLE no longer supported
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2699)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2766)
	at android.app.ActivityThread.-wrap12(ActivityThread.java)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1507)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:154)
	at android.app.ActivityThread.main(ActivityThread.java:6236)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:891)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:781)
	at de.robv.android.xposed.XposedBridge.main(XposedBridge.java:107)
Caused by: java.lang.SecurityException: MODE_WORLD_READABLE no longer supported
	at android.app.ContextImpl.checkMode(ContextImpl.java:2134)
	at android.app.ContextImpl.getSharedPreferences(ContextImpl.java:354)
	at android.app.ContextImpl.getSharedPreferences(ContextImpl.java:349)
	at android.content.ContextWrapper.getSharedPreferences(ContextWrapper.java:164)
	at kmod.xposed.c.b(Unknown Source)
	at kmod.xposed.cust.a.a(Unknown Source)
	at kmod.xposed.KMod.onCreate(Unknown Source)
	at android.app.Activity.performCreate(Activity.java:6684)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1119)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2652)
	... 10 more

Awesome module btw. :D
It's absolutely impossible that you are receiving a notification to update to version 2.6.4, this doesn't exist at the moment, it's in beta phase of personal use. Upgrade to version 2.6.3, available in the same forum or in the Xposed repository.
 

XenRon

Senior Member
Oct 21, 2016
236
60
0
It's absolutely impossible that you are receiving a notification to update to version 2.6.4, this doesn't exist at the moment, it's in beta phase of personal use. Upgrade to version 2.6.3, available in the same forum or in the Xposed repository.
Oops! Looks like I misread it! It prompts me to upgrade to 2.6.3. Seems like the xposed repo's latest version is 2.6.2 which lead me to download this version.
 

deloj

Senior Member
Oct 17, 2017
478
26
28
Hey.. Please look at the attached image circled in red. How do I change the black font to show up in white?
 

Attachments

  • 2017-11-05-194350.png
    2017-11-05-194350.png
    67.4 KB · Views: 148

XenRon

Senior Member
Oct 21, 2016
236
60
0
Not working in nougat (xposed module not detected)
You need I update your xposed template to the latest one to make it compatible with nougat.

Using systemless xposed
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Due to the latest WhatsApp changes, and my lack of time to fix them, the 2.21.7.9 libraries will be the last published for the moment. This will only influence privacy options and certain aesthetics. Otherwise, everything will continue to work the same.

    If I have some time the next few days I will try to fix them.

    Sorry for the inconvenience.
    2
    With the exact versions I said, it should work flawlessly because I'm using it right now in Oreo.

    I plan to make the module from scratch, with all the latest versions of everything, but not at the moment, because I don't have time. I have other jobs going on, and I don't have time for everything. And since KMod FWA works in the version I said, and many other older modules as well, I'm in no rush to start the project again.

    I don't think it is compatible with LSPosed, because I am not going to adapt the module to a multitude of framewoks that are being released and that I am not going to use. If they are compatible with Xposed, then KMod FWA will be.

    They don't seem to think about how many old modules worked perfectly, and they haven't been updated for years. And that now with the strange updates to Magisk and new Frameworks, now it has to be the modules that adapt to something that has worked for so many years?
    You are right with your logical reasoning, but it is also true that:
    1) frameworks updates, and maybe the creation of new frameworks too, are like KMod (or other modules) updates: for security or new features reason!
    So, why shouldn't they update or innovate them?!
    2) following your logical reasoning, all of us should stick to the now, unfortunately, outdated original Xposed framework (incompatible now, on newer Android version), without innovation and/or other features that following new technologies...I know that you are still on Oreo, and the creation of KMod module are yours, but.... 😬

    PS: obviously you have your own life and it's difficult and/or you need time to interely rewrite, or update, the code; I understand this 😉
    2
    You are right with your logical reasoning, but it is also true that:
    1) frameworks updates, and maybe the creation of new frameworks too, are like KMod (or other modules) updates: for security or new features reason!
    So, why shouldn't they update or innovate them?!
    2) following your logical reasoning, all of us should stick to the now, unfortunately, outdated original Xposed framework (incompatible now, on newer Android version), without innovation and/or other features that following new technologies...I know that you are still on Oreo, and the creation of KMod module are yours, but.... 😬

    PS: obviously you have your own life and it's difficult and/or you need time to interely rewrite, or update, the code; I understand this 😉
    Don't get me wrong, I'm not at all against updates, as you say they fix bugs or contain improvements. But since they do, what minimum to maintain the essence on which they have been working for years? At least on the Android versions that have been working so far. If Android 10 or 11 needs updating, as it doesn't work, then make the changes only for those versions, not for all the versions that have been working so far.

    Regarding the module update, as I said, I need time, and lately I have nothing. Surely in summer I will have a little more, but I'm not sure yet.
    2
    I have been able to do the libraries of the last few days ago, but I still haven't solved the problem that prevents me from doing it automatically, because I have to think about how to solve it. However, although it's a bit more tedious, for now, if there are no more changes, I will release the libraries as before.

    https://github.com/Krowne/Libraries
    1
    Updated WhatsApp and libraries to 2.21.7.10. Only thing missing seems to be indeed the privacy options. I am sure you will figure something out when you can find the time. I don't often respond in this topic, but I just wanted you to know how much I appreciate all the work you put into this.
  • 167
    KMod FWA v2.8.3

    6EjA7z1.jpg

    Disclaimer:

    • Use KMod FWA at your own risk.
    • Readers, end-users, and downloaders of KMod FWA are responsible for their own actions.
    • Readers, end-users, and downloaders of KMod FWA agree not to use for illegal actions.
    • This disclaimer is subject to change without notice at any time for any reason.

    Features:

    • Independent customization of each section of the application.
    • You can change color backgrounds, fonts and icons.
    • New icons and ticks in differents sections.
    • Customization different images of the application.
    • Hiding unwanted elements or of little use.
    • Direct access to module from within the application.
    • Privacy options.

    Minimum requirements:

    • Xposed Framework
    • Android 4.0.3 or higher.
    • From WhatsApp 2.21.4.1 or higher.
    • KMod FWA only work on Android devices with an integrated theming. This means that you can change the appearance of your Android through some application integrated in the ROM itself.

    Supports:

    • Android 4.0.3 (Ice Cream Sandwich)
    • Android 4.1 to 4.3.1 (Jelly Bean)
    • Android 4.4 (KitKat)
    • Android 5.0 (Lollipop)
    • Android 6.0 (Mashmallow)
    • Android 7.0 (Nougat)
    • Android 8.0 (Oreo)
    • Android 9.0 (Pie)
    • Android 10.0
    • Android 11.0+ (Correct operation is not assured)

    Instructions:

    1. Download the module and install.
    2. Activate it in Modules section of Xposed Installer, and reboot device (Normal restart, not quick).
    3. Open KMod FWA and accept root permissions.
    4. In Android 6.0 or higher, accept the storage and access permissions to the phone's book, or activate it from the application manager of your device.
    5. Make all the changes you want in Customization section.
    6. To see the changes made, click on the refresh icon
      1GXQvWr.png
    7. To save a theme, go to the Backup section, or click the save icon
      EGT7qjc.png
    8. To load a Theme, go to the Backup section, select the Theme you want to upload, and wait the message that the Theme has been loaded.
    9. Go to the Updates section, and Update the libraries. To check the latest available libraries, go to:
      https://github.com/Krowne/Libraries
    10. If you are using EdXposed it is recommended to enable SE Linux in settings.

    Instructions for installing Magisk, edXposed and KMod FWA on Android 8.0+

    https://forum.xda-developers.com/showpost.php?p=80500899&postcount=2677

    Downloads:

    - Version 2.8.3 (Stable version):

    Forum
    Github

    MD5: fbcb3fb3e33b2ee2fbae75c7c1378fd8

    Repository:

    http://repo.xposed.info/module/kmod.xposed

    Change Log:


    Known issues:

    • The customization is not applied correctly in the Settings section.
    • The circle of FAB button on the main screen doesn't apply color customization.

    ATTENTION!

    The Riru module v22+ from Magisk, doesn't detect Xposed correctly, therefore it's recommended to use version 21.3 so that everything continues to work correctly.

    As I communicated a long time ago, now the Hooks update system (now called libraries) will not continue to update automatically. Updates will now be made on each version independently, and there will be no updates for all versions.

    To update the libraries, you must enter the Updates section and click on the Update libraries option. At the moment, there will only be libraries for stable versions and beta versions published on weekends, however, in the link published below, I will publish all available versions of libraries in each version of KMod FWA.

    List of available libraries: https://github.com/Krowne/Libraries

    Download Themes:

    Place their themes on your SD card or internal memory, in the /KMod/Themes route. Make sure the directory exists before placing, if doesn't exist, open the module for create directories.

    Download from the index of themes

    XDA:DevDB Information

    KMod FWA, Xposed for all devices (see above for details)

    Contributors
    Krowne
    Xposed Package Name:

    Version Information
    Status:
    Stable
    Current Stable Version: 2.8.3
    Stable Release Date: 2021-02-09

    Created 2016-08-03
    Last Updated 2021-02-09
    56
    FAQ:
    Q: I installed an update, and KMod FWA is not recognized by Xposed.
    A: This is usually normal on some devices.

    Disable KMod FWA from the list of Xposed modules, perform a normal restart (not quick), enable KMod FWA again in the list of Xposed modules, and do a normal restart.

    Sometimes, disable and enable KMod FWA the list of Xposed modules, and do a normal restart is sufficient.

    Q: Why it doesn't work in some versions of WhatsApp?
    A: This only works in official versions of WhatsApp higher than that specified in the requirements.

    It may also be that your Android version doesn't have integrated customization, and that is the reason why there is no customization in WhatsApp.

    Q: Installed and activated the module, why the changes do not apply to WhatsApp?
    A: Maybe you have not successfully activated the module, deactivate, activate, and then restart of device (normal restart, not by software). You may also be using a version of WhatsApp not compatible with the module.

    Q: Can't download themes from the cloud?
    A: At the moment this option is not available, you can upload your themes to external and share servers.

    Q: Where was it saved, or where should I save new themes to load them into KMod FWA?
    A: Used to place their themes on your SD card or internal memory, in the /KMod/Themes route. Make sure the directory exists before placing, if doesn't exist, open the module for create directories.

    Q: I have changed the application icon, and no changes are applied.
    A: After changing the application icon you must restart your device. If it still doesn't change the icon, you may be using a launcher who does not support changing the application icon (such as Nova Launcher).

    Q: I have updated KMod FWA and several options have stopped working.
    A: If this happens, then go to KMod FWA Settings, select Delete cache, and press Apply changes in KMod FWA.

    Q: I have activated the option to see a Toast of the people who connect and disconnect, but it does not work.
    A: These notifications will only be displayed when:
    1. Log in to WhatsApp.
    2. Enter a contact's chat.
    3. You are inside WhatsApp.
    4. Do not keep the online status hidden.

    When these four conditions are met, then you should see when the contacts you have entered into your chat are connected or disconnected.

    If you comply with the four conditions, but leave WhatsApp, force the closure of the application or enter KMod FWA, you must repeat the four conditions to make it work again.

    Q: I have problems related to privacy options.
    A: See this post for more information: https://forum.xda-developers.com/showpost.php?p=75503030&postcount=1772

    Translations:

    Looking for volunteers to translate the module into different languages, to publish in the next update.. Interested send me private messages.

    Current languages:
    • English
    • Arab
    • Bengali
    • French
    • German
    • Spanish
    • Hindi
    • Indonesian
    • Italian
    • Dutch
    • Polish
    • Portuguese (Brazil)
    • Romanian
    • Russian
    • Turkish

    Thanks to:
    @wanam for the mod: Hide the read messages (in versions prior to WhatsApp 2.18.1).
    @Surajkumar for the mod: Deactivate delivery report (in versions prior to WhatsApp 2.18.1).
    jaredrummler ColorPicker (current version).
    24
    when your private life depends on a programmer or an app. there is no patience worth. nice to meet you KMod

    I also have a private life, and as I said many times this is a hobby, and I also said many times that I'm busy lately, that until June I wasn't going to be able to update, and even saying that, I've been working on something, but in a private way.

    If your private life depends on a developer or an app, I think you should look at it. (with all my respect).
    24
    Update - KMod FWA v2.7.6

    Version 2.7.6 (14-08-2019 - From WhatsApp 2.19.203):

    7cutsdM.png
    Added all privacy options again.
    7cutsdM.png
    Now you can add a button on the conversations screen to make phone calls.
    7cutsdM.png
    Restructured the icons section within the Conversations section.
    7cutsdM.png
    New method to update libraries (Hooks). They are now updated by selecting the Update libraries option, in the Updates section.
    lYwNNSB.png
    Removed the Clear cache option in Settings (Now use the Update libraries option).
    lYwNNSB.png
    Removed the automatic update of Hooks when entering WhatsApp (It didn't work correctly on some devices).
    lYwNNSB.png
    Removed swipe to respond option (it's already active by default).
    lYwNNSB.png
    Removed option to activate Stickers (it's already active by default).
    lYwNNSB.png
    Removed option to replace the call button of WhatsApp by telephone calls (a separate button was added).
    lYwNNSB.png
    Removed personalization of some screens of the Settings section (for now).
    TLaiDez.png
    Fixed other errors.

    Download:

    Repository Xposed
    Forum - XDA-Developers

    MD5: 043c64c2585b5df5ee23d1062e49a96b

    Xposed Repository:

    http://repo.xposed.info/module/kmod.xposed



    ATTENTION!

    As I communicated a long time ago, now the Hooks update system (now called libraries) will not continue to update automatically. Updates will now be made on each version independently, and there will be no updates for all versions.

    To update the libraries, you must enter the Updates section and click on the Update libraries option. At the moment, there will only be libraries for stable versions and beta versions published on weekends, however, in the link published below, I will publish all available versions of libraries in each version of KMod FWA.

    List of available libraries: https://github.com/Krowne/Libraries

    Another point that many ask me is the compatibility with Android 9 and 10. The module works for some people who use edXposed, if you are one of the people that KMod FWA doesn't work, it's not something I can solve, it's something that Developers of edXposed should solve, for incompatibilities with your devices. Therefore, it's not that KMod FWA doesn't work because it is not compatible, it's compatible, but your device with edXposed and KMod FWA is not.

    Note: The options to hide record audio and write don't work correctly in the latest beta versions.
    20
    Lack of time

    I'm aware that I'm not updating the libraries, but there are some errors, and I don't have time lately to update.

    The project is not abandoned, but if stopped until you have some time (Maybe it's for a few days, or maybe for weeks).

    I apologize to everyone for it.

    I wish the days were of 34 hours... :(
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone