• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Xposed version89 or 90-beta3 not active, on Moto G4 Nougat 7.1 with custom ROM

Search This thread
Oct 20, 2021
13
2
Hello everyone!

I installed Xposed on Moto G4 Android 7.1.2 (Nougat) into which I had installed e foundation custom ROM (bravo to me!). I wanted to install XPrivacyLua.

I downloaded the Xposed Framework v90-beta3 via Magisk. This resulted in a message in yellow: "Xposed Framework version 89 is installed, but not active. Please check the logs for details." "Could not load available ZIP files. Pull down to try again".
Please help! I would greatly appreciate your help, as I am a complete beginner. Actually, believe it or not, I haven't even used a smartphone before (true). I thought I would start on the right foot by installing a custom ROM, and going in the deep end. So far so good. But I need help and guidance from experienced folks now!
How can I make the Xposed active?

In Magisk, it says Xposed Framework v90-beta3 by rovo89 is installed. So not sure if I have v89 or v90 installed.
I have also given root access to Xposed in Magisk.

XPrivacyLua has also been installed, but it's not active, since Xposed is still inactive.

LOGS say as follows:
10-20 13:26:12.712 I/Xposed ( 457): ..............................
10-20 13:26:12.712 I/Xposed ( 457): Starting Xposed version 89, compiled for SDK 25
10-20 13:26:12.712 I/Xposed ( 457): Device: Moto G4 (Motorola), Android version 7.1.2 (SDK25)
10-20 13:26:12.712 I/Xposed ( 457): ROM: e_athene-userdebug 7.1.2 NJH47F 20210531 dev-keys,dev-release
10-20 13:26:12.712 I/Xposed ( 457): Build fingerprint: motorola/athene/athene:7.0/NPJ25.93-14/16:user/release-keys
10-20 13:26:12.712 I/Xposed ( 457): Platform: armeabi-v7a, 32-bit binary, system server: yes
10-20 13:26:12.712 I/Xposed ( 457): SELinux enabled: yes, enforcing: yes
10-20 13:26:13.754 I/Xposed ( 457): ................................
10-20 13:26:13.754 I/Xposed ( 457): ERROR: Could not access Xposed jar '/system/framework/XposedBridge.jar'
read: unexpected EOF!


Please advise re above log: "ERROR: Could not access Xposed jar '/system/framework/XposedBridge.jar'read: unexpected EOF!" How can I let Xposed access the Xposed jar?

I have found a similar problem on: https://github.com/rovo89/XposedBridge/issues/200

People in above GitHub page talked about solving the problem by giving permission by using a root explorer. I am not sure what a root explorer is and how to use it, and whether using it would solve the situation?
I wonder if someone can please explain in simple language?

I am awaiting with great anticipation your voice of experience, everyone!
 
Oct 20, 2021
13
2
Hi everyone,

I wonder if you had a chance to muse over the above situation?

Please do help. I am counting on you all.

Thank you in advance!

Yours
CD
 
Oct 20, 2021
13
2
Dear spawnlives,

Thank you so much for your reply. I am very grateful for your generous help.

I have a feeling I have already tried the original xposed without success, as I tried so many things.
But will definitely try it again!

All best wishes,
CD
 
Oct 20, 2021
13
2
Hello spawnlives and everyone,

Following your kind suggestion, spawnlives, I looked through my notes. I had tried the original Xposed for Android 7, which I had downloaded from XDA site.

The result was that Xposed didn't even show up in apps list, for some reason. It was nowhere to be seen - not even an icon.
So if you have further ideas, I would be most appreciative.

Unfortunately, the ROM I'm using had an update 2 days ago, which made Magisk to stop working. So Xposed has turned from yellow warning to red...
Sadly I don't think I can sort everything out until beginning of Dec, due to work.

I'll be back.

All best wishes,
CD
 

spawnlives

Senior Member
Jan 27, 2018
1,100
408
Samsung Galaxy S8
Samsung Galaxy S9
Hello spawnlives and everyone,

Following your kind suggestion, spawnlives, I looked through my notes. I had tried the original Xposed for Android 7, which I had downloaded from XDA site.

The result was that Xposed didn't even show up in apps list, for some reason. It was nowhere to be seen - not even an icon.
So if you have further ideas, I would be most appreciative.

Unfortunately, the ROM I'm using had an update 2 days ago, which made Magisk to stop working. So Xposed has turned from yellow warning to red...
Sadly I don't think I can sort everything out until beginning of Dec, due to work.

I'll be back.

All best wishes,
CD
Bear in mind, much like magisk. xposed has two components to it.
Framework and installer ( control ) app
The framework will not show up in the system an app, only the installer ( control ) app will.
If you are going to use rovo's version you will have to use his installer app as well.