[Z Ultra][TWRP][PhilZ Touch][CWM] XZDualRecovery Q&A

Search This thread


Jul 12, 2016
Can I use this recovery to flash other recovery (like original twrp, etc)? If yes, afterwards, how will I remove this recovery?


Senior Member
Aug 9, 2009
Motorola Edge 20 Pro
Guyz thanks for this awsome bat file ,... but i need help as i cannot make it work

i have xperia z ultra , with FTF flashed version , and rooted via easy root tool , installed busy box and su ...
but when i tried to load any method of recovery its failing continuously following are the steps i did.
1, TWRP manager ... --> failed error = some thing went wrong ..
2, Flashr --> failed error No recovery partition found
3, ADB commands to load img file --> adb server outdated ... error
4, through bat file of dual recovery (nuts ) --> failed error msg . .adb server otu dated....
5, Fastboot mode not helping ( i am using windows 10 ) fastboot drivers for sony issue cannot find the device through min adb ...

i am out of options now .... please devs kindly help me i need to load marshmellow ( rooted ) with recov on my device but due to following issues not able to do it
once i g0t into the recovery ( i cannot remmeber which method works) but after that happened i was unable to boot the phone normally ( its always rebooting to sony logo ) so i had again flashed it through flash tool back to .108 FTF ... and then again rooted it ..

now i am waiting for any one to give me a break through to get into recovery ...


thanks ... it was just a matter of changing the OS . i am using windows 10 , i installed virtual mahcine win xp , connected the xperia z , ran the batch file ... and Dhuz..!! Dhaa... i worked like a charm .... now i have the working recovery with rooted rom .108 ..
thanks... for creating this wonder full batch file....
Last edited:


Feb 7, 2017
Hard buttons works well but the Touchscreen doesnt work on recovery...... Pls help

C6802, rooted, os 5.1.1, LB


New member
Jul 14, 2010
Need Help Urgently

downloaded ZU-lockeddualrecovery2.8.26-COMBINE.installer
(model 6802)

what is this:
/system/bin/sh: su: not found
installation FAILED


Senior Member
Jul 12, 2017
hello, i downloaded it for ZU but when the phone is in recovery is recongized as t2 ultra, and doenst allow to flash a rom for z ultra...help plz


New member
Nov 19, 2017
Same as fafejaya
/system/bin/sh: su: not found
installation FAILED
Appears on 2.8.26 and 2.8.25 using windows 10. Archive does not contain the files. Where to get them or does anyone have a complete package?


Senior Member
Jul 12, 2017
Same as fafejaya
/system/bin/sh: su: not found
installation FAILED
Appears on 2.8.26 and 2.8.25 using windows 10. Archive does not contain the files. Where to get them or does anyone have a complete package?
HI, I don't know the exact solution for that...but thanks to SUPERUSER the solution was install a stock ROM on my device and try with TWRP... IF need some help let me know ;)


May 5, 2011
Backup goes to wrong external sd partition

Got Xperia z tab Wifi
- philz touch 6
-app2sd with re-partitioned external SD card to add an ext3 partition for app2sd to work.
My problem is that making a backup with Philz and choosing backup to /storage/sdcard1 the backup goes to the ext3 patition not the first one.
Any help appreciated


Sep 13, 2016
what if i want to flash rom after installing (LockedDualRecovery)??? on [UBL]

my bootloader is unlocked ......so how can i install a custom rom ??? on my Xperia Z Ultra [C8633]
running stock android [4.4.4] thanks u <3

Top Liked Posts

  • There are no posts matching your filters.
  • 37
    PhilZ Touch & CWM & TWRP
    *** For Locked and Unlocked BOOTLOADERS! ***

    Welcome to the Xperia Z Ultra Questions & Answers thread!

    I proudly present you the first and only DUAL RECOVERY for locked boot loaders on our lovely Xperia phones! :cool:

    If you have an unlocked bootloader and chose to keep the STOCK Sony kernel, you can also use this MOD.

    Currently supported XPERIA models:
    These are also links to the device specific Q&A threads.
    Xperia Z: SO-02E, C6602, C6603, C6606, C6616
    Xperia ZL: C6502, C6503, C6506
    Xperia Tablet Z: SO-03E, SGP311, SGP312, SGP321, SGP351
    Xperia Z Ultra: C6802, C6806, C6833, C6843
    Xperia Z1: C6902, C6903, C6906, C6943, C6916
    Xperia Z1 Compact: D5502, D5503, D5506
    Xperia Z2: D6502, D6503, D6506, D6543, D6563
    Xperia Tablet Z2: SGP511, SGP512, SGP521, SGP551, SGP561
    Xperia ZR: C5602, C5603, C5606
    Xperia T, TX, TL and V: LT30p, LT29, LT30at, LT25i
    Xperia S: LT26i
    Xperia SP: C5302, C5303
    Xperia T2 Ultra: D5303, D5322
    Xperia Z3: D6603, D6633, D6643, D6653, D6616
    Xperia Z3 Compact: D5803, D5833
    Xperia Tablet Z3 Compact: SGP621, SGP641, SGP651

    To follow development, be sure to check the DevDB thread!
    INSTALLER: How to install using the installer:
    1. Make sure you have USB debugging turned ON.
    2. download ZU-lockeddualrecovery[VERSION]-BETA.installer.zip from http://nut.xperia-files.com
    3. Windows:
      1. unpack at C: or somewhere you will remember!
      2. navigate to the resulting directory and look for install.bat, double click it to run;
    4. Linux:
      1. unpack in your home folder with 'unzip ZU-lockeddualrecovery[VERSION]-BETA.installer.zip'
      2. navigate to the resulting directory and 'chmod +x install.sh', then execute it, follow instructions.
    5. Your phone WILL reboot when installation has completed and it will go into the default recovery for the first boot.
    6. Reboot to system from recovery to allow the installer to clean up after installation (it is safe to skip this step).
    7. Enjoy DUAL RECOVERY!

    How to install or update using a previously installed (XZDualRecovery) recovery:
    Create a backup of /system/bin/chargemon and keep it somewhere safe, then just flash ZU-lockeddualrecovery[VERSION]-BETA.flashable.zip from http://nut.xperia-files.com using CWM or TWRP.

    How to remove:

    Delete the following files:
    /system/bin/recovery.twrp.cpio.lzma (or .tar)
    /system/bin/recovery.cwm.cpio.lzma (or .tar)

    Rename /system/bin/mr.stock to /system/bin/mr to restore stock functionality, then inside /system/bin/ rename chargemon.stock to chargemon check its permissions (should be 755 or otherwise visible as -rwxr-x-r-x). Done!

    When installing custom ROMs:
    Be sure to flash ZU-lockeddualrecovery[VERSION]-BETA.flashable.zip from http://nut.xperia-files.com after installing the ROM and before you reboot, this way you will not lose recovery!

    How to use:
    At boot, once you feel the phone vibrate and while you see the green led burn:
    - press VOL-UP for PhilZ Touch;
    - press VOL-DOWN for TWRP.

    To enter Vanilla CWM, you will need to use the (free) NDRUtils app from the Play store

    2.x Features:
    • When you have a SDCard1 and the XZDualRecovery is able to use it, you can put a file called 'donotrun' inside the XZDualRecovery log folder to make XZDualRecovery escape following boot attempts.
      If you find yourself in a bootloop situation, take out your SDCard1 and put that file in the directory if it exists using a PC. Reboot your phone with Power+Vol-UP and you will be able to boot your phone as if there was no recovery there!
    • XZDualRecovery will signal the escape or any reason why it would not be able to continue normal operation with a 2 second burn of your LED in the color RED. A reason would be a broken /cache and no SDCard1 or a busybox in /system/xbin which does not support the lzcat command. If you see that, check /tmp/XZDualRecovery for a logfile there, it will tell you why.
    • XZDualRecovery will try to use your SDCard1 for logging and functionality, if it has been formatted with ext2/4, FAT16/32 or exFAT. NTFS is currently unsupported.
    • XZDualRecovery now prevents the RIC service from starting up, this means when running XZDualRecovery the Remount-Reboot fix is no longer needed.

    • The default on first boot with the boot-to-recovery flag set by any recovery is PhilZ Touch Recovery.
    • Init.d support is disabled by default, set dr.initd.active to true to enable it.
    • Insecure ramdisk support is disabled by default, set dr.insecure.ramdisk to true to enable it, set to 'power' to boot it by pressing the power button at boot.

    Error reporting:
    Please, when reporting errors or problems:
    • Put up a notice in this thread providing the package name you used to install or update;
    • Include ROM name and/or FW version numbers;
    • Include what SU apk you are using (SuperUser or SuperSU)
    • Send me the contents of all the log files from right after a failed boot attempt or a link to an archive containing these logs by PM (that's including the .old rotation logs!). If you have no website or online location to store the logs, PM me for an email address to send them to.
    • Logs can be found inside:
      • /cache/recovery
      • /tmp/XZDualRecovery
      • /storage/sdcard1/XZDualRecovery
      • /cache/XZDualRecovery (if the previous exists, this one will not!)
      NOTE: I need them ALL!
    I really need them to troubleshoot what failed and what worked OK. Thank you!
    Special Thanks:
    • @DooMLoRD for all his excellent work on our much loved Sony phones!
    • The Team Win developers for TWRP
    • The ClockWorkMod developers for CWM
    • @alexocean for his awesome job testing almost all FW releases and the discovery of SuperSU causing problems for the installation of this recovery!
    • @RoberM for testing
    • @surdu_petru for testing and handy pointers
    • @Androxyde for allowing to use his linux and mac adb binaries.
    • @lancebukkake for finding the TWRP 'fix' to use exFAT formatted sdcards!
    • @delewer for the final fix for TWRP and its use of exFAT formatted sdcards
    • @DevShaft for some code help on the windows installer (the menu!)
    • @Androxyde again, but now for his bash code/script suggestions... oh boy this guy is a genius! :highfive:
    • @Tamirwig and @shoey63 for their excellent job at testing early BETA's (Xperia Z)
    • @gregbradley for his extensive testing on the Xperia Z1

    Well, enjoy! :fingers-crossed:

    The origins of this XZDualRecovery package are in the packages done by:
    Krabappel2548, Cpasjuste and DooMLoRD
    Thank you for your excellent work guys! :victory:
    Your thanks (and donations) should (also) go out to them, they deserve it! :highfive:
    Awesome, and thank you! I can't see a reason why i should flash this if i already have recovery/TWRP installed? Or? Would you recommend me to install this one, or isn't it that big of a deal?

    No, it's a personal preference really :)

    XZDualRecovery has been created with choice in mind. It's feature rich and more are coming but if you can do without the features... :)
    Hello @[NUT] , Why with TWRP I can not enter my SD card? I see 0MB...

    With Phil'z Touch no problem but i prefer TWRP


    That actually depends, what filesystem does the sdcard contain?

    @[NUT] hey quick question for you anyone here wanting to chime in..
    So I'm using the CM12 official nightlies and I flashed the 20150125 release
    and than flashed the the dual recovery flashable zip immediately after and before rebooting as stated in the OP and when the 20150126 nightly was released I went to boot to recovery only to find myself in Cyanogens Recovery.. Any ideas as to why that would have happened? I flashed the flashable dual recovery through TWRP and didn't think much as to check it afterwards.. I ended up using Cyanogens Recovery to update my nightly and that did work fine but CM's recovery will not allow me to flash your dual recovery because the signature verification fails.... Just curious to know how would I get back your dual recovery? Thanks!

    This recovery package is for Sony STOCK (based) ROM's only!

    My apologies but my buddy introduced me to an app just a short while ago and its free on the play store.. To anyone getting hung up with missing a recovery download Rashr its free on the Play Store and it allows you to backup your current recovery and kernel and allows you to flash a recovery right from the storage or you can download one via the app itself and I can confirm it picks the correct device model and flashes flawlessly!!!!!!!! I'm now running the official CM12 20150126 nightly and have TWRP installed woohooooo

    Sent from my Xperia Z Ultra using XDA Free mobile app

    Glad you got it fixed though.