[Z3C][TWRP][PhilZ Touch][CWM] XZDualRecovery Q&A

Search This thread

AlbertoSONIC

Senior Member
Jul 16, 2012
567
469
Arezzo
Every attempt of replacing KingRoot with SuperSU failed. So I tried to remove and readd root using KingRoot and my phone stuck in a bootloop. (It showed the sony screen, then the bootanimation starts but instantanely freezes and the z3c reboots). I took FlashTool and flashed the same firmware I was on, without data wipe. The z3c booted, with a lot of fcs, but it booted. Then I tried again KingRoot + recovery installation and it worked! I rebooted into recovery and installed ad 5.1.1 based rom. After I rebooted the z3c, it was again in a bootloop. Now I flashed the previous firmware again and the z3c is booting. Idk what to think, I'm new to sony "modding world" and everything I'm getting right now is a lot of bootloops :(
 

[NUT]

Senior Member
Every attempt of replacing KingRoot with SuperSU failed. So I tried to remove and readd root using KingRoot and my phone stuck in a bootloop. (It showed the sony screen, then the bootanimation starts but instantanely freezes and the z3c reboots). I took FlashTool and flashed the same firmware I was on, without data wipe. The z3c booted, with a lot of fcs, but it booted. Then I tried again KingRoot + recovery installation and it worked! I rebooted into recovery and installed ad 5.1.1 based rom. After I rebooted the z3c, it was again in a bootloop. Now I flashed the previous firmware again and the z3c is booting. Idk what to think, I'm new to sony "modding world" and everything I'm getting right now is a lot of bootloops :(

Does the 5.1.1 rom include any mods besides xzdualrecovery and root?

Boot to recovery and make a backup of your data partition now... Then:

Did you try wiping dalvik and /cache from recovery? If you do that, does it boot once trouble free and with the next boot end up in a bootloop again?

(last resort!) What happens if you wipe data?
 

AlbertoSONIC

Senior Member
Jul 16, 2012
567
469
Arezzo
Does the 5.1.1 rom include any mods besides xzdualrecovery and root?

Boot to recovery and make a backup of your data partition now... Then:

Did you try wiping dalvik and /cache from recovery? If you do that, does it boot once trouble free and with the next boot end up in a bootloop again?

(last resort!) What happens if you wipe data?
After many, many tries, I got it to boot. Data wipe wasn't enough. I flashed 5.0.2 firmware and it still wasn't booting. I had to install 5.1.1 firmware, which ism't rootable. I guess I'll give up as I already planned to sell this device (I took it just for the summer holiday)... Thank you anyway :)

Inviato dal mio D5803 utilizzando Tapatalk
 

sydios

Member
Jun 19, 2012
39
1
I can't get into recovery mode. When i try to use NDR Utils or TWRP or Hold the Volum Keys nothing happends. It just shows the Sony Logo and then its frozen. I have to press the on off button together with the volume key to have a reboot. Any Idea how to fix this?
 

[NUT]

Senior Member
I can't get into recovery mode. When i try to use NDR Utils or TWRP or Hold the Volum Keys nothing happends. It just shows the Sony Logo and then its frozen. I have to press the on off button together with the volume key to have a reboot. Any Idea how to fix this?

Installing the correct package can help... you're describing a situation which can be caused by using the wrong package.

Besides that... I'm missing a LOT of info on that post... ROM version? XZDR version? Logs?
 

leso60

Member
Aug 30, 2012
41
7
@[NUT] i was in 23.4.A.0.546 & creat a prerooted version of 23.4.A.1.200 (with flashable 2.8.22) i access recovery but when i make a wipe for clean install and after i apply the prerooted file i have an error (Philz), then i flash a new clean install of 23.1.A.1.28, after rooting & installing the recovery i install the prerooted file this time with TWRP recovery it's work, after applying the rest of firmware exculdin system with flashtool, phone start supersu installed but no R/W access and no access to recovery ( no led at startup, red or green)!!!
 

SirMacke

Senior Member
May 4, 2011
69
23
Hässleholm
Tried to make a Pre-rooted zip to my D5803 with the following:
23.4.A.1.232
BETA SuperSU 2.51
Z3C-lockeddualrecovery2.8.21-RELEASE.flashable

Creating it worked good.
Booted into recovery, flashed.
Now there is no SuperSU, no root and no recovery. (wtf?)

So I want to go back, but how to get the recovery back?
I cannot use the method in this thread.
Recovery will not install or work, do I need root before and how to get that?

==============================================
= =
= PhilZ Touch, CWM and TWRP Dual Recovery =
= Maintained by [NUT] =
= =
= For Many Sony Xperia Devices! =
= =
==============================================

1. Installation on ROM rooted with SuperSU
2. Installation on ROM rooted with SuperUser
3. Installation on unrooted ROM using the TowelRoot method
4. Install ADB drivers to windows
5. Exit

Please choose install action.
[1,2,3,4,5]?3
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Waiting for Device, connect USB cable now...
=============================================
Device found!

=============================================
Getting ro.build.product
=============================================
Device model is D5803
Firmware is 23.4.A.1.232

=============================================
Step2 : Sending the recovery files.
=============================================
0 KB/s (31 bytes in 1.000s)
17 KB/s (18340 bytes in 1.000s)
0 KB/s (501 bytes in 1.000s)
762 KB/s (12198 bytes in 0.015s)
2061 KB/s (65965 bytes in 0.031s)
3 KB/s (3082 bytes in 1.000s)
1824 KB/s (29204 bytes in 0.015s)
84 KB/s (1357 bytes in 0.015s)
1077 KB/s (34473 bytes in 0.031s)
1 KB/s (1202 bytes in 1.000s)
2019 KB/s (96956 bytes in 0.046s)
2260 KB/s (1410852 bytes in 0.609s)
3334 KB/s (3415138 bytes in 1.000s)
2778 KB/s (2311577 bytes in 0.812s)
2238 KB/s (1934768 bytes in 0.843s)
735 KB/s (11760 bytes in 0.015s)

=============================================
Step3 : Setup of dual recovery.
=============================================
=============================================
Attempting to get root access for installation using TowelRoot now.

NOTE: this only works on certain ROM/Kernel versions!

If it fails, please check the development thread (Post #2) on XDA for more detai
ls.

REMEMBER THIS:

XZDualRecovery does NOT install any superuser app!!

You can use one of the recoveries to root your device.
=============================================

=============================================
Sending files
=============================================
110 KB/s (1776 bytes in 0.015s)
13 KB/s (13592 bytes in 1.000s)
2055 KB/s (197320 bytes in 0.093s)
9 KB/s (9496 bytes in 1.000s)
854 KB/s (13672 bytes in 0.015s)
Copying kernel module...
2154 KB/s (34473 bytes in 0.015s)
0 KB/s (765 bytes in 1.000s)
6058 KB/s (96956 bytes in 0.015s)
Kernel version is 3.4.0-perf-g5c87ba0-02008-gbe52486
Version does not match 3.4.0-perf-ge4322cd, needs patching...
dd: conv option disabled
Kernel module patched.

modulecrcpatch (by zxz0O0)

module_layout: patched to 0xCE969278
__aeabi_unwind_cpp_pr1: match
kallsyms_lookup_name: not found
printk: not found
mem_text_write_kernel_word: not found
__aeabi_unwind_cpp_pr0: match

=============================================
Installing using zxz0O0's towelzxperia
(using geohot's towelroot library)
=============================================
error: only position independent executables (PIE) are supported.

=============================================
Installation finished. Enjoy the recoveries!
=============================================

Press any key to continue . . .
 
Last edited:

[NUT]

Senior Member
Tried to make a Pre-rooted zip to my D5803 with the following:
23.4.A.1.232
BETA SuperSU 2.51
Z3C-lockeddualrecovery2.8.21-RELEASE.flashable

Creating it worked good.
Booted into recovery, flashed.
Now there is no SuperSU, no root and no recovery. (wtf?)

So I want to go back, but how to get the recovery back?
I cannot use the method in this thread.
Recovery will not install or work, do I need root before and how to get that?

You should know better then to expect a KitKat exploit to work on Lollipop... really.

Use PRFCreator to create a pre-rooted and recovery included version of that ROM and start over by flashing a rootable ROM first.
 

apollus

Member
Jul 17, 2015
28
5
San Francisco
stuck on "Waiting for device, please connect usb cable" with usb debugging on...

Tried rebooting computer, making sure flashtool was not running, have flashtool drivers, rebooted phone, made sure usb debugging was on.

Any tips?
 

JDC2389

Senior Member
Apr 3, 2011
188
41
Being the only functional recovery everyone flashes I would greatly appreciate support for f2fs added m5 kernel is a godsend and gives us all the goods.
 

arcelo182

Member
Apr 10, 2012
32
0
Yogyakarta
gaklucu.com
Need solution for this problem. :) thanks
Code:
Please choose install action.
[1,2,3,4,5,6]?3
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Waiting for Device, connect USB cable now...
=============================================
Device found!

=============================================
Getting device and ROM info
=============================================
Device model is D5833
Firmware is 23.4.A.1.232
Android version is 5.1.1

=============================================
Step2 : Sending the recovery files.
=============================================
mkdir failed for /data/local/tmp/recovery, File exists
1 KB/s (31 bytes in 0.030s)
1613 KB/s (18170 bytes in 0.011s)
81 KB/s (501 bytes in 0.006s)
1383 KB/s (12754 bytes in 0.009s)
2576 KB/s (65965 bytes in 0.025s)
514 KB/s (3159 bytes in 0.006s)
1677 KB/s (29204 bytes in 0.017s)
136 KB/s (699 bytes in 0.005s)
1771 KB/s (34473 bytes in 0.019s)
195 KB/s (1202 bytes in 0.006s)
2491 KB/s (96956 bytes in 0.038s)
2120 KB/s (870760 bytes in 0.401s)
2100 KB/s (3415844 bytes in 1.588s)
2101 KB/s (2311205 bytes in 1.074s)
1273 KB/s (14346 bytes in 0.011s)

=============================================
Step3 : Setup of dual recovery.
=============================================
=============================================
Attempting to get root access for installation using rootki

NOTE: this only works on certain ROM/Kernel versions!

If it fails, please check the development thread (Post #2)
XDA for more details.


******** REMEMBER THIS: ********


XZDualRecovery does NOT install any superuser app!!

You can use one of the recoveries to root your device.
=============================================
Press any key to continue . . .
* server not running *
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Sending files
=============================================
1204 KB/s (13568 bytes in 0.011s)

=============================================
Installing using cubeundcube's rootkitXperia

Thanks to anyone involved in the development of this exploi

Keen Team, cubeundcube, AndroPlus and zxz0O0
=============================================
ro.build.product=D5833
ro.build.id=23.4.A.1.232
ro.build.version.release=5.1.1
max_fds=4096
Creating target socket...OK.
3072 sockets created.

=============================================
If your device now boots to recovery, reboot
it to system to continue and allow this script
to check and clean up. The script will continue
once your device allows adb connections again.
=============================================

* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Unrooted installation failed, please press 1
once the device finished rebooting to retry.
 
Last edited:

Rhonin86

Senior Member
Nov 17, 2011
1,370
1,313
Hagen
Hi folx,

i need a little hint, so that i don't commit the same error again. I have rooted my phone, installed a prerooted ROM and after that i tried to restore an older backup. So i entered TWRP and searched for the backup, but it was not found. So i thought i have to move the old backup in the new created folder. After moving the backup i could access it and flash it - but after flashing the phone's display stayed black and the phone couldn't be activated :( I think it is hardbricked...

So some assumptions - but i'm not sure, so maybe some of you could explain....

1 - the new repaired phone was somehow different, so TWRP created another folder(name) for the backups. So old backups couldn't be used and shouldn't be used - maybe a different TA - Partition ???
2 - Due to the fact that the bootloader was still locked - the phone should still boot, because the bootloader couldn't be accessed by TWRP. Or did i understand something wrong ???
3 - Is it possible to create another backup on z3c and restore it on another phone ?

THX in advance

Rhonin
 

[NUT]

Senior Member
Need solution for this problem. :) thanks
Code:
[HIDE]Please choose install action.
[1,2,3,4,5,6]?3
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Waiting for Device, connect USB cable now...
=============================================
Device found!

=============================================
Getting device and ROM info
=============================================
Device model is D5833
Firmware is 23.4.A.1.232[/HIDE]
Android version is 5.1.1
[HIDE]
=============================================
Step2 : Sending the recovery files.
=============================================
mkdir failed for /data/local/tmp/recovery, File exists
1 KB/s (31 bytes in 0.030s)
1613 KB/s (18170 bytes in 0.011s)
81 KB/s (501 bytes in 0.006s)
1383 KB/s (12754 bytes in 0.009s)
2576 KB/s (65965 bytes in 0.025s)
514 KB/s (3159 bytes in 0.006s)
1677 KB/s (29204 bytes in 0.017s)
136 KB/s (699 bytes in 0.005s)
1771 KB/s (34473 bytes in 0.019s)
195 KB/s (1202 bytes in 0.006s)
2491 KB/s (96956 bytes in 0.038s)
2120 KB/s (870760 bytes in 0.401s)
2100 KB/s (3415844 bytes in 1.588s)
2101 KB/s (2311205 bytes in 1.074s)
1273 KB/s (14346 bytes in 0.011s)

=============================================
Step3 : Setup of dual recovery.
=============================================
=============================================
Attempting to get root access for installation using rootki

NOTE: this only works on certain ROM/Kernel versions!

If it fails, please check the development thread (Post #2)
XDA for more details.


******** REMEMBER THIS: ********


XZDualRecovery does NOT install any superuser app!!

You can use one of the recoveries to root your device.
=============================================
Press any key to continue . . .
* server not running *
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Sending files
=============================================
1204 KB/s (13568 bytes in 0.011s)

=============================================
Installing using cubeundcube's rootkitXperia

Thanks to anyone involved in the development of this exploi

Keen Team, cubeundcube, AndroPlus and zxz0O0
=============================================
ro.build.product=D5833
ro.build.id=23.4.A.1.232[/HIDE]
ro.build.version.release=5.1.1
[HIDE]max_fds=4096
Creating target socket...OK.
3072 sockets created.

=============================================
If your device now boots to recovery, reboot
it to system to continue and allow this script
to check and clean up. The script will continue
once your device allows adb connections again.
=============================================

* daemon not running. starting it now on port 5037 *
* daemon started successfully *

=============================================
Unrooted installation failed, please press 1
once the device finished rebooting to retry.[/HIDE]

Seriously dude... read the changelog for 2.8.23... :mad:

Hi folx,

i need a little hint, so that i don't commit the same error again. I have rooted my phone, installed a prerooted ROM and after that i tried to restore an older backup. So i entered TWRP and searched for the backup, but it was not found. So i thought i have to move the old backup in the new created folder. After moving the backup i could access it and flash it - but after flashing the phone's display stayed black and the phone couldn't be activated :( I think it is hardbricked...

So some assumptions - but i'm not sure, so maybe some of you could explain....

1 - the new repaired phone was somehow different, so TWRP created another folder(name) for the backups. So old backups couldn't be used and shouldn't be used - maybe a different TA - Partition ???
2 - Due to the fact that the bootloader was still locked - the phone should still boot, because the bootloader couldn't be accessed by TWRP. Or did i understand something wrong ???
3 - Is it possible to create another backup on z3c and restore it on another phone ?

THX in advance

Rhonin

1: the TA is unique to each and every mobile Sony ever sold... if you restored your old phone's TA backup, you now degraded your device to a nice looking but utterly useless paperweight. Unless you have a backup of the original TA from that device, know how to do some JTAGGING and electronic surgery, you can throw it away.
2: TWRP can not access the bootloader, period. I have no idea what you tried to say there.
3: If you hard-bricked it with the TA backup of your previous phone, don't bother.

You know... the fact that the TA does not get included in a backup by default (it's always un-ticked when you try to backup your phone in TWRP) and that the backups are stored in a folder named as your old device's SERIAL NUMBER should have given you a hint to be careful...

Sorry but your head was not in the game for something as tricky as this I guess...
 
Last edited:
  • Like
Reactions: Rhonin86

Rhonin86

Senior Member
Nov 17, 2011
1,370
1,313
Hagen
1: the TA is unique to each and every mobile Sony ever sold... if you restored your old phone's TA backup, you now degraded your device to a nice looking but utterly useless paperweight. Unless you have a backup of the original TA from that device, know how to do some JTAGGING and electronic surgery, you can throw it away.
2: TWRP can not access the bootloader, period. I have no idea what you tried to say there.
3: If you hard-bricked it with the TA backup of your previous phone, don't bother.

You know... the fact that the TA does not get included in a backup by default (it's always un-ticked when you try to backup your phone in TWRP) and that the backups are stored in a folder named as your old device's SERIAL NUMBER should have given you a hint to be careful...

Sorry but your head was not in the game for something as tricky as this I guess...

First THX for your answer - just to sum it up for me:

I made a full backup including TA - assuming i get back the phone i send to SONY i flashed this backup - but as i see by the result they sent me a totally new one... :( So you are right meanwhile i have a shiny brick :eek:
OK so the foldername is a hint for the serial number.... i see i have to learn so much more.... :eek:

just a final question:

If i set my system on my spare Z3c and make a backup of it without TA could i use this backup on my other Z3c ? AFAIR i could do it this way on my older SGS+ and never encountered this problems....

And next time i will switch on my brain with this knowledge in the background

Merry X-Mas

Rhonin
 

[NUT]

Senior Member
First THX for your answer - just to sum it up for me:

I made a full backup including TA - assuming i get back the phone i send to SONY i flashed this backup - but as i see by the result they sent me a totally new one... :( So you are right meanwhile i have a shiny brick :eek:
OK so the foldername is a hint for the serial number.... i see i have to learn so much more.... :eek:

just a final question:

If i set my system on my spare Z3c and make a backup of it without TA could i use this backup on my other Z3c ? AFAIR i could do it this way on my older SGS+ and never encountered this problems....

And next time i will switch on my brain with this knowledge in the background

Merry X-Mas

Rhonin

http://nut.xperia-files.com/html/introduction-to-the-sony-ericsson-xperia-galaxy.html

Read it. It will teach you a lot.

Among basic things to know, also why that what you want to do will not work: your TA restore hard-bricked it. This means the device can no longer boot to anything useful until you fix the TA, which also means that you won't be able to re-flash anything to system.

Hard-bricking your device in Sony's case is truly a end-game type of thing unless you are capable of JTAGGING the board.
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone