ZenFone 2 Z00A(d) ZE551ML - can't boot - black/white screen, no bootloader, want Windows (KVM kernel/OS)

Search This thread


New member
Jan 21, 2023
I recently bought Asus Zenfone, because here in Ukraine is war, so I want small device with Windows (electricity often is off here because rockets fall on our electrric infrastructure etc).
So I've bought Asus Zenfone 2 used (it costed 16,25$). It came without accumulator, and 1/3 screen working. So I went to radio-market to buy new battery, it costed + ~10.25$ + 2,5$ to install battery. Then I've bought new touchscreen for it for ~22,5$, plus payed ~6,25$ to install it. Then around 7,5$ to restore battery connectors (on device and accumulator). So finally it worked, and wanted to see how to install Windows on Zenfone. Sure, if I had possibility to buy anywhere Zenfone better, new, not used, - I'ld do it, but it is not that easily available, just like any other Intel smartphone.

So, I started reading - how to make my device rooted. I don't understand how to get root. I found on wikipedia, that rooting is different from unlocking bootloader, and realized - yes. I need to unlock bootloader, and to boot from external flash-disk and install windows, or at least - new kernel with KVM support. I used pn my Android (non intel) Limbo x86 emulator, it can run some old windows 98 etc, maybe even xp, never win 2000, and if it runs win-7 or win-8 - it is so terribly slow. So I decided to buy Asus Zenfone. As in KVM mode I can send commands to CPU directly, and hope this Windows works much faster than in emulator. I hope just at least to run Windows XP on it, I need to code some C# code, so that Andorid phone is not only for mp3-playing, internet on the go and make calls, but to learn, study and to work. I don't know why Microsot, Intel and other companies don't like Intel CPUs in mobiles. They could do it if they wanted. I like WIndows because most programs are for Windows. And I want desktop x86 windows also on every mobile, intead of all Androids.

Anyway, What I tried to with my Zenfone. I found one amazing experience - that our hero and inspirer (ley God blesses him, maybe he will work in Intel/AMD/Asus/Microsoft etc to make more newer KVM kernels for future x86 phones with windows) - so Ycavan made KVM for Asus Zenfone 2. Great, I've read his thread - https://forum.xda-developers.com/t/...0-with-kvm-bridge-compiled-need-help.3145055/ - completely, with pen and paper writing down important information, downloaded all the files, and decided to start flashing.
I copied them to root of my Zenfone, unpacked tars and converted them into ZIPs. I also unpacked .img files to root of phone (I mean its folder which is visible if I connect it thorught USB, I know it is not "/" root of file system of Andoird, but anyway it is visible even inside CWM... sorry, was visible)...
So, I made some mistakes. I downloaded the kernel, tried to flash it using commands like :
fastboot flash boot boot_fhd_2.19_kvm_bridge_20150710.img
fastboot flash boot boot_fhd_2.19_kvm_bridge_20150714.img
fastboot flash boot boot_fhd_2.19_kvm_bridge_20150717.img
fastboot flash boot boot_fhd_2.20_kvm_bridge_20150820.img
fastboot flash boot boot_2.19_kvm_bridge.img
fastboot flash boot boot_fhd_2.20_kvm_bridge_20150820.img
but non of them produced bootable Zenfone. So I had to revert to previous bootloader using the CWM tool.
In fact I liked this CWM most. I found this thread - https://forum.xda-developers.com/t/...root-ze500-ze550-ze551-temporary-cwm.3114063/
or similar here on forum, and it worked amazingly. I attached Zen-phone to USB, turned it off, then on while pressing, keeping pressed volume-up key, and after Asus logo appeared and some "zzz" vibration, again it blinked and I saw bootloader with Android robot, and possibility to scroll through menu using volume up-down, to choose normal boot, or reboot/power off, or to run restore etc.
For some reason, Restore there not worked. So anyway, I understood that I can use tool like ADB (Android debug bridge) and fastboot to copy new firmwares/kernels/bootloaders etc to it, so I guessed I can do it myself, and was ready for risks... And this what bad can happen - it happened.
So, I runned in CWM - file cai_dat_CWM.bat - which asked to type ACCEPT and then T4, and phone started to go into amazing mode, some "clouds" started appearing on phone, and it loaded into special secret menu, from which I could select what to do next. To me it looked like default boot manager which I wanted to see like in Dos/Windows machines - so I can choose to run into safe mode windows, or set some settings before booting, or even use "reanimator dvd" etc to load Windows and other tools to do partitioning, passwrods recovery etc. So it looked like on desktops, and very nice. I went inside the menu, and found good option to make backup. I did it all. Then in same CWM tool (I think it is called SuperSU for Android), I finally choose to restore bootloader/kernel/boot (custom recovery), and this saved my from bricking the first time after I followed the manual from Ycavan. Well, I know I can read a lot more threads how to do this and that, but there is always risk that something wrong can happen. So I tried to read as much as I could, and follow manuals as precisely as I could understand. But my phone is kind of "bricked".
Now it shows some scfreen like TV which can't catch any tv program. So it is some random colors - see attached picture. It is good that it shows at least this. But in worse situation - it doesn't show anything. So let me tell how I achieved this, and if you can tell me how to avoid this mistake and to recover it. I hope to get help from anyone here who installed KVM kernel(s) and acheieved running Windows on their zenfone 2 (or maybe anyone who has XPerience with other x86 phones may help, or if it is general issue how to unbrick - then also non x86 users please help).
So, CWM made backup, I became more non-scared to make more experiments with firmware. But main problem is that I don't know which firmware to use. I ideally suggested that when I change kernel to KVM-supported from Ycavan - that it will work with my Andorid 5.0 (it was installed when I bought it). So, but unfortunately, after installing any of KVM kernels of Ycavan - I was unable to understand which OS to install, which version. So even I tried to try to flash whole 1GB+ image (I have downloaded UL-Z00A-WW- from official asus.com - https://www.asus.com/ua-ua/supportonly/asus zenfone 2 (ze551ml)/helpdesk_bios/ - but. I was unable to upload it to zenfone (flash it), as it said it is older than installed version.
Anyway, now it doesn't matter as I cannot run into ANdroid at all. Worse - I cannot even get Bootloader working in Android, as I see after turning phone on - only "white screen" with non-working TV-like image (see attached picture of my Zenfone 2).
So, to make this happen, I did this: I found some information about TWRP. I tried to install as recovery tool. Even though it was flashed into mobile, and I installed it from apk from Google-Play, still, I was unable to run it... So then I found even cooler tool - which was too risky to install. I was good, but Andorid stopped running at all.
This tool is called - preroot601. I runned in it preroot.bat, and then it did something similar to CWM, but several times it restartd the phone _ i have added screenshots of how it looked like on PC / Windows. So after several restarts, it did a lot of changes - Android didn't start after it. Phone always was able to start into recovery mode - into TWRP (I downloaded its .img and flased it as recovery for phone). But in TWRP I think I did something wrong. I made backup of all files (syste,, bootloader, everything). I saw it is cool - to see there terminal, ability so set attributes for files, mount partitions ... even USB -hey, can I run from flash-disk? or from external DVD/Bluray which I have in this mode? I have USB-hub, and can connect to it keyboard, mouse, flash-usb, ssd/hdd - all through Microusb-usb adapter and to usb-hub. So what I wanted to do is to try to see flash-disk, mount it on my android zenfone. And then after restart - I had black screen or this 'non-working analog-TV screen when no program/channel/wave is caught for signal"...
So, I don't even understand what I did, and why this all happened, and why I have to do to restore bootloader at least.

My aim is to have KVM enabled in the kernel. I don't mind if it is old Windows like XP working on this Zenfone, but I like windows to be my main OS on every phone which I may use in future (and hope they all be x86-64 and not ARM). So as I don't have Steamdect now (it has also AMD x86 CPU, like Zenfone), I want to do this, achieve it - having Windows on mobile - Zenfone.
I can carry it in pocket everywhere, so why not people like having desktop Windows x86-64 in each and every mobile? Even Lenovo are collaborating with IBM - then why not make also IBM-Mobile / IBM-smartphone, which will also be as good as PC - to unassemble it, change any part like on desktop, why not do it? I think everyone will enjoy it, and it will boost everything to better hights, levels.

So, please. If anyone here has similar experience of going to same screen like I have (see screenshot), or like that - black screen - indeed my device also may not even show any thing - even no ASUS logo, no bootloader (even if I press Volume-UP after powering and after flash it usually showed bootloader with robot - no... not now)...
So I don't see anything on screen of Android Zenfone now. no text, no bootloader, no recovery even - no TWRP menu. I think I am ready to format whole zenfone, and install there maybe some partition manager (like you know there is Partition magic on PCs, when I can split HDD/SSD nto two parts, one for Windows, and say other for Unix - Ubuntu or Android x 86 - all on same physical drive)... So I want some re-partitioning for intern SD memory, and be able to install there some ISOs, say with DOS, Win3.11, win 95, 98, 2000, xp, 7, 8,1 and maybe even 10. But guess last will be slow. I think Windows XP would be ideal OS for my Zenfone, if it can run fast. Win 7/8 maybe will be slow. But for some sceintific aims - like I just write some algorythm in Visual studio, and can do it even in WinXP, so why don't do it on my Zenfone? I don't like many Andorids, as they are not for work much - they are used by many people to play games, watch videos on phones, surf social networks, but not for real work. Real work is usually on WIndows, and no laptop can replace "Windows x86 in pocket" (on mobile). And I wonder why Microsoft develops "Windows for ARM" instead of investing millions into efforts like which Ycavan did - to make Windows run in KVM mode fast on x86 smartphones.

Ok, So, any ideas? What should I do now? I need some special tool to fix my phone first. Fix its loader. I think I need to bypass fastboot.exe restriction, which shows "waiting for device". Command in cmd like this: ADB.exe devices -L --- shows device from time to time - it shows:

c:\adb>adb devices -l
List of devices attached
0123456789ABCDEF device
c:\adb>fastboot flash boot boot_2.19_kvm_bridge.img
< waiting for device >

So, I cannot even flash some recovery device in this way. In devices manager I see "ADB interface" in "USB devices" category in devices treeview. And sometimes Moorefield appears, but with exclaimation mark - I have no idea how to make it disappear. I found here some info that I can install tool - xFSTK_Downloader_v1.7.0.zip - I downloaded it, installe,d but it doesn't run (I have win10 x64bit). hm... And driver required - iSOC_USB_Driver_Setup_v1.2.0.zip - I installed - but nothing.

So, what to do? How to make bootloader appear again? And how to write there prob=per bootloader with KVM kernel, and which firmware to flash so I can use KVM fast there with fast Windows...? Is it possible at all to make it run WIndows natively on Zenfone? or it will always be only in virtual machine inside some ArchLinux or in Limbo x86 on Android?
I read that Ycavan used this ArchLinux, but I don't understand why. Is he installing it over Android? Then also which version he uses? I need to know each and every version whcih he uses to make everything works. I 'ld require all the firmwares which he uses to make it work also - to make some Windows iso run on my Zenfone 2.
Did anyone achieved this successfully, except for Ycavan - to run Windows on Zenfone? Or except for him noone was able to install KVM kernel, and it was similar to mine situation? And maybe this is the reason why manufacturers of phons don't like x86 phones? I don't know. Any ideas?

See screenshots. What to do in this state?
IF anyone can please upload to somewhere whole pack of files ("WIndows on Zenfone starter kit") to make anyone able to just follow instaructions which will work in all cases to install WIndows there like Ycavan has - it would be great. There is lack of more detailed information - which .img files, .zips, firmwares etc, which OSes are supported by Ycavan's KVM kernels?
I have no idea. if anyone passed this path, and achieved Windows on Zenfone, please share your experiences, Ireally need it. Here in Ukraine when electricity disappears almost daily, we need devices like x86 phones almost for everyone. And mo matter if Windows is a bit old. KVM mode I guess must be much faster, almost native speed, so (like on tablet PCs), so please help...

Thank you all in advance, whoever will answer me.


  • IMG_20230121_213346.jpg
    1.3 MB · Views: 9
  • unlocked - with fastboot super-su.png
    unlocked - with fastboot super-su.png
    50.9 KB · Views: 6
  • unlocked - with fastboot super-su2.png
    unlocked - with fastboot super-su2.png
    81.4 KB · Views: 7
  • unlocked - with fastboot super-su3.png
    unlocked - with fastboot super-su3.png
    87 KB · Views: 6
  • device list ADB.PNG
    device list ADB.PNG
    71.8 KB · Views: 7
  • moore2.png
    44 KB · Views: 8


Forum Moderator
Staff member
Feb 17, 2016
c:\adb>adb devices -l
List of devices attached
0123456789ABCDEF device
c:\adb>fastboot flash boot boot_2.19_kvm_bridge.img
< waiting for device >

wrong mode. adb is only working in
- normal/boot mode
- recovery mode

fastboot is only working in
- bootloader mode
- fastboot mode

You can see 0123456789ABCDEF device in adb devices, therefore you are either in TWRP or in Android (Win?)

type adb shell and check the prompt is either $ (shell) or # (root shell)

in root shell you can flash partitions from cmd line. you can also reboot into bootloader/fastboot mode from cmd line.

adb reboot bootloader
Last edited:


New member
Jan 21, 2023
I had success in restoring my bootloader (logo with android robot) - I intalled xFSTK, so somehow I had success to make it run, and I added threee files (1, 2, and 4th) and tried to flash it. Phone was visible as Moorefield. Then I tried to use Asus flash tool to flash big RAW image, but for some reason I don't know why - I had even whole day left it to flash, it didn't do the task - Android stopped booting - no logo showing at all - have to use xFSTK to recover. Maybe I use wrong RAW image (from official site it is .zip, so have no idea where to get those raw files).
When try to flash using flashboot - I get error: - flash cmd error.
As for devices list. My device rarely appear there. It may appear for some seconds, and then xfstk can have success to flash it, and maybe even make it runnable into Android robot scren (bootloader).
I am thinking that I need to install maybe ArchLinux, which Ycavan is using, but have no idea where to get RAW file for it, and how to flash it. Maybe some problem with my USB port on old laptop, or maybe even with USB cable (though have few good almost new cables, even new 4Amperes one). So maybe even problem in port of Zenfone itself (to change it). No idea. Because even when I tried to flash it (that huge 1GB file), phone disconnected, or showed "ready for commands", instead of showing process of ownloading RAW image/Android into phone's memory.

Flashboot/adb almost unusable. Well, I'll try, maybe it'll work.
My hope is try to go into CWM, run from it into "secret menu" on phone, and from it - to access internal memory of phone, and restore phone from backup. But when I tried to load into it once - it hanged on "clouds". I don't know...
And I don't think I'm ready now to format internal memory of phone or to repartition. At least I don't have backup on some external card (sd-card) etc.

as for adb. maybe it can't see my device, even if it is "recovery mode" (when see in devices manager in Windows - Moorefield). Now I'm stuck on xFSTK and can't go anywhere further like adding TWRP into phone, or foing into backup/restore menu on phone, and of course there is no Android. Even when I see Android robot (boot menu) - I feel happy, that at least phone shows anything, so at least bootloader workds. Maybe difference is in drivers - when I have Moorefield driver, then maybe it contradicts with Zenfone driver, and I have to reinstall them? Or use other OS? I have dual-boot (two Windowses on my laptop), so maybe I need to use one Windows - to work with Moorefield (xfstk) - when phone is in "worst" situation when no logo shows / no bootloader. And the other Windows I have to run on laptop - with Zenfone driver installed (I think it shows something like Asus device in device manager). But they seem to use contradicting drivers, I am not sure. And maybe it's some problem with my usb ports, but hope no. They seem to be ok... Maybe I'll have to go some day to give phone for diagnostics to repairing center again ;-(