• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Zenfone 5z camera doesn't work properly

Search This thread

toninoBJT

New member
Feb 26, 2021
2
0
Dear comunity,
I've installed Lineage OS on my Asus Zenfone 5z, but the default camera app seems to can't work with other applications, let me explain better.
If I press the camera icon it works perfectly and I can take photos and videos, but if I am in Signal app or other texting app and I want to share a photo on the fly, I have to press the camera icon on the app that i am using causing that last one to crash. It seems like the most of the apps that I've installed can't find a camera app. Any ideas? I'm very frustrated 😖
Thank you so much.
 

tooth fairy

Member
Nov 14, 2018
11
5
Hi toninoBJT

i have no clue why this happend.
A workaround could be tu use another camera App.

You forgot to mention which Version of LinageOS you are running, but in both LinageOS Threads are recommendations for e.g.
OpenCamera
or
GoogleCamera (GCAM) with links to the APP

Perhaps using one of this will help ?
 

toninoBJT

New member
Feb 26, 2021
2
0
Hi toninoBJT

i have no clue why this happend.
A workaround could be tu use another camera App.

You forgot to mention which Version of LinageOS you are running, but in both LinageOS Threads are recommendations for e.g.
OpenCamera
or
GoogleCamera (GCAM) with links to the APP

Perhaps using one of this will help ?
Hi tooth fairy,
Sorry, I forgot to mention the Version. I've installed LineageOS 18.1 (Android 11), but it seems that there is no possibility to choose the default app for camera. I try to install other camera app, like OpenCamera, but I can't choose to make default one them. (there are no option in settings)
 

ThE_MarD

Senior Member
Dec 10, 2014
2,909
3,434
Grande Prairie
LeEco Le Max 2
Moto X4
Heyyo @toninoBJT , you can remove LOS snap as the default camera app by going into settings > applications > all apps > select LOS snap camera app > Open by default > clear defaults.

lineage-18.1-20210614-nightly-Z01R-signed official build has some camera fixes that should fix the camera to work in all apps. Credits to @Aryaannnn for the fix