ZTE Nubia Z7 Max - Marshmellow "destroys" battery

Search This thread

esp901

New member
Sep 2, 2016
3
0
Hello! Last week I purchased a Z7 Max from Efox. It came with stock Android 6 and worked very good out of the box. But I had to realize, that the battery seems to be VERY poor. Even after a few cycles of loading... What means very poor?: for testing I stopped every app, service, wifi, mobile, gps - all. After 8 hours without doing anything the battery was
35% !! WTF. Who needs a mobile like this.
I found a lot of threads which described the same behaviour after upgrading to Marshmellow with different devices (but found no one complaining the Z7 Max...).

Does anyone else have the same problems and hopefully has solved it?

Thank you in advance - Wolfgang
 

pchatzop

Senior Member
Oct 16, 2015
264
330
There is no stock Android 6.0 rom for the Z7 max as far as I am aware. What is the displayed version in the settings? Last official version is 3.86.
 

Zeggi

Senior Member
Dec 26, 2009
672
279
Stockholm
I have a z7 max which I haven't used for more than 8 months. I just started using it again since unofficial cm13 and Rr are out. The battery life is very poor, I can't remember how it was before but in my case my battery drops from 15% to 1%. When I connect a charger the phone states 5% right away.

I think in my case it's a bad battery but after reading this I'm considering installing latest stock rom for testing.
 

esp901

New member
Sep 2, 2016
3
0
no Solution

Sorry for my late reply to your answers - I was on a trip for a week.

Well - with Android 6 , this was a misreading by me. Sorry. It had 5.1.1 with Software 3.9.6. Now I did a full wipe and "up"grade to 3.8.6. Sadly this had no battery-effect at all. The only progress was, that the bad behaviour at every reboot to update all apps (took about 5-10 Minutes!) is over.
I guess it's a hardware-defect and I will send it back to eFox. Very sad about this - I like this phone really.

Thanks for your replies (sorry for bad english...)
 

oleg77

Senior Member
Feb 2, 2011
65
17
3.9.6 is probably the UI version (User Interface), of the last official firmware :
3.8.6 is indeed the last stock OTA (over the air) firmware update : it's a lollipop (5.1) android update.
So you probably reflashed the same android firmware on the device.