FORUMS
Remove All Ads from XDA

[ROM][T810/T815] AOSP/LineageOS 7.1 Nougat || 2017/01/28

1,122 posts
Thanks Meter: 16,605
 
By RaymanFX, Recognized Developer on 1st September 2016, 11:45 AM
Post Reply Email Thread


LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Bugs/Issues :
  • Audio input volume is low
  • The video buffer will be cropped into weird dimensions when streaming (YouTube, etc)
  • Netflix is broken(?)

Instructions :
  • Download the latest build and gapps
  • Reboot to recovery
  • Flash the latest build and gapps
  • Reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
### RELEASES ###
AOSP
01.09.2016 - SM-T815 / SM-T810
Paranoid Android
29.09.2016 - SM-T815 / SM-T810
CyanogenMod
26.10.2016 - SM-T815 / SM-T810
LineageOS
28.01.2017 - SM-T815 / SM-T810

XDA:DevDB Information
AOSP 7.0 Nougat, ROM for the Samsung Galaxy Tab S2

Contributors
RaymanFX
Source Code: https://github.com/CyanogenMod/android_kernel_samsung_gts2/tree/cm-14.1

ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
Based On: AOSP

Version Information
Status: Testing

Created 2016-09-01
Last Updated 2016-09-01
The Following 31 Users Say Thank You to RaymanFX For This Useful Post: [ View ]
 
 
1st September 2016, 01:11 PM |#2  
Senior Member
Thanks Meter: 166
 
More
you are boss!
I have wifi tab s2, i will test afternoon
1st September 2016, 04:35 PM |#3  
T_I's Avatar
Senior Member
Thanks Meter: 1,262
 
Donate to Me
More
T810 version works.
  • Install image in TWRP
  • reboot to recovery
  • install opengapps (I used pico) and supersu.

Found issues:
  • My SD card is not supported (64 GB, extfat fs) and the device wants to format
  • Google Play services keeps stopping

Camera seems to be working correct. Initial login to google seems to be working, playstore is having issues.
I guess that's to be expected in the first 7.0 android and opengapps boot,
1st September 2016, 05:14 PM |#4  
Senior Member
Thanks Meter: 166
 
More
Chiefs, give me idea where are make mistake on t810. I installed successfully. Then installed pico gapps 7.0 for arm. Got error this gapps are for android 5.1.1, arm 22 if I remember. ROM booted but no google of course.
Give me all steps please
Thanks

Sent from my SM-T810 using XDA-Developers mobile app
1st September 2016, 07:19 PM |#5  
VeEuzUKY's Avatar
Senior Member
Thanks Meter: 112
 
More
I wanna jump on this ROM! But.......
I very want to jump on this ROM and get it tested for feedback and help it developed, but I a major issue..

Can I get this flashed to start with coming from a T-815C that is still running stock 5.01 Lollipop? Believe it or not Samsung is STILL not releasing stock 6.01 for my Hong Kong purchased Tab (version T-815C), only Lollipop updates. Ironically, Hong Kong was one of the very first locations where the Tab S2 line was first available for retail when it was launched and now, they dont even care to get it updated. Even the much older, original Tab S is already getting Marshmallow!!! But the S2 NOT! Subsequently I was told that I cant install Marshmallow CM or ASOP builds on my unit unless I'm already on a stock 6.01 firmware. But how about this 7.0 ROM? Same issue or somehow I can get it flashed directly from 5.01?

I have now reached a point of moral exhaustion with Samsung that is starting to take me to the idea of abandoning the brand forever. I have already had a streak of bad purchases and poor quality issues with several Samsung hardware in the past, and to say their repair centers are basically a waste of time, is an understatement. They do anything possible not to honor any warranties. But now, a current model hardware that doesn't get upgraded at all to a more than 1 year old OS, is starting to be too much for me to take. I bought this Tab under the assumption to immediately get rid of TouchWiz and get an CM or ASOP build in it, ONLY to find out, stupid me, that Samsung neglects completely the hardware they are selling as current models. Its unacceptable. My frustration and disgust at Samsung has reached overboard levels.

Id like to recap and confirm if it is INDEED true that I CAN'T jump into this CM 60.1 ROM unless I am already on Marshmallow? Or is there a workaround and way to do it? The weeks and months are passing by and I go anywhere like this.. just totally stuck.

Anyway, thanks for any advice or ideas on what I can try to do to get my Tab flashed and going with this 7.0 ROM so I can test drive it and give some feedback. There's gotta be away. Thanks again for the input and thumbs up to the developers for this ROM I cant wait to get my hand on
1st September 2016, 07:32 PM |#6  
T_I's Avatar
Senior Member
Thanks Meter: 1,262
 
Donate to Me
More
Quote:
Originally Posted by ivanox1972

Chiefs, give me idea where are make mistake on t810. I installed successfully. Then installed pico gapps 7.0 for arm. Got error this gapps are for android 5.1.1, arm 22 if I remember. ROM booted but no google of course.
Give me all steps please
Thanks

Sent from my SM-T810 using XDA-Developers mobile app

Install image, go back to TWRP main menu, restart to recovery and install gapps.
After that, boot, tap away 'google play services stopped' until you're don and in settings. There give the app 'google play services' every permission it wants and do a 'forced stop' of the application. Then you're ready to go.

I'll check tomorrow which permissions the app really needs, as it wants to much for my taste.

Sent from my T810 running cm-13.0

---------- Post added at 08:32 PM ---------- Previous post was at 08:29 PM ----------

Quote:
Originally Posted by VeEuzUKY

I very want to jump on this ROM and get it tested for feedback and help it developed, but I a major issue..

Can I get this flashed to start with coming from a T-815C that is still running stock 5.01 Lollipop? Believe it or not Samsung is STILL not releasing stock 6.01 for my Hong Kong purchased Tab (version T-815C), only Lollipop updates. Ironically, Hong Kong was one of the very first locations where the Tab S2 line was first available for retail when it was launched and now, they dont even care to get it updated. Even the much older, original Tab S is already getting Marshmallow!!! But the S2 NOT! Subsequently I was told that I cant install Marshmallow CM or ASOP builds on my unit unless I'm already on a stock 6.01 firmware. But how about this 7.0 ROM? Same issue or somehow I can get it flashed directly from 5.01?

I have now reached a point of moral exhaustion with Samsung that is starting to take me to the idea of abandoning the brand forever. I have already had a streak of bad purchases and poor quality issues with several Samsung hardware in the past, and to say their repair centers are basically a waste of time, is an understatement. They do anything possible not to honor any warranties. But now, a current model hardware that doesn't get upgraded at all to a more than 1 year old OS, is starting to be too much for me to take. I bought this Tab under the assumption to immediately get rid of TouchWiz and get an CM or ASOP build in it, ONLY to find out, stupid me, that Samsung neglects completely the hardware they are selling as current models. Its unacceptable. My frustration and disgust at Samsung has reached overboard levels.

Id like to recap and confirm if it is INDEED true that I CAN'T jump into this CM 60.1 ROM unless I am already on Marshmallow? Or is there a workaround and way to do it? The weeks and months are passing by and I go anywhere like this.. just totally stuck.

Anyway, thanks for any advice or ideas on what I can try to do to get my Tab flashed and going with this 7.0 ROM so I can test drive it and give some feedback. There's gotta be away. Thanks again for the input and thumbs up to the developers for this ROM I cant wait to get my hand on

I expect you'll need to flash 'a' 6.0.x stock image. Any one will do, as long as it's for T815.

First make a backup with twrp of current image, then flash stock 6.0.x with odin, then flash this image with twrp, reboot to recovery and install opengapps.

Sent from my T810 running cm-13.0
The Following 2 Users Say Thank You to T_I For This Useful Post: [ View ] Gift T_I Ad-Free
1st September 2016, 07:33 PM |#7  
Senior Member
Thanks Meter: 166
 
More
Quote:
Originally Posted by T_I

Install image, go back to TWRP main menu, restart to recovery and install gapps.
After that, boot, tap away 'google play services stopped' until you're don and in settings. There give the app 'google play services' every permission it wants and do a 'forced stop' of the application. Then you're ready to go.

I'll check tomorrow which permissions the app really needs, as it wants to much for my taste.

Sent from my T810 running cm-13.0

Thanks, boss.
But, how to root? You said youmust root explicitly.
Thanks

Sent from my SM-N920C using XDA-Developers mobile app
1st September 2016, 07:42 PM |#8  
T_I's Avatar
Senior Member
Thanks Meter: 1,262
 
Donate to Me
More
Screenshots...

Main screen


About


SuperSU


Google play service with not enough permissions


Unsupported extfat (sdcard of 64GB, stock formatting), vfat works as I understand it.


Sent from my SM-T810 using Tapatalk

---------- Post added at 08:42 PM ---------- Previous post was at 08:36 PM ----------

Quote:
Originally Posted by ivanox1972

Thanks, boss.
But, how to root? You said youmust root explicitly.
Thanks

Sent from my SM-N920C using XDA-Developers mobile app

I've installed BETA-SuperSU-v2.74-2-20160519174328.zip and when you connect with google play it gets updated.

I'm currently back at cm-13.0, as I have some things to do tonight. I will copy sdcard and reformat to vfat tomorrow to switch, get some extended testing done. Nice to play with it.

Sent from my SM-T810 using Tapatalk
The Following 2 Users Say Thank You to T_I For This Useful Post: [ View ] Gift T_I Ad-Free
1st September 2016, 07:49 PM |#9  
VeEuzUKY's Avatar
Senior Member
Thanks Meter: 112
 
More
Quote:
Originally Posted by T_I

I expect you'll need to flash 'a' 6.0.x stock image. Any one will do, as long as it's for T815.

First make a backup with twrp of current image, then flash stock 6.0.x with odin, then flash this image with twrp, reboot to recovery and install opengapps.

I cant! This is what I just explained! There is NO stock 6.0.x firmware update from Samsung from a Hong Kong T815-C, only Lollipop. Ive tried flash other stock 6.0.x with odin for T815 from other regions, and the flash gets aborted. Will not go it.

What can I do? This is too ridiculous that Samsung doesn't offer a 6.0.x update for a T815C..
1st September 2016, 08:26 PM |#10  
Senior Member
Thanks Meter: 202
 
More
The Play Services nag is irritating but I'll happily put up with it just to be able to try Android 7. Since I installed it, I've spent most of the time loading apps rather than having a chance to test many. I did try both Hulu and Netflix. Netflix works, Hulu doesn't. It get stuck buffering.
edit: I just flashed supersu and that seems to have fixed the Play Service closing problem.
1st September 2016, 09:10 PM |#11  
T_I's Avatar
Senior Member
Thanks Meter: 1,262
 
Donate to Me
More
Quote:
Originally Posted by VeEuzUKY

I cant! This is what I just explained! There is NO stock 6.0.x firmware update from Samsung from a Hong Kong T815-C, only Lollipop. Ive tried flash other stock 6.0.x with odin for T815 from other regions, and the flash gets aborted. Will not go it.

What can I do? This is too ridiculous that Samsung doesn't offer a 6.0.x update for a T815C..

Any stock 6.0.x image will do, as I tried to explain. You need an adjustment in one of the internal device blobs, forgot which one, but wuthout android 6 and higher won't boot. After that you can run cm-13.0 or this image.

I tested T815 cm-13 on my T810 and after a stock flash (EU tab, Canadian stock) it worked. I'm 'officially' stuck at 5 as well, that didn't stop me.

Make a TWRP backup after installing the latest official update and flash. Some experience with odin and twrp is nice, but not required, the manuals are good. When you know someone who did these things before and you're not sure uf you can do it, getting help is useful.

Sent from my SM-T810 using Tapatalk

---------- Post added at 10:10 PM ---------- Previous post was at 10:08 PM ----------

Quote:
Originally Posted by lewmur

The Play Services nag is irritating but I'll happily put up with it just to be able to try Android 7. Since I installed it, I've spent most of the time loading apps rather than having a chance to test many. I did try both Hulu and Netflix. Netflix works, Hulu doesn't. It get stuck buffering.
edit: I just flashed supersu and that seems to have fixed the Play Service closing problem.

Which version supersu are you using and can you check if permissions for google play services are still all off or that all are turned on now.

Sent from my SM-T810 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes