FORUMS
Remove All Ads from XDA

[ROM][UNOFFICIAL][gts4lvwifi][10] LineageOS 17.0

7,375 posts
Thanks Meter: 15,557
 
By LuK1337, Recognized Developer on 24th September 2019, 10:09 PM
Post Reply Email Thread


LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Download the latest build and gapps
  • Reboot to recovery
  • Flash the latest build and gapps
  • Reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
XDA:DevDB Information
[ROM][UNOFFICIAL][gts4lvwifi][10] LineageOS 17.0, ROM for the Samsung Galaxy Tab S5e

Contributors
LuK1337
Source Code: https://github.com/LineageOS

ROM OS Version: Windows 8 Mobile

Version Information
Status: Testing

Created 2019-09-24
Last Updated 2019-09-24
The Following 10 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
25th September 2019, 08:35 AM |#2  
Senior Member
Thanks Meter: 369
 
More
Well.. that was faster than expected. Thank you very much for your dedication.

Which gapps are you currently using or recommending? Opengapps doesn't seem to have gapps for 10 yet.
Also any special instructions for flashing when coming from your previous los16 rom?
25th September 2019, 09:53 AM |#3  
Quote:
Originally Posted by andre0005

Well.. that was faster than expected. Thank you very much for your dedication.

Which gapps are you currently using or recommending? Opengapps doesn't seem to have gapps for 10 yet.
Also any special instructions for flashing when coming from your previous los16 rom?

Apparently https://sourceforge.net/projects/ope...es/arm64/test/ works but setup wizard is crashing. You'd have to remove it manually ^^
The Following 2 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
25th September 2019, 01:28 PM |#4  
Junior Member
Thanks Meter: 4
 
More
I had the opportunity to test the image yesterday as kind of a preview. After killing the setup wizzard, it worked really great. The switch from LOS 16 to 17 was easy.

Rooting had to be done with magisk (current stable was fine) as Luk told me that superSU probably won't work.

I eventually reverted to LOS 16 mainly because of personal discomfort. No Trebuchet, some settings dialogues not (yet) ported and Titanium Backup did not work (there were no buttons displayed - could not even press the problems? button as it was not there ). I personally decided to wait a bit until I will return to LOS 17 on that device.
The Following User Says Thank You to inka$$o For This Useful Post: [ View ] Gift inka$$o Ad-Free
25th September 2019, 01:57 PM |#5  
EugenStanis's Avatar
Senior Member
Flag Warszawa
Thanks Meter: 299
 
More
That was fast. You got me
25th September 2019, 03:33 PM |#6  
Senior Member
Thanks Meter: 369
 
More
Quote:
Originally Posted by inka$$o

I had the opportunity to test the image yesterday as kind of a preview. After killing the setup wizzard, it worked really great. The switch from LOS 16 to 17 was easy.

Rooting had to be done with magisk (current stable was fine) as Luk told me that superSU probably won't work.

I eventually reverted to LOS 16 mainly because of personal discomfort. No Trebuchet, some settings dialogues not (yet) ported and Titanium Backup did not work (there were no buttons displayed - could not even press the problems? button as it was not there ). I personally decided to wait a bit until I will return to LOS 17 on that device.

Did you perform a full wipe before flashing?
Also how did you 'kill' the setup wizard?
25th September 2019, 07:41 PM |#7  
Senior Member
Thanks Meter: 1,113
 
More
There is an issue with twrp decrypting storage on Los 17. Is this more than likely a twrp issue?

I also can't install apps, probably because no access to SD card.
25th September 2019, 07:42 PM |#8  
Quote:
Originally Posted by suzook

There is an issue with twrp decrypting storage on Los 17. Is this more than likely a twrp issue?

TWRP issue.
25th September 2019, 07:45 PM |#9  
Senior Member
Thanks Meter: 1,113
 
More
Quote:
Originally Posted by LuK1337

TWRP issue.

Apps won't install from play store also
Unfortunately I can't download anything, since SD card is encrypted. Guess I will go back to Los 16. Thanks anyway op.
25th September 2019, 07:57 PM |#10  
Quote:
Originally Posted by suzook

Apps won't install from play store also
Unfortunately I can't download anything, since SD card is encrypted. Guess I will go back to Los 16. Thanks anyway op.

>Apps won't install from play store also
Format data; reboot and they should install fine now.
25th September 2019, 08:13 PM |#11  
Senior Member
Thanks Meter: 1,113
 
More
Quote:
Originally Posted by LuK1337

>Apps won't install from play store also
Format data; reboot and they should install fine now.

Will give it a shot.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes