FORUMS
Remove All Ads from XDA

Battery Not Charging...most of the time

481 posts
Thanks Meter: 272
 
By TiTiB, XDA Ad-Free Senior Member on 3rd September 2019, 10:29 PM
Post Reply Email Thread
Posting this in hopes someone has advice—been searching but still nothing that addresses this issue.
Samsung Galaxy Tab S5e (SM-T720)
Rooted with Magisk 19.3 > Manager 7.3.2
Riru - EdXposed v0.4.5.1_beta (4463) (YAHFA)

PROBLEM
The battery is NOT charging (sometimes) even though other monitoring methods show it charging. The system is showing decreasing charge % even though 3C and other apps are showing it charging. The system makes the 'charging sound' when plugging and unplugging.

FYI, I did let the battery 'fully' discharge once—accidently—but that was days ago, and have fully charged it several times since.

HERE'S SOME DETAIL
Battery
- charges when powered off
- charges when rebooted, until screen unlocked
- charges SOMETIMES even after screen unlocked

- multiple apps and system status bar recognize whether or not it's plugged in and indicate charging
--at the same time, Ampere app & Settings > Battery recognize being plugged in, but DIScharging
From these findings it seems to me that it's a 'battery control file' issue. I'm not knowledgeable enough to know the correct terminology, or even if I'm right, but I'm pretty sure (hopeful?) this can be fixed with a few changes to a few files.

Might have to start uninstalling, in order, Xposed Modules > Xposed > Magisk, reflashing ROM but don't want if I don't have to.

Any pointers much appreciated.
6th September 2019, 05:05 AM |#2  
TiTiB's Avatar
OP Senior Member
Thanks Meter: 272
 
More
Magisk Manager 7.3.2 was causing problems. Older *and* newest (7.3.3-a6126c5e) work fine.


Thanks everyone
Post Reply Subscribe to Thread

Tags
battery, battery charge problem

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes