FORUMS
Remove All Ads from XDA

[ROM][UNOFFICIAL][9.0][TB-X704F/L] LineageOS 16.0 for Lenovo Tab4 10 Plus

122 posts
Thanks Meter: 285
 
By yener90, Senior Member on 21st April 2019, 02:36 PM
Post Reply Email Thread


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


What works:
Wifi
Bluetooth
Audio
LED
USB
RIL
Encryption
Fingerprint
Camera
Hall sensor
DT2W
Selinux Enforcing

Broken
nothing

Source code:
device: https://github.com/lenovo-devs/andro..._lenovo_TBX704
device-common: https://github.com/lenovo-devs/andro...novo_tb-common
kernel: https://github.com/lenovo-devs/andro...lenovo_msm8953
vendor: https://github.com/lenovo-devs/propr..._vendor_lenovo

Important
If you are using this ROM first time, wipe data. Wipe data completely. I mean the option where you need to enter "yes". Use this option and then flash the rom.
This ROM only works with the TWRP I added.

If you want to use GAPPS, flash it directly after flashing ROM. Don't let the ROM boot. Otherwise your device will not get certification, so you will not have Google Access.


Instructions (thx @matshias, just changed few lines to get ROM flashing working)
  1. Put your ROM (and GApps) onto your sdcard (sdcard must be exfat or fat32, NTFS not supported)
  2. Install fastboot and adb on your PC, e.g. from here
  3. Enable developer options and in there select to unlock your bootloader by enabling OEM unlock and enable USB debugging
  4. Connect your PC to your tablet and run
    Code:
    adb reboot bootloader
    using adb on command line. The tablet will reboot into bootloader mode where you will only see the Lenovo logo. Now you use
    Code:
    fastboot oem unlock-go
    to unlock. This will factory reset your device
  5. Don't setup, cause you will need to format your tablet later again. Shutdown tablet. Hold volume up and power button to start to bootloader
  6. Then run
    Code:
    fastboot flash recovery twrp-3.2.3-0-<your-filename>.img
    to flash TWRP
  7. Select with volume buttons "Recovery Mode" and press power button
  8. Select to write to system, otherwise you can't flash ROM
  9. Backup at least system and boot partitions to your sdcard cause you will wipe data in next step. Choose "System Image" for the system partition backup.
  10. Format data using this tutorial
  11. Flash ROM
  12. Optionally flash SuperSU or Magisk in TWRP which should install system less. Keep OEM unlock enabled if you flash or modify anything
  13. Restart


Download
2019-07-14
• security patch level: 2019-07-05
ROM
TWRP

Older downloads

2019-06-22 (thx @codeworkx)
• bugfixes and performance improvements
• fix camera detection for ov8856 sensor
ROM

2019-06-09 (thx @codeworkx)
• bugfixes and performance improvements
• set_permissive.zip patch no more required
• TWRP 3.3.0 support
• security patch level: 2019-06-05
ROM

2019-05-14
• fixed sim issue for x704l caused in last update
• fixed a little issue on x704l (should improve battery life)
• added double tap to wake
• latest changes of LineageOS
ROM

2019-05-10
• fixed wifi after fresh installation
• changed scheduler to bfq
• added wireless display broadcast
• improved performance
• removed ril elements from X704F variant
• security patch level: 2019-05-05
ROM
SIM fix for X704L

2019-04-30
• fixed fingerprint bug caused by SELinux
• removed PS3/PS4 controller hid, as it doesn't work
• optimized performance
ROM

2019-04-28
• fixed notifcation led (light was only red for notifications)
• fixed ril values
• added support for PS3/PS4 controller
• SELinux is enforced after boot
ROM

2019-04-24
• fixed hall sensor
• fixed camera
• fixed long time to wake up screen
ROM

2019-04-22
• fixed fingerprint removement after reboot/user switch
• fixed partially camera (same like in 15.1)
• fixed reboot to recovery and bootloader for advanced reboot menu
• fixed long time to wake up screen
• fixed deep sleep
ROM

2019-04-21
• intital release
• TB-X704L is now integrated, no more additional zip required
• You can update from previous version
ROM


Optional downloads
Dolby Digital Plus (use the TWRP one)
GAPPS (use 9.0 arm64; I suggest using pico variant)

Mounting system rw
This is impossible on our tablet. The bootloader enforces verity check, which causes this issue.
The only possibility is to modify bootloader, what is dangerous and requires good knowledge.
there is a workaround using magisk with a mod. which mounts your system rw on mount:
https://forum.xda-developers.com/sho...&postcount=259

Thanks
@highwaystar_ru (he gave me the important hint, also used his sources and his thread )
@LumenReaper (for his work with CM14.1, where I took big part of his device tree )
@Flowah123 for the TB-X704L files

Donations
For donations you can click here
Thanks to @rorzer, @Preyer11, @Tschumi, @MrMagic, @max_work, @vicenza & 5 x anonymous

Please don't support Lenovo and buy their tablets
Code:
Updates vary depending on the model where our tablets receive Android and security updates after the introduction. 
We announced Tab 4 10 Plus in February 2017 and since then it has received seven OTA updates. 
However, this model has reached the end of its update cycle and will not receive any more updates in the future.
- Lenovo (2018-05-11)
Just seven updates and not even one major upgrade, please don't support them.

Reporting bugs
Please tell what mods you are using and what tablet variant (TB-X704F or L or ABCDEFGH..)
If your tablet doesnt start:
go to TWRP. use file manager, go to sys/fs/pstore, copy the files and upload it here.
if your tablet starts and bug appears later:
go to TWRP. use file manager, go to sys/fs/pstore, copy the files
start your tablet normal, let the bug appear, enter adb root
use adb logcat and adb shell dmesg, copy the content to a text file and upload here

XDA:DevDB Information
[ROM][UNOFFICIAL][9.0][TB-X704F/L] LineageOS 16.0 for Lenovo Tab4 10 Plus, ROM for the Lenovo Thinkpad Tablet

Contributors
yener90, codeworkx
ROM OS Version: 9.x Pie

Version Information
Status: Testing

Created 2019-04-21
Last Updated 2019-06-11
The Following 27 Users Say Thank You to yener90 For This Useful Post: [ View ] Gift yener90 Ad-Free
 
 
21st April 2019, 05:15 PM |#2  
Member
Thanks Meter: 105
 
More
Yener, you're amazing. Thanks to you we are on the current Android version. Installation ran without problems. I was so free to attach some screenshots.

What I noticed so far:

- I can confirm the list of things that are working and things that are broken.
- Significantly newer kernel (3.18.138) than LineageOS 15.1 (3.18.115) and of course Nougat (3.18.31).
- Magisk 18.1 works fine (had problems with it under LOS 15.1)
- Waking up the device by pressing the power button or using the fingerprint sensor takes an unusually long time (3-4 seconds). I caught myself several times pressing the button again.

Will you offer a new TWRP 3.3.0?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190421-180045_Settings.png
Views:	1624
Size:	89.8 KB
ID:	4746752   Click image for larger version

Name:	Screenshot_20190421-180059_Settings.png
Views:	1598
Size:	112.0 KB
ID:	4746754   Click image for larger version

Name:	Screenshot_20190421-180015_Trebuchet.jpg
Views:	1672
Size:	183.5 KB
ID:	4746756   Click image for larger version

Name:	Screenshot_20190421-180020_Trebuchet.png
Views:	1632
Size:	211.0 KB
ID:	4746757   Click image for larger version

Name:	Screenshot_20190421-180035_Trebuchet.png
Views:	1600
Size:	167.5 KB
ID:	4746759  
The Following 2 Users Say Thank You to LumenReaper For This Useful Post: [ View ] Gift LumenReaper Ad-Free
21st April 2019, 08:34 PM |#3  
OP Senior Member
Thanks Meter: 285
 
Donate to Me
More
Quote:
Originally Posted by LumenReaper

- Waking up the device by pressing the power button or using the fingerprint sensor takes an unusually long time (3-4 seconds). I caught myself several times pressing the button again.

Wiil be fixed tomorrow release. It has the same bugs like the little older brother:
  • Fixed reboot to recovery and bootloader from reboot menu
  • Fixed long time to wake up screen
  • Fixed Deep sleep
Also there is an issue with fingerprint. After restart it doesn't work anymore. This will be also fixed.

Quote:
Originally Posted by LumenReaper

- The release is an engineering build. @yener90 isn't it common to release userdebug?

Everything is normal, I don't know, why it is like that

Quote:
Originally Posted by LumenReaper

Will you offer a new TWRP 3.3.0?

I'm not planning to change something on TWRP currently.
The Following 4 Users Say Thank You to yener90 For This Useful Post: [ View ] Gift yener90 Ad-Free
22nd April 2019, 09:35 AM |#4  
Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by yener90

Wiil be fixed tomorrow release. It has the same bugs like the little older brother:

  • Fixed reboot to recovery and bootloader from reboot menu
  • Fixed long time to wake up screen
  • Fixed Deep sleep
Also there is an issue with fingerprint. After restart it doesn't work anymore. This will be also fixed.

Okay, thank you very much. I can also confirm the problem with the fingerprint scanner, it occurs not only after a reboot, but also when you switch between two users.

Quote:
Originally Posted by yener90

Everything is normal, I don't know, why it is like that

Maybe I can help here: You will get an engineering build if you run lunch lineage_TBX704-eng. If you run lunch lineage_TBX704-userdebug instead, you will get a userdebug build.
The Following User Says Thank You to LumenReaper For This Useful Post: [ View ] Gift LumenReaper Ad-Free
22nd April 2019, 10:00 AM |#5  
OP Senior Member
Thanks Meter: 285
 
Donate to Me
More
Quote:
Originally Posted by LumenReaper

Okay, thank you very much. I can also confirm the problem with the fingerprint scanner, it occurs not only after a reboot, but also when you switch between two users.

Same bug, will be also fixed.

Quote:
Originally Posted by LumenReaper

Maybe I can help here: You will get an engineering build if you run lunch lineage_TBX704-eng. If you run lunch lineage_TBX704-userdebug instead, you will get a userdebug build.

I didn't change anything How do you come to this conclusion? in Device Info HW App its listed as userdebug build
The Following 2 Users Say Thank You to yener90 For This Useful Post: [ View ] Gift yener90 Ad-Free
22nd April 2019, 10:25 AM |#6  
Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by yener90

I didn't change anything How do you come to this conclusion? in Device Info HW App its listed as userdebug build

Forget it, my mistake. I should read more carefully.
The Following User Says Thank You to LumenReaper For This Useful Post: [ View ] Gift LumenReaper Ad-Free
22nd April 2019, 02:15 PM |#7  
OP Senior Member
Thanks Meter: 285
 
Donate to Me
More
Update
2019-04-22
• fixed fingerprint removement after reboot/user switch
• fixed partially camera (same like in 15.1)
• fixed reboot to recovery and bootloader for advanced reboot menu
• fixed long time to wake up screen
• fixed deep sleep
ROM
The Following 7 Users Say Thank You to yener90 For This Useful Post: [ View ] Gift yener90 Ad-Free
22nd April 2019, 06:48 PM |#8  
Member
Thanks Meter: 4
 
More
I'm impressed!
22nd April 2019, 07:06 PM |#9  
Senior Member
Thanks Meter: 270
 
More
Nice update @yener90, thank you very much.

Now, here's a good one, dirty flashed the V9 over your V8 and then flashed Gapps and Magisk19.
All went well and I was impressed with how well the tablet ran and its stability, a few apps needed updating and then I used the tablet for about 2 hours or so, no problems whatsoever.
So I did a backup and rebooted, now the tablet powers off after approx 30secs. or so displaying the 'powering off' notification but instead of actually powering off it reboots to TWRP.
I have wiped Dalvik and cache but to no avail.
I used your TWRP to flash the ROM and use the original TWRP to create the backups/restorations to/from Ext SD . TB-X704V (L)

Any ideas please, as it was running very well prior to doing a backup ?

TIA.
22nd April 2019, 07:50 PM |#10  
Junior Member
Thanks Meter: 4
 
More
thanks yener
flashed it 5min ago and looking for something not working but so far, it runs nice
The Following User Says Thank You to Preyer11 For This Useful Post: [ View ] Gift Preyer11 Ad-Free
22nd April 2019, 07:57 PM |#11  
OP Senior Member
Thanks Meter: 285
 
Donate to Me
More
Quote:
Originally Posted by Sparkrite

Nice update @yener90, thank you very much.

Now, here's a good one, dirty flashed the V9 over your V8 and then flashed Gapps and Magisk19.
All went well and I was impressed with how well the tablet ran and its stability, a few apps needed updating and then I used the tablet for about 2 hours or so, no problems whatsoever.
So I did a backup and rebooted, now the tablet powers off after approx 30secs. or so displaying the 'powering off' notification but instead of actually powering off it reboots to TWRP.
I have wiped Dalvik and cache but to no avail.
I used your TWRP to flash the ROM and use the original TWRP to create the backups/restorations to/from Ext SD . TB-X704V (L)

Any ideas please, as it was running very well prior to doing a backup ?

TIA.

I'm suprised that it even starts. I really don't know. Maybe encryption got broken or filesystem error.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes