FORUMS
Remove All Ads from XDA

[ROOT METHOD] 2018 Updated Stock firmware

n/a posts
Thanks Meter: 0
 
By TheVampkid, Guest on 23rd April 2018, 02:37 PM
Post Reply Email Thread


Hello all, I have been driving myself mad all night trying to root my friends phone because it's close to unusable today. I figured I give him root to help with battery and memory.
All the root methods listed in this forum technically will work but only with a custom ROM which will very likely require a custom kernel and bootloader.

Today I save your time and sanity with the latest and greatest in root technology. MAGISK.

==============================================
Files
--------
Stock G900T ROM (For if you mess up)
Compatible TWRP
Odin
Official Magisk Thread - Grab the zip

==============================================
Guide
--------
I ran into some weird behavior during this so be sure to read carefully and follow everything word for word.

1. Preparation:
- Put magisk zip on an sd card or internal storage of the phone
- Ensure drivers are installed. Open Odin and put device in Download mode. (Hold power, volume down and home until you arrive at the download mode screen), Plugin the phone and make sure you see "added"
- If you don't see the added dialogue install the proper drivers for the phone.
- If you see added, you can move on.

2. Flash TWRP:
- In the options tab make sure only F. Reset time is checked.
- Select the box AP and navigate to the TWRP tar.md5 file, the UI will stop responding for a minute while it calculates and checks the md5 hash to authenticate it.
- Then hit start, wait until the box says PASS. If you forgot to uncheck reboot, quickly put the device into recovery mode. (Holding power, volume up and the home button)
- If the phone is still in download mode just put it in recovery mode, and allow TWRP to modify.

3. Flash Magisk
- Don't worry here, Magisk is systemless and if something goes wrong there are no consequences. Go to install and navigate to magisk zip file.
- Swipe to flash it.

4. Check. Make sure root works. Use a root check app like the one by JRummyapps.
- grab a couple apps that require root and test them, make sure magisk can give root perms.
- There's a possibility that Magisk's app wasn't installed correctly. You can extract the zip to get the APK file from inside and install it manually.
- If magisk manager is installed, and you can't seem to get the superuser perms, install SuperSU, and install the supersu binary via TWRP/CWM
- You can now choose which super user you want.

5a SuperSU
- Uninstall Magisk by going to the app and hitting install, count to 5 then reboot.
- Go back to SuperSU and install the binary again via TWRP.
- You should now have root.

5b Magisk
- Uninstall SuperSU my removing the app.
- Test a root needing app if it doesn't work, reboot to recovery and reflash magisk, then reboot to android, and test again, you should have root.
The Following User Says Thank You to TheVampkid For This Useful Post: [ View ] Gift TheVampkid Ad-Free
 
 
25th April 2018, 06:11 PM |#2  
Senior Member
OKC
Thanks Meter: 16
 
Donate to Me
More
worked for me.

no need to download a root checker app if your on stock since samsung tells you its rooted and how bad it is for your phone.

i used adb for most so i got a su shell and confirmed that way too.
The Following 2 Users Say Thank You to thegreatkazoo For This Useful Post: [ View ] Gift thegreatkazoo Ad-Free
31st May 2018, 05:11 AM |#3  
Senior Member
Flag San Antonio
Thanks Meter: 80
 
More
Google's "uncertified device" scheme is driving me mad!
Good job, Vamp!

Were you able to determine if the method that you described resolved the Google "uncertified device" problem? Also, does it bypass Google SafetyNet?

The Google's "uncertified device" scheme is driving me mad. I went through several cycles of installing stock Play Services and Play Store. Each time I would immediately re-gain access to Play Store and the gremlins in my phone would immediately disappear. (Gremlins such as "Running Applications" app and widget becoming intermittant, Total Recall recorder not responding to incoming calls, "Android Services" (with the fanbelt and pulley icon) increasing to 30-40% CPU utilization, etc.) In the meantime, some apps (notably in my case "NOAA Weather" app, which I have subsequently come to believe must be a Google shill) would complain about not being able to work without updating Play Services. I had to update Play Services to avoid the pop-ups. But doing that appears to be a final nail in the coffin. Soon after, symptoms reappear and it becomes increasingly difficult to get into the Play Store by reverting to old Playstore/Play Services versions.

Finally I finally white-listed my SuperSu rooted S5 stock MM on Google's "ROM developer" white-list website. In a twinkling of an eye, Google obviously "flipped the switch" for my phone and I had immediate access to Play Store. I then began locking down the same misbehaving apps as always by freezing with Ti and blocking Internet access with Netguard. As I did each lockdown step, I made sure that I could open Play Store and see my apps. After finishing, I assumed that all was well, as I could still see my apps in Play Store.

Not to be... After the passage of a few hours or less, enough time for the Play Store app, the tweaked Google Services, and whatever installed apps are tightly integrated with Play Services and are reporting the phone state back to Google (e.g., the NOAA Weather app) provide enough information back to Google, another switch appears to gets flipped. The phone again enters the same chaotic state described above, finally sutting down from thermal overload caused by "Android System" swallowing up an enormous quantity of CPU cycles.

Thus it appears to me (after much experimentation) that the new Play Services (12.6.75 and then 12.6.85) appear to enforce or re-enforce the "SafetyNet" scam. It appears that Google may be scrambling to get the lockdown tweaked without burning customers' batteries too much, as they seem to be updating Play Services at an alarming rate.

Peeking at some of the Google Services databases at /data/data/com.google.android.gms/databases using SqLite is enough to make the devil blush; and those likely to be most incriminating are encrypted. For the latter, only their structure and key field identifiers are visible, not the data. NOAA Weather appears by itself in one of the visible databases. I stored away a TWRP image of the entire phone in this state in a safe place should I need to prove up this nightmare in the future.

The bottom line is that I bought an $850 phone several years ago with an OS (subsequently force-updated to Marshmallow) and a set of Google system apps, in a technical and legal environment that did not exclude customizing my phone or the use of privacy tools such as Ti and Netguard. Now Google appears to be intruding physically into my phone in order to suck out data (even though sync is off) and change my settings ("sync data" continues to get re-enabled as does "auto-update" in the Play Store). And, (at least as it appears tentatively) software (probably the new Play Services) is being planted that could eventually phsically destroy my phone by causing too many thermal overload shutdowns.

I am seriously hacked, both literally and emotionally!
31st May 2018, 07:58 AM |#4  
Senior Member
Flag San Antonio
Thanks Meter: 80
 
More
A Bit Confused...
Your heading says: "[ROOT METHOD] 2018 Updated Stock firmware."

But then you say:
"All the root methods listed in this forum technically will work but only with a custom ROM which will very likely require a custom kernel and bootloader."

It is unclear whether by "in this forum" you mean in the T-Mobile Galaxy S5 Android Development forum or in your thread.

So, were you successful with installing Magisk on TMO Galaxy S5 (SM-G900T) with stock ROM? If so, which version of Android? Stock Marshmallow 6.0.1 per chance?

Thanks!
7th July 2018, 01:37 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Stock ROM is the latest 6.01.

USA (T-Mobile)
2017-04-02
Version
PDA
6.0.1
G900TUVU1GQC2
CSC
18th September 2018, 07:30 PM |#6  
gmolds's Avatar
Senior Member
Thanks Meter: 22
 
More
So... going to this from LOS 15.1 would this be the order:


  1. Backup (if that's the way you roll)
  2. ODIN the latest stock firmware (GQC2 2017 from TMO)
  3. Reboot and let it get into the system for the initial party time
  4. Follow the steps in the OP
Is that about it?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes