FORUMS
Remove All Ads from XDA

Text Messaging with Google Home and AutoVoice

3,258 posts
Thanks Meter: 4,987
 
By muniz_ri, Senior Member on 16th December 2017, 01:39 AM
Post Reply Email Thread
After following the process below you will be able to start a natural language dialog with Google Home or Google Mini to send text messages to any contact (see video demo).

***Updated 1/1/2018*** Added troubleshooting section below to address the issue where AutoVoice ends the dialog prematurely. Also, added Step 7 to Part 3 of the instructions to make certain that, once the setup is complete, Tasker is synced with Dialogflow.com.

Video Demo
Learn more about AutoVoice here.

Requirements:
- Tasker
- AutoVoice BETA (Full Paid Version + Monthly Subscription to Natural Language feature $.99/month)
- AutoContacts BETA

Part 1.
1. Download and install the Tasker, AutoVoice BETA, and AutoContacts BETA apps. Also download the AutoVoice_Text_Messaging.prf.xml and AutoVoice.zip.

Part 2.
1. Go to Dialogflow.com and sign up for free using the same Google account used for your Google Home.
2. Click on "Create Agent."
3. Enter the Agent Name as AutoVoice and click on "Create."
4. Once the agent is created click on the gear icon in the top left corner then go to the "Export and Import" tab.
5. Select "Restore Zip" and restore the AutoVoice.zip file from Step 1.
6. Take note of the "Client access token" and the "Developer access token." You will make use of this info in the next step.

***Make Certain that you have received the AutoVoice and AutoContacts BETA updates from the Play Store before continuing!***

Part 3.
1. Open the AutoVoice app and grant all permissions.
2. From the main menu select "Natural Language" then "Setup Natural Language." Next, insert the Client access and Developer access tokens from Dialogflow.com and press "Accept."
3. From the apps Natural Language menu select "Commands" and toggle On the "Use For Google Assistant/Alexa" toggle switch. Log-in using your Google account when prompted and set-up your subscription for the Natural Language feature. Back out to exit AutoVoice.
4. Link Google Home to AutoVoice. See video: https://youtu.be/KaCQMjPllno

5. Open AutoContacts, grant all permissions and allow it to load your contacts (I recommend that you upgrade to the full, paid version or you will only have access to a limited number of contacts).

6. Next, place the AutoVoice_Text_Messaging.prf.xml file from Step 1 into the Tasker/profiles folder (if these folders do not exist then create them). Open Tasker, long-press "Profiles," select "Import," then import the xml file. Back-out of Tasker to save the profile.

7. Open the AutoVoice app again, go to "Natural Language," select "Commands," then toggle the "Use For Google Assistant/Alexa" toggle switch off and on in order to sync Tasker with Dialogflow.com.

Last, create the following shortcut in the Home app. To begin the text messaging dialog say "Ok Google, send a message." Or, you can also say "Ok Google, ask AutoVoice to send a message." Enjoy!

Troubleshooting:
- Users are reporting that AutoVoice may end the dialog prematurely. If that happens open the AutoVoice app, select "Natural Language" then "Commands." Select the applicable command where the dialog ends prematurely and select "Toggle Finish Assistant Conversation." Note: the only command that should finish the conversation is "answer-send."
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20171215-164932.png
Views:	544
Size:	70.7 KB
ID:	4361723  
 
 
26th December 2017, 03:56 AM |#2  
arbyn's Avatar
Member
Flag Anoka
Thanks Meter: 3
 
More
So I set this all up and it seems to work. But how do I phrase the text of the message and assign it to a contact?
After I say "Hey google send a message" Google Home replies with "Sure heres autovice", then autovice says "command sent send a message"
26th December 2017, 05:38 AM |#3  
OP Senior Member
Thanks Meter: 4,987
 
Donate to Me
More
Quote:
Originally Posted by arbyn

So I set this all up and it seems to work. But how do I phrase the text of the message and assign it to a contact?
After I say "Hey google send a message" Google Home replies with "Sure heres autovice", then autovice says "command sent send a message"

It sounds like AutoVoice is not recognizing the Dialogflow agent. Try opening the AutoVoice app, select Natural Language, then Commands, then toggle off and on the "Use for Google Assistant/Alexa" toggle switch. That should solve it.
29th December 2017, 06:17 AM |#4  
arbyn's Avatar
Member
Flag Anoka
Thanks Meter: 3
 
More
Quote:
Originally Posted by muniz_ri

It sounds like AutoVoice is not recognizing the Dialogflow agent. Try opening the AutoVoice app, select Natural Language, then Commands, then toggle off and on the "Use for Google Assistant/Alexa" toggle switch. That should solve it.

Tried that still the same result. WTH
29th December 2017, 09:16 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Google home mini stop to repond at the end of task
Thanks for this profile. Google home mini is responding up to the command, what should i message. Then it is dead. I have tried several times but got stuck in that step. If it works then it is great.
Thank you
29th December 2017, 04:59 PM |#6  
Junior Member
Flag Lincoln Park
Thanks Meter: 0
 
Donate to Me
More
Not Able To Get It Working
I have set everything up and checked several times and I have 2 problems. I have signed up to be a beta tester with autocontacts and am not getting the beta version update. The second problem is that I have a message on my phone that says " Tasker no active profiles" Thanks
29th December 2017, 05:00 PM |#7  
OP Senior Member
Thanks Meter: 4,987
 
Donate to Me
More
Quote:
Originally Posted by BirdmanMorin

I have set everything up and checked several times and I have 2 problems. I have signed up to be a beta tester with autocontacts and am not getting the beta version update. The second problem is that I have a message on my phone that says " Tasker no active profiles" Thanks

The BETA versions are a must or it will not work. Send an email to the AutoContact dev. He is very responsive.
29th December 2017, 05:01 PM |#8  
OP Senior Member
Thanks Meter: 4,987
 
Donate to Me
More
Quote:
Originally Posted by BirdmanMorin

I have set everything up and checked several times and I have 2 problems. I have signed up to be a beta tester with autocontacts and am not getting the beta version update. The second problem is that I have a message on my phone that says " Tasker no active profiles" Thanks

Did you receive and install the BETA version updates of the Auto apps?
29th December 2017, 05:43 PM |#9  
Junior Member
Flag Lincoln Park
Thanks Meter: 0
 
Donate to Me
More
Am not getting beta version update
Quote:
Originally Posted by muniz_ri

Did you receive and install the BETA version updates of the Auto apps?

I stated that I am not getting the update for the beta version. I don't know why
29th December 2017, 05:47 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Google home mini stop to repond at the mid of task
Google home mini is responding up to the command, what should i message. Then it is stops responding. I have tried several times but got stuck in that step. I tested in dialogflow api site, everything is fine. Not able to solve.
29th December 2017, 10:32 PM |#11  
OP Senior Member
Thanks Meter: 4,987
 
Donate to Me
More
Quote:
Originally Posted by BirdmanMorin

I stated that I am not getting the update for the beta version. I don't know why

Sorry, I was rushing through the forum while at work. Suggest you post a note to the AutoApp's Dev hear. He is very helpful: https://plus.google.com/u/0/communit...99489813640793
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes