FORUMS
Remove All Ads from XDA

[RECOVERY][IME][20.05.2019][OFFICIAL] TWRP 3.3.1-0 for HTC U12+ aka Imagine

4,211 posts
Thanks Meter: 12,100
 
By Freak07, Senior Member on 21st July 2018, 01:26 PM
Post Reply Email Thread
Announcement from Freak07: TWRP is now official for the U12+! Get the official download from twrp.me!
22nd July 2018, 02:35 AM |#11  
Senior Member
Flag NYC
Thanks Meter: 19
 
More
Quote:
Originally Posted by umaranjum

Might be a stupid question but did you try booting in fastboot? AFAIK it only works in fastboot

Not the person you replied to, but since I have the same problem, I followed the steps in OP, and since it's only 2 steps, I'm sure the other person performed the "adb reboot bootloader" step.
22nd July 2018, 03:27 AM |#12  
Member
Thanks Meter: 3
 
More
Ah, Ok. Interesting, it worked the first time for me, have you tried redownloading the TWRP img and trying it again? If so, then it may be a problem specific to your device, in which case @Freak07 should be able to help you out better

---------- Post added at 02:27 AM ---------- Previous post was at 02:25 AM ----------

Quote:
Originally Posted by k_l_o

Not the person you replied to, but since I have the same problem, I followed the steps in OP, and since it's only 2 steps, I'm sure the other person performed the "adb reboot bootloader" step.

Ah, yes, I forgot about that lol. I do apologise, I'm quite tired. If it still doesn't work after redownloading then you'll need to wait for @Freak07 to help you out, as I mentioned above. Apologies that I couldn't be of more help and I hope you two manage to get it working
22nd July 2018, 05:17 AM |#13  
Freak07's Avatar
OP Senior Member
Thanks Meter: 12,100
 
More
Quote:
Originally Posted by k_l_o

@Freak07

Followed your instructions, but hangs at downloading 'boot.img' after second step: "fastboot boot TWRP_3.2.2.0_Imagine.img"

I'm Unlocked and Rooted with Magisk.

Do you also get the same
FAILED: unknown command
as @schmeggy929?


Quote:
Originally Posted by schmeggy929

same here
fastboot boot TWRP.img
downloading...
FAILED: unknown command

To both of you.

Try both bootloader and download mode for booting. Although only bootloader should work for booting.

Make sure you have the latest fastboot and adb drivers!

Try different usb ports.

What happens if you try to fastboot boot a stock boot.img?
22nd July 2018, 05:39 AM |#14  
Senior Member
Flag Taipei
Thanks Meter: 80
 
More
Thanks @Freak07, @Captain_Throwback. TWRP_3.2.2.0_Imagine.img is worked.

product: htc_imedugl
current-slot: a
version-main: 1.15.709.6
Attached Thumbnails
Click image for larger version

Name:	072201.jpg
Views:	402
Size:	40.2 KB
ID:	4555204   Click image for larger version

Name:	IMAG1024.jpg
Views:	406
Size:	267.9 KB
ID:	4555205   Click image for larger version

Name:	IMAG1026.jpg
Views:	386
Size:	283.6 KB
ID:	4555206  
Attached Files
File Type: log recovery.log - [Click for QR Code] (23.1 KB, 4 views)
The Following User Says Thank You to nenebear For This Useful Post: [ View ] Gift nenebear Ad-Free
22nd July 2018, 06:32 AM |#15  
Senior Member
Flag Adelaide
Thanks Meter: 185
 
More
Great news! Thanks everyone for your hard efforts! Get my U12 at the end of the month so looking forward to flashing. Hopefully Lee will have a nice ROM for us by then too
22nd July 2018, 03:30 PM |#16  
Senior Member
Flag NYC
Thanks Meter: 19
 
More
Quote:
Originally Posted by Freak07

Do you also get the same
FAILED: unknown command
as @schmeggy929?




To both of you.

Try both bootloader and download mode for booting. Although only bootloader should work for booting.

Make sure you have the latest fastboot and adb drivers!

Try different usb ports.

What happens if you try to fastboot boot a stock boot.img?

I get a "FAILED (status read failed (Too many links))

Does it matter that I've Magisk already installed which required a patched_boot.img?
22nd July 2018, 03:31 PM |#17  
schmeggy929's Avatar
Recognized Themer
Flag New Jersey
Thanks Meter: 1,918
 
Donate to Me
More
Quote:
Originally Posted by Freak07

Do you also get the same
FAILED: unknown command
as @schmeggy929?




To both of you.

Try both bootloader and download mode for booting. Although only bootloader should work for booting.

Make sure you have the latest fastboot and adb drivers!

Try different usb ports.

What happens if you try to fastboot boot a stock boot.img?

Tried all available USB ports, two different cables. Where do I get a stock boot img for US Unlocked? Also while in bootloader, the only command that works is "fastboot reboot bootloader". "Fastboot reboot" and "fastboot reboot download" does nothing.
22nd July 2018, 03:39 PM |#18  
Freak07's Avatar
OP Senior Member
Thanks Meter: 12,100
 
More
Quote:
Originally Posted by k_l_o

I get a "FAILED (status read failed (Too many links))

Does it matter that I've Magisk already installed which required a patched_boot.img?

Could you please post everything from your terminal?

And update the fastboot and adb binaries with the one from the following link for your current OS beforehand

https://www.xda-developers.com/googl...ary-downloads/

No it doesn’t matter I did the same.
22nd July 2018, 03:41 PM |#19  
Freak07's Avatar
OP Senior Member
Thanks Meter: 12,100
 
More
Quote:
Originally Posted by schmeggy929

Tried all available USB ports, two different cables. Where do I get a stock boot img for US Unlocked? Also while in bootloader, the only command that works is "fastboot reboot bootloader". "Fastboot reboot" and "fastboot reboot download" does nothing.

You can extract it from the US firmware zip linked in the firmware thread.

Is fastboot devices showing your device?

Did you update your fastboot and adb binaries to the ones found here for your OS?

https://www.xda-developers.com/googl...ary-downloads/
22nd July 2018, 04:14 PM |#20  
schmeggy929's Avatar
Recognized Themer
Flag New Jersey
Thanks Meter: 1,918
 
Donate to Me
More
Quote:
Originally Posted by Freak07

You can extract it from the US firmware zip linked in the firmware thread.

Is fastboot devices showing your device?

Did you update your fastboot and adb binaries to the ones found here for your OS?

https://www.xda-developers.com/googl...ary-downloads/

Low and behold after updating the binaries twice and redownloading TWRP.img for the third time, it finally booted to TWRP. Cancelled decrypt and kept "Read Only". Flashed your Kernel successfully except for preload error due to not mounted. Rebooted and everything seems good, shows Kirisakura_1.0.
Thanks for the help!
The Following User Says Thank You to schmeggy929 For This Useful Post: [ View ] Gift schmeggy929 Ad-Free
22nd July 2018, 04:37 PM |#21  
Senior Member
Flag NYC
Thanks Meter: 19
 
More
Quote:
Originally Posted by Freak07

Could you please post everything from your terminal?

And update the fastboot and adb binaries with the one from the following link for your current OS beforehand

https://www.xda-developers.com/googl...ary-downloads/

No it doesn’t matter I did the same.

I downloaded the SDK tools and it updated my adb + fastboot, from what I can tell, and now I have a different result. I attached a screenshot.
Attached Thumbnails
Click image for larger version

Name:	Terminal.GIF
Views:	586
Size:	455.9 KB
ID:	4555525  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes