FORUMS
Remove All Ads from XDA

Soft bricked my G2. Can enter TWRP but flashed ROMs won't boot up

107 posts
Thanks Meter: 5
 
By nookin, Senior Member on 16th November 2015, 12:00 AM
Post Reply Email Thread
I ran into a strange problem. I was experimenting between 2 ROMs (T-Mobile 30b Extreme and xdabbeb's VS980 3.12). I have TWRP installed and I had successfully tried both ROM (Stock 39A Rooted -> T-Mobile 30b Extreme -> xdabbed -> T-Mobile 30b Extreme).

But then, I went into TWRP recovery and decided to wipe it clean (Advanced, wiped all partitions including system and Internal Storage) and flash again, something bad happened. The phone will not finish booting.

The phone will boot up with the standard LG logo for about a minute. Then boot into an animated, bigger LG Logo. And then it will stuck there forever. Normally, it should go into something like "initializing... 1 out of 130".

I can still enter TWRP recovery and browse the file system and even flash another ROM from OTG-USB. But none of the ROM would boot beyond the initial boot screen. Any ideas?

Edit: It seems my issue is covered here:

https://www.reddit.com/r/lgg2/commen...orage_in_twrp/

I had 39A and really don't want to go back to square one if I have a choice. What exactly is the Internal Storage and why even having TWRP cannot help me recover?
 
 
16th November 2015, 05:30 PM |#2  
OP Senior Member
Thanks Meter: 5
 
More
Answering my own question.

Yes, there is a better solution. The solution is even under the same page as "Wipe" of TWRP. It is called "Format Data". I suspect that either the entire partition for internal storage is removed or some important file is missing. "Format Data" restores it. I'm back to where I was. I can't believe no one from reddit mentioned this.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes