Remove All Ads from XDA

[GUIDE] GEAR 2 + CM 11 4.4.4 on Dev S5

20 posts
Thanks Meter: 1
Post Reply Email Thread
GEAR 2 + CM 11 4.4.4 on Dev S5
Note: I have done this 4 times and this has worked 4 times

VZ Samsung S5 Dev. Ed.
CM11 4.4.4: Rom file that I used was cm-11-20140831-UNOFFICIAL-klte
Recovery: vle twrp v2.8.0.1

( For some reason my twrp backups dont work can someone help me out please)
Note: This is the only method. I tried everything else. I also tried this on lollipop roms but none of them worked (also receiving text messages and dial pad doesn't work for me while in a call aka inputting voicemail password)

Ok so I tried to find a way to install my Gear 2 on my Aosp CM11 Rom
I couldn't find anything so after a couple hours of research I did it. These are the steps:

First make sure that your gear 2 software is update on the gear. Download Kies 3 if its not. Then after this You have
to Root your Gear 2

Use this link:

You just have to Flash the tar file to the gear, if you want to install themes and everything else then you will
have to install Tizen SDK but its not necessary to move forward

Next I followed this:

Where it says samsung Devices With custom Roms:

You Must change that as it says in that step: I used es file explorer and its text editor:

Leave build.prop open and go to the step that says GetFIt Apps Working (optional):

And change all of them as they did in this step : The only one I skipped was ro.product.model (which i did not find)
and I also added an " =SM-900S " to "ro.product.deviece"/

reboot the phone!!! or it wont work

I then went to this website:

and I downloaded:


the .apk file
and then I downloaded everything in the extracted folder:

the 3.apk files in it:

Then I went back out:

and i downloaded the GearManagerStub.apk file which is located in the folder named gear manager stub;

so I Installed all the files first to the phone ( i installed the gear 2 app last): dont open anything till you install all the .apk files

your gear should be in reset mode (if not, just reset it), i Then opened the app and it installed updates (4 updates)/ PLEASE BE PATIENT/ a menu came up on both screens phone & the gear. (Pairing menu)
i then hit pair/ after the release notes came out on my phone I then hit accept twice on my phone and then hit next. The app connects then it force closes. I then re opened the app and it worked!!

Everything seems to be working !! The apps seems to work fine with out any issues or errors.

I just did research i wanted to share:
Thanks to everyone on xda and everywhere else i borrowed the files & links from
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes