FORUMS
Remove All Ads from XDA

LineageOS

137 posts
Thanks Meter: 3
 
By yatman60, Senior Member on 9th May 2017, 09:20 PM
Post Reply Email Thread
Has anyone attempted to install the base LineageOS on their Verizon m8?

If so, what was the level of success? Does everything work?
 
 
15th May 2017, 06:42 PM |#2  
Senior Member
Thanks Meter: 88
 
More
yes its sweet
25th June 2017, 05:58 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by yatman60

Has anyone attempted to install the base LineageOS on their Verizon m8?

If so, what was the level of success? Does everything work?

I am using LineageOS on my VZW m8. I am having issues with my data disconnecting intermittently. Everything else seems to be working fine.
25th June 2017, 11:21 PM |#4  
Senior Member
Thanks Meter: 29
 
More
So ...glad I found this thread, as I was going to create my own (though I think general might be a better place for it...I'll suggest to mods).

Hopefully this can be a good place for all of us VZW M8 users to discuss our LOS experiences.

I just started looking for a new ROM after months of hating the stock MM update. I'm hoping to get another year or so out of my M8.

So far I have narrowed it down to:
NuSenseSeven - A really nice Sense 7 MM build that doesn't seem to have the performance issues of stock MM.
Wolla - Nice clean Sense 8 MM build with a healthy collection of tweaks to configure.
Lineage (LOS) - Nougat build for M8 (only one?). Clean, fast AOSP-like ROM with ability to build extremely light and add what you need from gapps.

So far these are my main issues with Lineage after trying for only a few days:

Not HTC specific. So you are going to lose out on some HTC tools and menus. Something like HTC Connect to cast media, or the comprehensive gesture support HTC has. Some of these you can get back through third party apps, but not all of it and not really as well integrated as you get with HTC/Sense. There are about 5-10 things that a ROM like Wolla has that I can't find the same settings in LOS. Basically I'm deciding if I want to lose out on those to get the benefits on being on the latest possible Android for the phone.

Right now I'm leaning 80% yes on LOS, but I might decide to go back to Wolla or NuSenseSeven. I would need to do some more testing between those two before I decided on which one though.

Although there is a lack of some features in those ROMS, there are other features that you will only get in LOS like the updated Nougat notification system, Privacy Guard, and maybe a few others. So you need to choose what is best for you.

As far as speed/stability/etc. So far I have been really impressed with LOS, though all builds I mention have been way better than stock MM in the few days I've been testing. Here are the only known issues/bugs that I have had with LOS so far:

1) NFC icon. The NFC icon doesn't appear in the status bar, so you can't see at a glance if it is enabled (you can see it in quick launch though). I think this is a regression and there is a bug listed for it. I actually haven't tested the NFC yet though, but it appears that it works, just no notification icon.

2) Double list of APN in mobile settings. This is just a display bug...for some reason the menu option is there twice.

3) I too have had some data/connection issues, but I am not ready to rule the ROM as the issue yet. Basically on the quicklaunch bar it was showing my data connection as "No service" instead of "Verizon Wireless." It would say Verizon sometimes, but not always. I couldn't tell if this was an issue with the display or not because my other ROMS didn't have a comparable icon, so I had to start looking at the hidden phone menus to see what my connection was saying. Sure enough, my phone didn't appear to be getting a carrier name listed when I was using LOS most of the time, but it was there all the time (at least all my testing time) on other ROMs.

As I was trying to compare/troubleshoot this by flashing different ROMS and radios at some point I got to a point where my 4G wouldn't work at all (stuck at 3G). This was the case even when flashing back to pure stock everything. I spent the better part of a day working on this and couldn't find the solution until I found a few other threads of people discussing no 4G connection and the only solution was a new SIM card. Sure enough I got a new SIM from Verizon today and 4G came back immediately. I reflashed LOS and on boot it shows I'm on Verizon, so I'm hoping it stays.
The Following User Says Thank You to TraderJack For This Useful Post: [ View ] Gift TraderJack Ad-Free
28th July 2017, 05:01 PM |#5  
Senior Member
Thanks Meter: 14
 
Donate to Me
More
Stumbled into this thread last week, and was curious. Currently running LineageOS 14.1-20170727 and I'm impressed. Been running fine for about a week now with no major issues. Getting a slightly better battery life, better responsiveness, and good 4G connectivity.
Only minor issues have been spotty WiFi connection, though it might have just been due to a weak signal. That and USB tethering doesn't appear to be working yet. Wifi Tethering seems to work fine though.
**Edit** USB tethering does work. Don't know why it wasn't earlier. Perhaps a bad USB cable
28th July 2017, 10:24 PM |#6  
Junior Member
Thanks Meter: 0
 
More
How to get it?
I'd like to try this ROM on my M8. Did you guys just flash the ROM for the regular M8 not a ported Version?
If yes, is it safe to do that. I have the GPE ROM installed on my M8 running GSM not CDMA.
Thanks!
31st July 2017, 02:52 PM |#7  
Senior Member
Thanks Meter: 14
 
Donate to Me
More
Quote:
Originally Posted by Mohamed Yehia

I'd like to try this ROM on my M8. Did you guys just flash the ROM for the regular M8 not a ported Version?
If yes, is it safe to do that. I have the GPE ROM installed on my M8 running GSM not CDMA.
Thanks!

Yeah, I just tried out the regular M8 version "One 2014 (m8)", and it worked just fine. No special setup coming from the GPE Rom, other than a full wipe. ( That's what I was running as a daily driver before ) It took a long time for the first boot, and it even rebooted on its own after the initial flashing and reboot. Give it a try. I've been really happy with it thus far.
29th September 2017, 06:13 PM |#8  
Junior Member
Thanks Meter: 0
 
More
working well except roaming
I've been running lineage on my verizon M8 for a couple months with excellent results - except when I'm out of the country roaming. In Canada and now Chile the same thing is happening - the network appears for one second, then gone the next, and repeat. Sometimes it's connected long enough for a text to get through, but not enough for any data usage. And it keeps asking me to select my sim card, and of course I have only 1.
17th November 2017, 04:11 PM |#9  
Member
Thanks Meter: 6
 
More
LOS 15 is amazing. Everything works perfectly fine. I just wish LOS performed as smooth as Sense based ROMs
19th November 2017, 07:42 PM |#10  
Senior Member
Thanks Meter: 54
 
More
Any custom kernels available for M8s running LineageOS?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes