FORUMS

Dual Booting ubuntu and windows 8.1 on the Pipo W2

124 posts
Thanks Meter: 26
 
By StridAst, Senior Member on 2nd November 2014, 03:51 PM
Post Reply Email Thread
Ok, So I thought I would post this guide to installing ubuntu 14.04 on the Pipo W2. This guide might help on some of the similar tablets out there too, like the voyo a1 mini. But I can't be certain about the others

Also, to give credit where credit is due, this guide is mostly adapted with little adaptation from the following guides:
http://asus-t100-ubuntu.blogspot.com/
http://linuxnorth.wordpress.com/2014...mer-book-t100/

and work on wifi wouldnt be possible without help on the ubuntu forums
http://ubuntuforums.org/showthread.p...3#post13151763

and the wifi drivers were posted for the rlt8723bs by this guy here
http://www.hadess.net/2014/09/and-no...nda-v975w.html

First the information as to what works, and what doesn't . As of 11/02/2014 stock ubuntu 14.04 works, the touchscreen works. However wifi, sound, bluetooth, suspend, hibernation, power button, volume buttons, and the micro sd card do not.

Updating to newer kernels changes what works and what doesn't. I was able to get wifi working on kernels 3.16.2 and the power button, and volume buttons, but the touchscreen didn't work on 3.16.2 on kernels 3.17.0 and 3.17.1 I was able to get wifi working, and the touchscreen works, but the volume buttons and power button didn't. you can still boot up with these later kernels, but it's not as easy. I had to go into ubuntu advanced options and boot to recovery for each kernel, then from the recovery menu boot to desktop. A bit of a pain. I think it's a graphics related problem, and I'm working on it, but as of this writing, the kernels I tested from 3.15.x on wouldn't boot without this. (if they booted at all, 3.18.rc2 didnt boot at all)

I am still testing various kernels, to see which one seems the most stable and enables the most features I will update this as new information is worked out.

Ok, starting. Part 1. The Prep work.
--------------------------------------------------------------------------------------------------------------------
Things you will need. A USB hub, a USB keyboard, USB wireless adapter, (or USB LAN adapter) and a mouse. (or trackball) And a USB thumbdrive of course. Without these things, you wont be able to complete the installation easily. Plug them all in, and connect them to the tablet.

Download An ubuntu 14.04.1 lts image (you can substitute ubuntu gnome, 14.04.1 lts, or lubuntu 14.04.1 lts image etc) here's a link to Ubuntu though. you can do this on your tablet, or your desktop. up to you.

http://www.ubuntu.com/download/desktop
Select 32 bit. (NOT AMD64) and click on download, then unless you wish to donate, click on the link that says "not now, continue to the download"

now download Rufus from here
http://rufus.akeo.ie/ and use rufus to install the ISO image on your thumbdrive by clicking on the disk icon next to ISO image near the bottom, and selecting the ubuntu-14.04.1-desktop-i386.iso file (or ubuntu-gnome-14.04.1-desktop-i386.iso or whatever flavor you downloaded) The top option on the rufus menu should automaticly list the thumbdrive, if it doesnt, select the thumbdrive unless you want to screw up whatever drive it's pointing at. (you might be able to make your system unbootable if you don't do this carefully so PAY ATTENTION) Is it listing your thumbdrive? if so, click on start on rufus and let it finish.

now you need to download this file here: https://drive.google.com/folderview?...XNrbzN6djQzajg

Leaving the thumbdrive in, unzip the unpackit.tar.gz file to the thumbdrive root directory, and overwrite all files. when you are done, if you did this on your desktop, safely remove the thumbdrive and plug it into the hub connected to your tablet. if you did this with your tablet, leave it plugged in and continue.

Now, for the windows setup.

First, get to control panel. (you can access it by pressing the windows key to get to the start menu, then going to PC settings, and selecting control panel) click the view to small icons, then click on Power Options. Next click on "Choose what the power button does" and from the next menu, click on "change settings that are currently unavailable"
now scroll down and uncheck the box that says "turn on fast startup" then save.

IMPORTANT NOTE: if you want to screw up windows, so that it wont boot, do the next step in a hurry and pay little attention to what you are doing.

Next you need to set up up some space for Ubuntu. (NOTE: you must have 8-10GB or so empty space on windows partition first, so if you don't have 8-10GB free, go delete some things until you have enough space free.) Ready? Ok you need disk management. go to your desktop then right click on on the start button. and select Disk Management from the menu Expand the window so you can see what you are doing, and right click on "Windows (C select "Shrink Volume" from the list. You will see a window that lists
"Total size before shrink in MB"
"Size of available shrink space in MB"
"Enter the amount of space to shrink in MB"
"Total size after shrink in MB"

Now, using the "Enter the amount of space to shrink in MB" option, type in 10000 or so, (8000 works too) to shrink the volume by 10 gb or 8gb (yes I know it's overly rounded, forgive my OCD) and leave the space as unallocated. do NOT shrink to the max it will let you. always give windows some space to work with.

IMPORTANT NOTE: If you shrink the volume by more then the free space, you will probably screw up your windows installation. I am NOT going to help you figure out how to fix windows, if you ignored these warnings and screw it up. Mostly because I haven't the faintest idea how to fix your windows installation if you shrink the volume too much.

Next eject any Micro SD card you have in the tablet, and pull it out.

Lastly for windows side of things, go back to your desktop, and again right click the start menu, open the shut down options list, then hold shift down and click on restart

You should now be faced with a blue screen with several options, click on "Use a Device" then select "UEFI:Removable Device" and allow the tablet to restart. it will boot back up to windows, but now you should have the USB drive in your UEFI settings boot options. Power the tablet down, all the way, and this time, when you see it start to boot up, press f7 over and over and over until you see the boot option menu, select your thumbdrive and hit enter.

You should be faced with the Grub menu now, press e to edit, and arrow over to where it says video=VGA-1:1368x768e delete the 1368x768 and replace it with 800x1280 now the end of that line should say:

video=VGA-1:800x1280e reboot=pci,force

then hit f10 to boot. it should take a few min, but boot to desktop, if it doesnt, power off the tablet by holding down the power button for 12 seconds, and try again. If it doesn't boot and just errors with rpmb timeout errors for more then 5 min, just try again. (and unplug anything but the keyboard and usb thumbdrive from your hub until you reach desktop.

Once you hit desktop, wait a good 15 seconds before touching anything, otherwise kernel panic hits sometimes.

Once you are at your desktop, click in the upper right corner and go to system settings, and go to Brightness & Lock and uncheck the box that says "dim screen to save power" and change "Turn screen off when inactive for" to never.

Next exit that screen and connect to your wifi or make certain your wired network is working. check to make certain you have internet access. then hit ctrl-alt-t to open a terminal. type the following

sudo umount /dev/mmcblk0p*

now kill that window. you are now ready, FINALLY ready to install ubuntu.


Part 2 : Installing Ubuntu
-------------------------------------------------------------------------------------------------------------------------------------
Click on the icon to install ubuntu, then when the window pops up, select your language and continue

On the next window check both boxes to install updates and third party software, (third party is probably optional) and click continue

Now, we wait. wait wait wait and wait. the next window will take quite a while to pop up. probably rpmb timeout errors as it checks all the drives. might be 30 min or so. no way to speed this up.

Now PAY ATTENTION: Next window, click on the last option that says "Something Else" if you click standard install, you can kiss windows goodbye.

Following window, will list all your drives. do you see that 10000 or 8000 MB of space you created earlier? nice and round and most importantly, easily recognizable? click on that it should say "free space", then click on the "+" button., when the create partition box pops up, select logical instead of primary, and select the mount point to / and Use As: should say "Ext4 journaling file system" it will list the partition as something like mmcblk0p5 (might be mmcblk0p6 or mmcblk0p4 or whatever. pay ATTENTION to this, write it down. you will need it later.

don't worry about swap space, the installer crashes if you try to set any space aside as swap space. so just leave the entire unallocated space for the ext4 partition

click on "Install Now" and a warning will pop up, just click continue (this is a warning about it suggest swap space. you cant, so just continue)


select your timezone, keyboard layout, then username, computer name, password on the next screens, and DON'T encrypt your home partition. and let it install

It should run for a while and finish installing

When it finishes, don't reboot, and instead exit the installer and power off instead of rebooting. you will see it stops after system halted. once you see that, hold the power button for 12 seconds to power off the device.

Leave everything plugged in, and power on, when you see the grub menu, this time hit "C" to drop to a command line. and remember the number at the end of your partition where you installed linux? get out that paper. you need it now. now type:

linux (hd1,gpt5) (dont hit enter yet) if your partition was 6 instead of 5 (mmcblk0p6 instead of mmcblk0p5) then instead of gpt5 use gpt6 etc.

now continue and add /boot/vmlin so that the command line reads
linux (hd1,gpt7)/boot/vmlin now hit Tab

it should autofill and read something like

grub> linux (hd1,gpt5)/boot/vmlinuz-3.13.0-32-generic

still dont hit enter. now add root=/dev/mmcblk0p5 (or whatever your partition was) followed by video=VGA-1:800x1280e reboot=pci,force

the final line should read something like

grub> linux (hd1,gpt5)/boot/vmlinuz-3.13.0-32-generic root=/dev/
mmcblk0p5 video=VGA-1:800x1280e reboot=pci,force

NOW you can hit enter.
next line. type:

Initrd (hd1,gpt5)/boot/initrd and press Tab again

now it should read something like

grub> initrd (hd1,gpt5)/boot/initrd.img-3.13.0-32-generic

now hit enter

now type boot then hit enter.

it should boot to desktop now

ok now we need to fix grub so you can boot without the thumbdrive in

make certain you are connected to the internet, via wired or usb wireless adapter, and open another terminal by hitting ctrl-alt-t

now copy and paste this in and hit enter:

sudo apt-get update && sudo apt-get install git bison libopts25 libselinux1-dev autogen m4 autoconf help2man libopts25-dev flex libfont-freetype-perl automake autotools-dev libfreetype6-dev texinfo

when it asks to install hit a y and let it continue

when it finishes and you see a terminal prompt again, type or copy:

git clone git://git.savannah.gnu.org/grub.git

and hit enter at the next prompt type

cd grub

followed by enter again, then type or copy:

./autogen.sh

hit enter again and at the next prompt type or copy:

./configure --with-platform=efi --target=i386 --program-prefix=""

enter again, at when it finishes, at the next prompt type

make

and hit enter. At the next prompt (will take a while to finish) type or copy:

cd grub-core

and hit enter. then copy and paste in:

sudo ../grub-install -d . --efi-directory /boot/efi/ --target=i386

hitting enter again. At the next prompt, type or copy and paste in:

cd /boot/efi/EFI

hit enter then paste in:

sudo cp grub/grubia32.efi ubuntu/grubia32.efi

and hit enter

now we get to edit grub.

next command you type or paste in should be:

sudo nano /etc/default/grub

and we get to edit the following line

GRUB_CMDLINE_LINUX_DEFAULT

find that line, and delete the words quiet and splash. and replace with

video=VGA-1:800x1280e reboot=pci,force

hit ctrl-x and save as you exit.

now we have the LAST command you need to type here. it's:

sudo update-grub

and of course hit enter.

once you have the terminal prompt again, you can exit the terminal, and power off the tablet again. (you will need to hold the power button for 12 seconds after system halts. get used to this.)

Now, I'm going to assume you don't want ubuntu to be the default OS to boot into yet. if you really do, skip this part, if not, continue.

Disconnect the usb thumbdrive and then press the power button on your tablet., Now press F7 over and over until the UEFI boot menu shows up Select "Enter Setup"

arrow over to the boot menu, and select windows as the number 1 option.

now, your tablet should be set up, to boot into windows by default.

To boot to ubuntu, use F7 to enter the boot menu on startup, and select grub and ubuntu

you can leave it with grub as the bootloader if you want. there are ways to configure grub to boot into windows by default, but you will need to keep a keyboard with the tablet at all times then. since sometimes it wont auto boot, and will wait forever for the enter key to be pressed to select your boot option.

I'll add information to my next post to explain how to rotate the screen in ubuntu, as well as information for updating kernels and getting the internal wifi to work.
The Following 5 Users Say Thank You to StridAst For This Useful Post: [ View ] Gift StridAst Ad-Free
2nd November 2014, 04:44 PM |#2  
OP Senior Member
Thanks Meter: 26
 
More
ok, tips and tricks. to rotate the screen, you need to enter two commands into the terminal

first to rotate the view to the right, you type:

xrandr -output VGA1 -rotate right

on my most recent installation (ubuntu mate 14.04) this didnt work. so I needed instead to use

xrandr -o right


then hit enter of course. this WONT rotate the touchscreen. to rotate that, we need xinput.
first you can type xinput list to list what devices are present. I assume you will see FTSC1000:00 2808:5056 listed. if so, this will work, if not, you will need to adjust this command to fit what you see listed. (most important if you are adapting this guide to another bay trail tablet other then the pipo w2) the command that you want, assuming that's your touchscreen is

xinput set-prop "FTSC1000:00 2808:5056" "Coordinate Transformation Matrix" 0 1 0 -1 0 1 0 0 1

and hit enter of course. your touchscreen should now be rotated to the right as well,


-----------------------------------------------------------------------------------------------------


ok, Wifi, to get wifi up and running, you will break screen rotation. Also it will break your normal boot process, requiring you to boot though advanced options for ubuntu, and recovery mode after that. The wifi is also unstable, and prone to hanging, requiring you to disconnect and reconnect at random intervals. It's not a perfect workaround, pretty far from it in fact, but it does at least prove the wifi is possible to get working. we probably need a better driver. Overall, you will get much much MUCH better performance with a usb wifi module. but that's extremely annoying to use so feel free to experiment here.

step one, go to here: http://kernel.ubuntu.com/~kernel-ppa....18-rc4-vivid/

and download the following files. http://kernel.ubuntu.com/~kernel-ppa...91835_i386.deb

http://kernel.ubuntu.com/~kernel-ppa...091835_all.deb

http://kernel.ubuntu.com/~kernel-ppa...91835_i386.deb

now copy them to your desktop in ubuntu.

now in terminal type:

cd Desktop

then type:

sudo dpkg -i linux*.deb

once it's done, reboot your tablet. now go to grub, and select advanced options for ubuntu, then select recovery mode for the 3.18-rc4 kernel. and resume normal boot once you see the recovery menu show up

this should allow you to boot to desktop. after which go back to terminal, and type the following commands in, one line at a time of course, waiting for the next prompt before typing the next line

sudo apt-get install build-essential linux-headers-generic git
git clone https://github.com/hadess/rtl8723as.git
cd ~/rtl8723as
make clean
make
sudo make install
sudo depmod -a
sudo modprobe 8723bs

reboot. go through the recovery mode menu again to boot to desktop. wifi should now be working. you will need to use recovery mode to boot from this point on. since 3.18-rc4 wont boot without it. Be forwarned, suspend mode breaks wifi it seems. one time of the suspend, and you will need to reboot to get it working again. So I would suggest disabling everything applicable to your tablet screen shutting off. also, the wifi is extremely unstable. as noted above. it can quit for no reason, and need to disconnect and reconnect to use it more.

information for how to install the wifi driver was gained here:
http://ubuntuforums.org/showthread.p...3#post13151763

information as to why the wifi won't work, even with the drivers, on 14.04 default kernels was obtained from this thread https://bugzilla.kernel.org/show_bug.cgi?id=67921
The Following 2 Users Say Thank You to StridAst For This Useful Post: [ View ] Gift StridAst Ad-Free
3rd November 2014, 08:11 AM |#3  
Junior Member
Thanks Meter: 4
 
More
would this work on a clovertrail device?
3rd November 2014, 04:03 PM |#4  
OP Senior Member
Thanks Meter: 26
 
More
I don't think so. I don't think clovertrail is Linux friendly at all. Clovertrail+ should be, but not clovertrail. However the clovertrail+ devices I know of are the Asus padfone the Asus zenfone and the lenovo k900. All of which use droidboot. (Can't load grub). And have PowerVR graphics which are not open source, so no Linux drivers. There are probably more clovertrail+ devices out there I just haven't looked into them much.
15th November 2014, 07:00 PM |#5  
OP Senior Member
Thanks Meter: 26
 
More
I added information to the second post about screen rotation, and relevant information to the workaround for wifi. Be advised that it's not a perfect workaround. wifi works, and so does the power button. but it requires booting through recovery mode
27th November 2014, 01:19 AM |#6  
SuperSuperFrank's Avatar
Junior Member
Flag London
Thanks Meter: 0
 
More
Thumbs up
It's cool. Do you know whether it works well on the latest W2f?
27th November 2014, 03:05 PM |#7  
OP Senior Member
Thanks Meter: 26
 
More
No idea. Probably though. But I can't be certain. I don't have a pipo w2f to test with.
13th December 2014, 05:59 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Arch Linux
Have you tried to install ArchLinux on this tablet?
17th December 2014, 04:28 AM |#9  
OP Senior Member
Thanks Meter: 26
 
More
nope, sorry so far i've just experimented with ubuntu and fedlet. I have not installed fedlet, just booted and looked around a bit.
4th January 2015, 08:46 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by StridAst

nope, sorry so far i've just experimented with ubuntu and fedlet. I have not installed fedlet, just booted and looked around a bit.

I tried this guide , my interest was just trying to live mode ubuntu , but unfortunately the screen is distorted even changing resolution.

My though is a Pipo W6 .

Did you try to start Live Android X86 ?
5th January 2015, 02:40 PM |#11  
OP Senior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by Tony Evo

I tried this guide , my interest was just trying to live mode ubuntu , but unfortunately the screen is distorted even changing resolution.

My though is a Pipo W6 .

Did you try to start Live Android X86 ?

I've not tried android at all on mine. I keep meaning to do so, but have not found the time yet. Hmm though on the W6. did you try setting resolution settings at 1200x1920 or just 1920x1200? which number you put first matters and can result in a distorted screen. the w2 is listed as 1280x800 resolution, but to get ubuntu to work without the screen going all wonky, you have to reverse the numbers to 800x1280.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes