FORUMS

[UPDATE] Secure boot unlocked!

348 posts
Thanks Meter: 48
 
By XDA-00, Senior Member on 17th April 2016, 05:15 PM
Post Reply Email Thread
Big Update!!


Caution

Before doing anything, disable bitlocker or your surface won't boot.

Run this command in Command Prompt :-

manage-bde -protectors %systemdrive% -disable (either replace %systemdrive% with C: or just leave it at that)


================================================== ==================================================
Edit :- Links are dead!! Go to the following thread :-

https://forum.xda-developers.com/win...ce-rt-t3653848


================================================== ==================================================

Microsoft Backdoor has been revealed!
http://rol.im/securegoldenkeyboot/

Secure Boot is disabled!
http://forum.xda-developers.com/wind...nlock-t3436640

Now you can run unsigned apps on surface rt!
The Following 3 Users Say Thank You to XDA-00 For This Useful Post: [ View ] Gift XDA-00 Ad-Free
18th April 2016, 10:38 PM |#2  
Member
Thanks Meter: 5
 
Donate to Me
More
Hey!, i'm trying this, i think that this can work!, if work, WoW, if not work meh, if not work and broke my surface "poor man, new dely is becomed the biggest version of the columbine massacre"
I'm joking for the last man 😄

---------- Post added at 09:36 PM ---------- Previous post was at 09:29 PM ----------

Hey! Worked, and well, restarted and not broken, now i'll try for the bios

---------- Post added at 09:38 PM ---------- Previous post was at 09:36 PM ----------

Sorry, but the secure boot option is enabled anyway, but we tried!
The Following User Says Thank You to roxas22 For This Useful Post: [ View ] Gift roxas22 Ad-Free
19th April 2016, 10:40 AM |#3  
OP Senior Member
Flag New Delhi
Thanks Meter: 48
 
More
Quote:
Originally Posted by roxas22

Hey!, i'm trying this, i think that this can work!, if work, WoW, if not work meh, if not work and broke my surface "poor man, new dely is becomed the biggest version of the columbine massacre"
I'm joking for the last man ��

---------- Post added at 09:36 PM ---------- Previous post was at 09:29 PM ----------

Hey! Worked, and well, restarted and not broken, now i'll try for the bios

---------- Post added at 09:38 PM ---------- Previous post was at 09:36 PM ----------

Sorry, but the secure boot option is enabled anyway, but we tried!

Thanks for testing. Any ideas for BITLOCKER?

Try doing it in normal mode with admin rights and reboot.
19th April 2016, 01:54 PM |#4  
Member
Thanks Meter: 5
 
Donate to Me
More
Hey, i think i made a mistake, what do you mean for "safe mode"?

---------- Post added at 12:54 PM ---------- Previous post was at 12:43 PM ----------

Hey, i think that we can change UEFIsecurebootEnabled with UEFIsecurebootDisabled, but i have done my part, this time you have to try
The Following User Says Thank You to roxas22 For This Useful Post: [ View ] Gift roxas22 Ad-Free
19th April 2016, 04:46 PM |#5  
OP Senior Member
Flag New Delhi
Thanks Meter: 48
 
More
Quote:
Originally Posted by roxas22

Hey, i think i made a mistake, what do you mean for "safe mode"?

---------- Post added at 12:54 PM ---------- Previous post was at 12:43 PM ----------

Hey, i think that we can change UEFIsecurebootEnabled with UEFIsecurebootDisabled, but i have done my part, this time you have to try

Great idea, but unfortunately I cannot try because when I boot into safe mode with cmd it asks for bitlocker recovery key and I don't have it so I have to 'skip this drive'(boot to virtual drive) and my normal account does not have admin rights and I cannot change it.
I can only view settings.
29th May 2016, 07:03 PM |#6  
Member
Flag Kyiv
Thanks Meter: 5
 
More
Quote:
Originally Posted by XDA-00

Great idea, but unfortunately I cannot try because when I boot into safe mode with cmd it asks for bitlocker recovery key and I don't have it so I have to 'skip this drive'(boot to virtual drive) and my normal account does not have admin rights and I cannot change it.
I can only view settings.

I can try m8
30th May 2016, 07:32 AM |#7  
Member
Thanks Meter: 5
 
Donate to Me
More
Quote:
Originally Posted by tornado95

i can try m8

try man! Try!

---------- Post added at 06:32 AM ---------- Previous post was at 06:30 AM ----------

Quote:
Originally Posted by roxas22

try man! Try!

try man! Try!
31st May 2016, 06:48 AM |#8  
Member
Flag Kyiv
Thanks Meter: 5
 
More
Quote:
Originally Posted by roxas22

try man! Try!

---------- Post added at 06:32 AM ---------- Previous post was at 06:30 AM ----------


try man! Try!

Not working at all System automatically change value to 1( Also I have tried adding UEFISecureBootDisabled with value 1, but nothing change.
31st May 2016, 07:15 AM |#9  
Member
Thanks Meter: 5
 
Donate to Me
More
Quote:
Originally Posted by Tornado95

Not working at all System automatically change value to 1( Also I have tried adding UEFISecureBootDisabled with value 1, but nothing change.

Can you try to disable bitlocker?
31st May 2016, 09:53 AM |#10  
Member
Flag Kyiv
Thanks Meter: 5
 
More
Quote:
Originally Posted by roxas22

Can you try to disable bitlocker?

Hmm... How? I only write a recovery key to unlock it.
2nd June 2016, 03:58 AM |#11  
Inactive Recognized Developer
Flag Denver
Thanks Meter: 566
 
Donate to Me
More
Those flags are simply status flags, they're set by the kernel on boot. The kernel keeps track of SecureBoot internally. You can set those to disabled and change permissions so nothing can overwrite them, doesn't change anything.
Post Reply Subscribe to Thread

Tags
jailbreak, secure boot

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes