FORUMS
Remove All Ads from XDA

[TUTORIAL] Deploy XAPs easily with WPV Xap Deployer

248 posts
Thanks Meter: 42
 
By MrCego, Senior Member on 5th December 2015, 06:37 AM
Post Reply Email Thread
I really sorry if there are another tutorials about this, but I wanna shared this easy method to deploy any xap you want, especially root and interop unlock tools.

NOTE: This tutorial is oriented to people with low-requeriment PCs like x86 SO or small tablets. I always recommend to install Visual Studio + SDK Windows Phone 8.1/Windows 10 Mobile if your PC can support them. You can skip download lite SDKs if you have VS installed.

NOTE 2: Make sure your PC has installed Net Framework 4.5.1. If not, download it here and install.

What do you need?
1. Windows Phone SDK 8.0 Lite: Download it Here.
2. Windows Phone SDK 8.1 Lite: Download it Here
3. WPV XAP Deployer Tool : Download it here

What should do you do?
1. Extract compressed files into each folder.
2. Open WP8 SDK Tools Lite Setup Av1.0 folder and start InstallWP8SDKToolsLite.bat file. Do not run as administrator.
3. When CMD dialog shows, press ENTER. All dialog confirmations press yes. When it finishs, press ENTER again.
4. Do the same in step 2 and 3 but with the WP8.1 SDK Tools Lite Setup Av1.00 folder and InstallWP81SDKToolsLite.bat file.
5. Now open WPV XAP Deployer 2.0 folder and run WPV XAP Deployer. Press Add Xap Files button. A dialog windows is shown; select XAPs you want to deploy. Press Deploy. Wait.





That's all! Remember, your phone must be in Developer Mode (in case you have installed Windows 10 Mobile) or Developer Unlocked (if you have Windows Phone 8.1 in device) for successfully deploying.

I hope this tutorial can help you to deploy easily your XAPs. Regards!
Attached Thumbnails
Click image for larger version

Name:	1.PNG
Views:	31834
Size:	18.2 KB
ID:	3565480   Click image for larger version

Name:	2.PNG
Views:	35586
Size:	26.4 KB
ID:	3565481  
The Following 13 Users Say Thank You to MrCego For This Useful Post: [ View ] Gift MrCego Ad-Free
 
 
5th December 2015, 10:04 AM |#2  
Senior Member
Thanks Meter: 132
 
More
Not bad : http://forum.xda-developers.com/show...7#post64124487
5th December 2015, 10:17 AM |#3  
dxdy's Avatar
Senior Member
Thanks Meter: 2,028
 
Donate to Me
More
WP8.0 SDK Tools Lite Setup Av1.20
WP8.1 SDK Tools Lite Setup Av1.20

http://dhost.info/vink/avink/forums/...95402fe47fe82f
The Following 2 Users Say Thank You to dxdy For This Useful Post: [ View ] Gift dxdy Ad-Free
22nd December 2015, 12:06 AM |#4  
MrCego's Avatar
OP Senior Member
Flag Cartagena
Thanks Meter: 42
 
Donate to Me
More
Replaced down links. Thanks dxdy.
18th March 2016, 11:26 PM |#5  
Member
Flag Bellevue
Thanks Meter: 3
 
More
I am getting error while connecting to device (0x89731B01). It waits for long time and then throws this error. I have installed the tools and enabled developer mode on phone. I have VS 2015 installed also (I tried without installing SDKs also.)
31st March 2016, 01:28 AM |#6  
Member
Thanks Meter: 3
 
More
@MrCego - By far the most thorough instructions and easy to follow for a newb, thank you.
14th April 2016, 08:16 PM |#7  
LEFTKOYL's Avatar
Member
Flag Athens
Thanks Meter: 5
 
More
Where I can find usb drivers for lumia 950 (win7x64)?
15th April 2016, 01:08 AM |#8  
Senior Member
Flag Mashad
Thanks Meter: 382
 
More
Quote:
Originally Posted by LEFTKOYL

Where I can find usb drivers for lumia 950 (win7x64)?

No drivers needed as far as I know
15th April 2016, 06:42 AM |#9  
Senior Member
Thanks Meter: 132
 
More
Install windows device recovery tool, has all the drivers.
16th April 2016, 06:58 PM |#10  
Member
Thanks Meter: 11
 
More
I need help please.
It wont connect with my phone with developer mode on and i get a error instead.
But if i change from developer to sideload mode,it suddenly can connect with my phone ,and load the app but fails at installing (Says it needs the developer mode )

I use a nokia 930 with the 14322 build.
27th April 2016, 11:28 AM |#11  
Junior Member
Thanks Meter: 0
 
More
I have a problem with starting the WPV Xap deployer. I get a Windows error message, WPV Xap Deployer has stopped working. Windows is collecting dada......

My opsys is Win7 Ultimate
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes