FORUMS
Remove All Ads from XDA

TWRP 3.2.1 with working decryption

13 posts
Thanks Meter: 9
 
By nialv7, Junior Member on 19th February 2018, 09:08 AM
Post Reply Email Thread
The old TWRP 3.1.1 image made by @eagleeyetom no longer works after I upgraded to Oreo. So I put in sometime and figured out how to fix that myself. Turns out it's easier than I thought!

Note I have only tested this with OmniRom 8.1, YMMV with a different android version.

Thanks the mods for moving this thread here.

DOWNLOAD

Update: Fixed some missing utilities (e.g. unzip). The default configuration file is the worst!
The Following 6 Users Say Thank You to nialv7 For This Useful Post: [ View ] Gift nialv7 Ad-Free
 
 
19th February 2018, 09:14 AM |#2  
eagleeyetom's Avatar
Developer Committee Lead / XDA Portal Team / Senior Moderator
Flag Gdańsk
Thanks Meter: 15,588
 
Donate to Me
More
Quote:
Originally Posted by nialv7

The old TWRP 3.1.1 image made by @eagleeyetom no longer works after I upgraded to Oreo. So I put in sometime and figured out how to fix that myself. Turns out it's easier than I thought!

Note I have only tested this with Oreo, YMMV with a different android version.

I have to post here because I "must have a higher post count in order to make a new thread in this development section". So maybe a mod can move it there?

DOWNLOAD

What did you do? I'm very curious since I couldn't find a way to fix it.
19th February 2018, 10:41 AM |#3  
OP Junior Member
Thanks Meter: 9
 
More
@eagleeyetom I just makr twrp run qseecomd before decryption.
19th February 2018, 10:45 AM |#4  
eagleeyetom's Avatar
Developer Committee Lead / XDA Portal Team / Senior Moderator
Flag Gdańsk
Thanks Meter: 15,588
 
Donate to Me
More
Quote:
Originally Posted by nialv7

@eagleeyetom I just makr twrp run qseecomd before decryption.

I tried that. How did you build it? Do you have a source that you could share?
19th February 2018, 11:08 AM |#5  
Member
Flag Paris
Thanks Meter: 7
 
More
Decryption doesn't work for me on 7.1.1 - 34.3.A.0.252
19th February 2018, 11:21 AM |#6  
OP Junior Member
Thanks Meter: 9
 
More
@Wxfdswxc If you are using Android 7, try this twrp: https://forum.xda-developers.com/x-c...mpact-t3640914
19th February 2018, 11:23 AM |#7  
Member
Flag Paris
Thanks Meter: 7
 
More
Quote:
Originally Posted by nialv7

@Wxfdswxc If you are using Android 7, try this twrp: https://forum.xda-developers.com/x-c...mpact-t3640914

Yes I know, I tried it to be ready for Oreo, I already switched back to 3.1.1.
It was just to pass the info.
19th February 2018, 11:28 AM |#8  
OP Junior Member
Thanks Meter: 9
 
More
@eagleeyetom Here are some patches
Attached Files
File Type: patch bootable_recovery.patch - [Click for QR Code] (4.1 KB, 130 views)
File Type: patch device-sony-common.patch - [Click for QR Code] (3.0 KB, 108 views)
19th February 2018, 12:14 PM |#9  
oshmoun's Avatar
Senior Member
¯\_(ツ)_/¯
Thanks Meter: 1,316
 
More
Quote:
Originally Posted by nialv7

@eagleeyetom Here are some patches

which twrp branch did you use to build the recovery image? omni's android-8.1 or android-7.1?
19th February 2018, 12:27 PM |#10  
OP Junior Member
Thanks Meter: 9
 
More
@oshmoun 8.1
The Following User Says Thank You to nialv7 For This Useful Post: [ View ] Gift nialv7 Ad-Free
19th February 2018, 12:33 PM |#11  
oshmoun's Avatar
Senior Member
¯\_(ツ)_/¯
Thanks Meter: 1,316
 
More
Quote:
Originally Posted by nialv7

@oshmoun 8.1

interesting, so just to make sure, you used this repository and branch?
https://github.com/omnirom/android_bootable_recovery
because I tried that, and couldn't get it to boot
will test with your patch
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes