FORUMS
Remove All Ads from XDA

Need help installing TWRP

6 posts
Thanks Meter: 0
 
By Moongose83, Junior Member on 27th July 2018, 03:49 PM
Post Reply Email Thread
[SOLVED]
Hello,
I recently got Xperia L from my friend and I wanted to give it a "new life" in form of new Lineage OS. The problem is I can't install any new TWRP so I'm stuck. I'm total noob when it comes to this. I've flashed many roms on my S4 mini, but this Sony gives me hard times.

Things I've done:
*Unlocked bootloader via Flashtools with code from xperia original site.
*Had to reflash original "C2105_15.3.A.1.17_CE.ftf" because of bootloop.
*Tried root via DoomLord Easy Rooting Kit - didn't work.
*Ended up rooting via Kingo Root app from PC.
*Tried install TWRP through original app + using the
su
dd if=/sdcard/twrp.img of=/dev/block/platform/msm_sdcc.1/by-name/FOTAKernel
commands. - didn't do anything (no error tho)
*Tried to install TWRP through ADB - gives error "command not allowed".
*Managed to instal TWRP through Recovery installer apk v 1.4 - but it's old version (2.7.1.0)which doesn't support flashing new TWRP.
*Many more things what I've found here on this forum which ended up bootlooping the phone, did nothing or gave error.

added:
*Flashify freezes when I try to select "Choose a file" in Recovery menu and doesn't load anything when I choose to download TWRP.
*Managed to instal CWM or TWRP via Recovery Installer for Xperia L - v1.8 - both old version, so no win for me.

So here I'm stuck on C2105_15.3.A.1.17_CE.ftf with old TWRP v2.7.1.0 and I can't move forward. Any help will me MUCH appreciated! Let me know if you need any more info.

[SOLVED]
Followed How To on original Lineage wiki and it worked. I'm an idiot that I haven't checked it sooner.
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes