FORUMS
Remove All Ads from XDA
Honor 9 Lite

[FIX] Xperia SP Vibration

1,889 posts
Thanks Meter: 4,461
 
Post Reply Email Thread
The video below will show you how to fix the missing vibration in the Xperia SP [Most of the time]. Thanks for watching and please do subscribe to help me out in my channel and also do remember to leave a THANKS for this post!
Any questions? Post it down below or create your own seperate thread in the Q&A Forum! (I'm actively helping out there too! )

(Changed Video Link for Higher Quality)
The Following 7 Users Say Thank You to Furrydaus For This Useful Post: [ View ] Gift Furrydaus Ad-Free
 
 
24th August 2014, 04:50 PM |#2  
Junior Member
Flag tehran
Thanks Meter: 4
 
More
dude its awesome !!
is there anyway you can uplod a better quality video so i can see the specifics ?
thanks anyway bro great job.
24th August 2014, 06:17 PM |#3  
Quote:
Originally Posted by moh3en xperia

dude its awesome !!
is there anyway you can uplod a better quality video so i can see the specifics ?
thanks anyway bro great job.

Actually I could but my hdcamera is on repair. I could try my webcam. Ill update the thread if I can get a new vid up
The Following User Says Thank You to Furrydaus For This Useful Post: [ View ] Gift Furrydaus Ad-Free
24th August 2014, 06:25 PM |#4  
Junior Member
Flag tehran
Thanks Meter: 4
 
More
cool man !
thanks
The Following User Says Thank You to moh3en xperia For This Useful Post: [ View ] Gift moh3en xperia Ad-Free
25th August 2014, 07:54 AM |#5  
le grande magnetto's Avatar
Senior Member
Thanks Meter: 1,442
 
More
Quote:
Originally Posted by Furrydaus

Actually I could but my hdcamera is on repair. I could try my webcam. Ill update the thread if I can get a new vid up

Just take photo of that component or most important steps.
Anyway, could you tell more about that vibration problem? Idk if I have one or dont, I might be thinking everything is ok but be wrong.
25th August 2014, 08:22 AM |#6  
Quote:
Originally Posted by le grande magnetto

Just take photo of that component or most important steps.
Anyway, could you tell more about that vibration problem? Idk if I have one or dont, I might be thinking everything is ok but be wrong.

Sure. Thanks for the suggestions. I'll hit you guys up with smtgh better in a day or two
25th August 2014, 09:44 PM |#7  
Junior Member
Flag tehran
Thanks Meter: 4
 
More
cant even open that back cover and i think i broke it a little !!
27th August 2014, 01:03 AM |#8  
Quote:
Originally Posted by moh3en xperia

cant even open that back cover and i think i broke it a little !!

Ive broke the screws before but I didnt mind. Just make sure to slowly remove the internal cover sloely to prevent the headphone jack wire being removed. If it does then you'll have to put it back and such. It isnt recommended to leave the phone in a windy area to prevent dust from entering
The Following User Says Thank You to Furrydaus For This Useful Post: [ View ] Gift Furrydaus Ad-Free
27th August 2014, 06:38 PM |#9  
Junior Member
Flag tehran
Thanks Meter: 4
 
More
dude not working for me..
i open the back cover and rotate that thing but did not work
i think the vibration slab is dead
thanks anyway
31st August 2014, 08:50 AM |#10  
Quote:
Originally Posted by moh3en xperia

dude not working for me..
i open the back cover and rotate that thing but did not work
i think the vibration slab is dead
thanks anyway

It's a trial and error procedure. Try moving the slab a little left or right. It doesnt neccesarily have to be how I showed you guys in the video. Test the vibartion by booting up your device and if it doesn't work, just turn it off. And try again lol

Sent from my Huashan using XDA Premium
31st August 2014, 01:24 PM |#11  
Junior Member
Flag tehran
Thanks Meter: 4
 
More
Cool
it`s automatically got fixed !!!!!!!!!!!!!!!!!!!!!!!!!!!
i mean what the hell was that ?!
anyway
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes