FORUMS

WiFi strength, range, and throughput

809 posts
Thanks Meter: 2,071
 
By XDA_RealLifeReview, RealLifeReview Dude on 29th July 2016, 09:35 PM | Average Rating:
Post Reply Email Thread
Rate this thread to express how you think the Sony Xperia X Performance's Wifi performs. A higher rating indicates that it has excellent range, throughput, and signal strength. Like when you're taking a dump in the bedroom upstairs, do your videos have to buffer or do they come through without interruption?

Then, drop a comment if you have anything to add!
2nd August 2016, 10:30 AM |#2  
Member
Thanks Meter: 21
 
More
wifi in my device is worst than ever sony devices (xz, xz1, xz ultra, xz2, xz3c, xz3 not mention non z series)

wifi is connected but no internet (when internet OK - superslow)

and I have to mention about vibrating engine - it's very loud (like bad mounted)
4th August 2016, 03:36 AM |#3  
augie7107's Avatar
Senior Member
Flag Boston
Thanks Meter: 431
 
More
WIFI not particularly good on mine either. Walls cause a problem when Z5 has no problem keeping strong signal

Sent from my F8132 using XDA-Developers mobile app
6th August 2016, 08:32 AM |#4  
power323f's Avatar
Senior Member
Flag Grave
Thanks Meter: 17
 
More
My z2 has 2bars and my Xp has 0bars 😢

Sent from my D6503 using XDA-Developers mobile app
The Following User Says Thank You to power323f For This Useful Post: [ View ] Gift power323f Ad-Free
6th August 2016, 10:21 PM |#5  
dillalade's Avatar
Senior Member
Flag Richmond
Thanks Meter: 365
 
More
I concur XP worse then z5c. Finding I have to manually connect to my WiFi networks it won't auto connect most of the time which is even more annoying than the weaker WiFi connection which is also occurring.

Sent from my F8131 using XDA-Developers mobile app
23rd March 2017, 10:16 AM |#6  
Junior Member
Thanks Meter: 0
 
More
I was hoping this would have been fixed by now, but it seems to still be a problem. I got my XP a few days ago and I'm having a lot of issues with the WiFi at work.

If I put my XP next to my Z3C on my desk, the Z3C has full signal and the XP struggles to even keep the connection alive. The signal indicator in the status bar hits rock bottom and apps lose connectivity. It also won't connect automatically when I get to work.
I installed all the available updates immediately after booting the phone, so I don't know if the problem was introduced in any of those. I'm on Nougat, build 39.2.A.0.442 now.
Maybe worth noting: When downloading the updates I put the phone in the same place it's having problems now, but it had no problems downloading them.

Has anyone found a fix for this? Factory reset? Send the phone back for service/replacement?

EDIT: Factory reset did not help for me at all. The signal strength seemed fine when I booted into safe mode, but it didn't stay that way after I did another factory reset after that.
18th April 2018, 10:47 AM |#7  
huangjs's Avatar
Member
Flag Taipei
Thanks Meter: 2
 
Donate to Me
More
Xperia X Performance is the worst WiFi ever in my life. Ever used Sony Arc, Samsung S3, Sony Z2.
Ever worse upgraded to Oreo. Lots of TCP re-transmissions, disconnections.
I don't even know what is the "Performance" for? Cost-down Performance?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes