FORUMS
Remove All Ads from XDA

Z1 Compact - Need help with disabling battery thermal throttle

9 posts
Thanks Meter: 0
 
By Norph, Junior Member on 22nd December 2015, 06:29 PM
Post Reply Email Thread
I currently have a Sony Z1 Compact which I think the battery thermal sensor is broken...

It all started with, I have a Euphoria OS with android lollipop 5.1 installed and one day I was copying videos into phone, and then during that time.... my phone sudden rebooted when I was transferring videos from my laptop, and not just normal reboot, it keep on rebooting every time it succeed on loading into the OS. (Yes it will reboot every time it reached the lock screen....)

And I also tried restoring a backup it was the same too... so I decided to charge the phone instead of letting reboot, but sadly it won't charge too! So I just decided to leave my phone to run dry and then only charge it back to see if it will work again. I can still enter fastboot and flashmode during this time.

After it ran dry, I can't charge it, I can't enter fastboot nor use flashtool to flash back to stock too, so I decided to spend some money on getting a battery replacement.

Once I got my battery replacement, I instantly flashed back stock (yup with some capacity in battery I can enter fastboot) and I just found out that when I plug my phone to charge it shows "Your device turned off due to overheating ,charging will continue once the device cools down." even know the battery isn't heating, so I felt bad for the old battery as I assume it was in good condition but the phone just refuses to charge it!

So after researching I ended up with, I think the battery thermal sensor is broken and I saw something such as kernel has setting that can disable battery throttle, but I know it's risky but I don't use my phone much, all I use it is for listening to music, messaging if I receive a SMS or maybe a short call which won't go more then 2mins.

I want to ask if I can actually disable thermal throttle via recovery because even now that I installed back to stock it's the same still ( I still get reboots after every time it loads finish the OS, weirdly for custom ROMs it will run finish till optimizing apps finish then only it will show the "Shutting down..." message ).

I can provide my TWRP backup of my Euphoria OS upon request and I hope that someone can help me out!
Thank you very much and I hope that you can help me out! (Sorry English isn't actually my native language but I checked twice for spelling errors so I hope you can understand my situation!)
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes