FORUMS
Remove All Ads from XDA

[ROM][OFFICIAL][pioneer][9] LineageOS 16.0

7,092 posts
Thanks Meter: 14,832
 
By LuK1337, Recognized Developer on 30th August 2018, 09:42 PM
Post Reply Email Thread


LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Download the latest build and gapps
  • Boot to recovery
  • Flash the latest build
  • Boot to recovery again
  • Flash gapps
  • Reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
XDA:DevDB Information
[ROM][OFFICIAL][pioneer][9] LineageOS 16.0, ROM for the Sony Xperia XA2

Contributors
LuK1337
Source Code: https://github.com/LineageOS

ROM OS Version: Windows 8 Mobile
ROM Kernel: Linux 4.x

Version Information
Status: Testing

Created 2018-08-30
Last Updated 2019-03-01
The Following 23 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
 
 
30th August 2018, 09:42 PM |#2  
LuK1337's Avatar
OP Recognized Developer
Flag Zamość
Thanks Meter: 14,832
 
Donate to Me
More
How to flash latest firmware
1. Download latest firmware with XperiFirm.
NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
Code:
for f in FILE_*; do unzip $f; done
unzip boot.zip -d boot
2. Go to the directory where the firmware got downloaded to and remove following files:
- kernel_X-FLASH-ALL-18AE_0x00.hash
- kernel_X-FLASH-ALL-18AE.sin
- persist_X-FLASH-ALL-18AE_0x00.hash
- persist_X-FLASH-ALL-18AE.sin
- system_other_X-FLASH-ALL-18AE_0x00.hash
- system_other_X-FLASH-ALL-18AE.sin
- system_other_X-FLASH-ALL-9B8D_0x00.hash
- system_X-FLASH-ALL-18AE_0x00.hash
- system_X-FLASH-ALL-18AE.sin
- system_X-FLASH-ALL-9B8D_0x00.hash
- userdata_X-FLASH-CUST-18AE.sin
- vendor_X-FLASH-ALL-18AE_0x00.hash
- vendor_X-FLASH-ALL-18AE.sin
- vendor_X-FLASH-ALL-9B8D_0x00.hash
3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
current-slot: _b
Finished. Total time: 0.001s
7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
Setting current slot to 'a'...
OKAY [ 0.012s]
Finished. Total time: 0.014s
or
Setting current slot to 'b'...
OKAY [ 0.012s]
Finished. Total time: 0.014s
8. Unplug usb cable and repeat steps: 3, 4
9. Profit?
The Following 3 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
31st August 2018, 02:45 PM |#3  
LuK1337's Avatar
OP Recognized Developer
Flag Zamość
Thanks Meter: 14,832
 
Donate to Me
More
Quote:
Originally Posted by Jozinek

Reccomended Gapps for this build?

dunno, just try any gapps you want.

btw I recommend downloading new build, I fixed wvm and camera no longer takes an eternity to launch.
The Following User Says Thank You to LuK1337 For This Useful Post: [ View ]
31st August 2018, 06:10 PM |#4  
Casserole's Avatar
Senior Member
Thanks Meter: 34
 
More
Does it use 4.9 kernel or 4.4?
31st August 2018, 06:11 PM |#5  
Stricted's Avatar
Senior Member
Flag Hesse
Thanks Meter: 1,095
 
Donate to Me
More
Quote:
Originally Posted by Casserole

Does it use 4.9 kernel or 4.4?

4.4
31st August 2018, 09:54 PM |#6  
techboy11's Avatar
Member
Thanks Meter: 17
 
Donate to Me
More
Unable to boot?
hello, thanks for this build. I have flashed the latest build in TWRP but for some reason keep getting thrown back into TWRP after flashing everything and rebooting. I'm not entirely sure why this is occurring.
31st August 2018, 10:11 PM |#7  
LuK1337's Avatar
OP Recognized Developer
Flag Zamość
Thanks Meter: 14,832
 
Donate to Me
More
Quote:
Originally Posted by techboy11

hello, thanks for this build. I have flashed the latest build in TWRP but for some reason keep getting thrown back into TWRP after flashing everything and rebooting. I'm not entirely sure why this is occurring.

Stop flashing twrp lol.
31st August 2018, 10:15 PM |#8  
techboy11's Avatar
Member
Thanks Meter: 17
 
Donate to Me
More
Quote:
Originally Posted by LuK1337

Stop flashing twrp lol.

I did not flash TWRP at first, but it still threw me into the default Lineage/Android recovery. Flashing TWRP or not doesn't make a difference for me.

Edit: I should mention the recovery screen I get without flashing TWRP says that my data is corrupt and I should try factory resetting or try booting again. Doing a factory reset option brings it to the same screen again.
31st August 2018, 10:36 PM |#9  
LuK1337's Avatar
OP Recognized Developer
Flag Zamość
Thanks Meter: 14,832
 
Donate to Me
More
Quote:
Originally Posted by techboy11

I did not flash TWRP at first, but it still threw me into the default Lineage/Android recovery. Flashing TWRP or not doesn't make a difference for me.

Edit: I should mention the recovery screen I get without flashing TWRP says that my data is corrupt and I should try factory resetting or try booting again. Doing a factory reset option brings it to the same screen again.

Try fastboot -w reboot.
The Following User Says Thank You to LuK1337 For This Useful Post: [ View ]
31st August 2018, 10:44 PM |#10  
techboy11's Avatar
Member
Thanks Meter: 17
 
Donate to Me
More
Quote:
Originally Posted by LuK1337

Try fastboot -w reboot.

That worked. Now boots. Thanks for your help!
The Following User Says Thank You to techboy11 For This Useful Post: [ View ] Gift techboy11 Ad-Free
1st September 2018, 10:15 AM |#11  
Senior Member
Thanks Meter: 63
 
More
Thanks dude
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes