FORUMS

Xperia XZ1 screen looks yellow compared other smartphones

227 posts
Thanks Meter: 62
 
By one-option, Senior Member on 10th November 2017, 10:00 AM
Post Reply Email Thread
Hi all:

I just got my Xperia XZ1, and I have noticed that the screen does looks yellow compared to Xperia XZ and other smartphones like LG G6 when the screen show white color.

I know that we can change the Blue color in the white color balance option to make the screen looks more blue like other smartphones.

but my question is """" Is All The XZ1 Units Screens Show The White Color More in The Yellow Side ? """""

to explain more ............ the white color in the XZ1 looks like yellow !!!!

the Xperia XZ1 screen is a very crisp and clear one, I do feel that colors are alive but I'm wondering if all XZ1 units have the same screen or my XZ1 screen have a problem and if there is a problem is it a software or hardware problem ???????
10th November 2017, 01:11 PM |#2  
Junior Member
Thanks Meter: 3
 
More
Change in Settings-> Display -> Color gamut -> sRGB professional
This solved for me the same yellowish white color on my XZ1 and colors looks more natural now.
10th November 2017, 02:25 PM |#3  
OP Senior Member
Thanks Meter: 62
 
More
Quote:
Originally Posted by pavitra.das

Change in Settings-> Display -> Color gamut -> sRGB professional
This solved for me the same yellowish white color on my XZ1 and colors looks more natural now.

I have done that, it doesn't work for me

this is a picture to compare my XZ1 with the LG G6, big difference
Attached Thumbnails
Click image for larger version

Name:	20171110_160329.jpg
Views:	1038
Size:	232.4 KB
ID:	4328564  
13th November 2017, 02:51 AM |#4  
Member
Thanks Meter: 25
 
Donate to Me
More
Quote:
Originally Posted by one-option

I have done that, it doesn't work for me

this is a picture to compare my XZ1 with the LG G6, big difference

The g6 looks a Bit greenish. try setting the whitebalance. I turned up the blue Level a lot
9th December 2017, 08:38 AM |#5  
OP Senior Member
Thanks Meter: 62
 
More
I think I was wrong after hard reset everything is ok


nice work Sony

I really like black colors in XZ1
13th January 2018, 10:58 AM |#6  
Member
Flag Chennai
Thanks Meter: 1
 
More
Quote:
Originally Posted by one-option

I think I was wrong after hard reset everything is ok


nice work Sony

I really like black colors in XZ1

Hey Even I have the same issue, My old Z2 is much natural n blue. I even kept my blue colour balance at the maximum 255 but still looks yellow compared to the z2's 85 blue. Did it really work after you've done a factory reset?
15th January 2018, 05:52 AM |#7  
Junior Member
Thanks Meter: 5
 
More
Adjust your white balance setting.
R - 0
G - 50
B - 150
The Following 4 Users Say Thank You to tummycj For This Useful Post: [ View ] Gift tummycj Ad-Free
24th January 2018, 11:32 AM |#8  
chrisftlse's Avatar
Senior Member
Flag Toulouse
Thanks Meter: 191
 
More
Quote:
Originally Posted by tummycj

Adjust your white balance setting.
R - 0
G - 50
B - 150

Thanks for sharing this settings.
My screen looks looks much better and more natural.

BTW. Any idea to know the oem screen brand name and version?
It could be good to compare and find if there is different screen model and which one looks yellowish 😉
The Following User Says Thank You to chrisftlse For This Useful Post: [ View ] Gift chrisftlse Ad-Free
10th March 2018, 11:22 PM |#9  
degraaff's Avatar
Senior Member
Thanks Meter: 146
 
More
I noticed that when switching between colour gamut modes, the display randomly gets a very red tint. Switching gamut again will restore normal white balance. Also, I find that the white of my xz1's display is very neutral. If I look at my xz1 after having looked at a more blueish display of my Z3 Compact for a while, the xz1 will look yellowish because my eyes have adapted to the cold blue tint of the z3 compact display. But after letting my eyes adapt to my xz1 again, its display beats my z3 compact out of the water in terms of white balance.

Also, blueish screens are worse for your sleep
11th March 2018, 06:37 PM |#10  
Senior Member
Thanks Meter: 132
 
More
Quote:
Originally Posted by tummycj

Adjust your white balance setting.
R - 0
G - 50
B - 150

Thanks, but the colors are to "cold".
Best I could get, trying to match to a good calibrated XZ screen. (XZ screen targeted to 6500k).
For (now) my settings are, with color gamut set to standard:
R 142
G 0
B 179
21st May 2018, 06:25 AM |#11  
Senior Member
Flag Kuala Lumpur
Thanks Meter: 18
 
More
R 42
g 108
b 255


Quote:
Originally Posted by snake218

thanks, but the colors are to "cold".
Best i could get, trying to match to a good calibrated xz screen. (xz screen targeted to 6500k).
For (now) my settings are, with color gamut set to standard:
R 142
g 0
b 179

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes