FORUMS
Remove All Ads from XDA

SOLUTION - Proximity Sensor Fix for Z Ultra - Give a try

18 posts
Thanks Meter: 4
 
By itsmeluigi, Junior Member on 24th April 2017, 10:08 PM
Post Reply Email Thread
This is an fix I've find for my Z Ultra, maybe It works for
your's too.

When I lift up a little bit the USB-Port, the Prox-sensor
worked again.

You can slightly push with your fingertip or with an USB cable plugged in.

When this makes the sensor working, put a little thin piece of plastic direct right under the USB Port.
Put It between the USB Port and the bezel, so that the USB connector stays that little up.

You can give feedback if it works or not.
The Following 3 Users Say Thank You to itsmeluigi For This Useful Post: [ View ] Gift itsmeluigi Ad-Free
 
 
26th April 2017, 07:22 PM |#2  
SUPERUSER's Avatar
Senior Member
Thanks Meter: 362
 
More
Quote:
Originally Posted by itsmeluigi

This is an Fix I've find for my Z Ultra, maybe It works for
yours too.

When I liftet up a little bit the USB-PORT, the Prox-Sensor
worked again.

You can slightly push with your fingertip or with an USB cable plugged in.

When this makes the Sensor working, put a little thin piece of plastik direct right under the USB Port.
Put It between the USB Port and the Bezel so that the USB connector stays that little liftet up.

You can give feedback if it works or not.

Hey. You're a god damn artist!
I tried your idea earlier today before I put my phone together and I didn't really put any effort to it.
But I made a phone call and the sensor works just fine!

You can find my thread here: https://forum.xda-developers.com/xpe...s-rom-t3536343
27th April 2017, 07:53 PM |#3  
Junior Member
Flag Kochi
Thanks Meter: 0
 
More
Quote:
Originally Posted by SUPERUSER

Hey. You're a god damn artist!
I tried your idea earlier today before I put my phone together and I didn't really put any effort to it.
But I made a phone call and the sensor works just fine!

You can find my thread here: https://forum.xda-developers.com/xpe...s-rom-t3536343

Wow, thanks
27th April 2017, 08:37 PM |#4  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by SUPERUSER

Hey. You're a god damn artist!
I tried your idea earlier today before I put my phone together and I didn't really put any effort to it.
But I made a phone call and the sensor works just fine!

You can find my thread here: https://forum.xda-developers.com/xpe...s-rom-t3536343

Hello, would you please tell me which Rom you are using?
27th April 2017, 08:51 PM |#5  
SUPERUSER's Avatar
Senior Member
Thanks Meter: 362
 
More
Quote:
Originally Posted by AmeyDude

Hello, would you please tell me which Rom you are using?

The last cm nightly build for togari: https://archive.org/download/cmarchive_nighlies before they shut down cyanogenmod.
I use SensorDisabler: http://repo.xposed.info/module/com.m...er.disableprox to fake a maximum distance.
I reset the value to default in the app and made a call to see what would happen. Before the screen just went dark as soon as I pressed the dial button. But now the screen stays on and shuts off if I hover my finger over the sensor and turns back on when I remove the finger.

I like to point out that my phone behaved the same way regardless of which rom I flashed. Its was not an issue caused by cyanogenmod.
4th May 2017, 04:24 PM |#6  
Junior Member
Thanks Meter: 1
 
More
Wow thank you for sharing your solution. I've been trying to fix my proximity sensor but found no good solution until I found your thread. Thank You again!
The Following User Says Thank You to jazzibrahim For This Useful Post: [ View ] Gift jazzibrahim Ad-Free
6th May 2017, 02:21 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Need to fix my camera help!
I have Z ultra phone and i have replaced its camera with Z1's new replacement camera the device is not booting up, i think I need to install Z1 camera software into my Z ultra phone but I am totally lost as I don't know how to do that, I just want to install camera leaving the Z ultra rom untouched, please someone help me.
12th May 2017, 06:42 PM |#8  
Junior Member
Flag Harare
Thanks Meter: 1
 
More
i fixed mine by opening and cleaning the sensors with a cloth
12th May 2017, 07:57 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by itsmeluigi

This is an Fix I've find for my Z Ultra, maybe It works for
yours too.

When I liftet up a little bit the USB-PORT, the Prox-Sensor
worked again.

You can slightly push with your fingertip or with an USB cable plugged in.

When this makes the Sensor working, put a little thin piece of plastik direct right under the USB Port.
Put It between the USB Port and the Bezel so that the USB connector stays that little liftet up.

You can give feedback if it works or not.

What's a liftet?
13th May 2017, 02:23 PM |#10  
OP Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by Soul Annihilator

What's a liftet?

Lift up.

Sorry for my bad english.
15th June 2017, 08:11 PM |#11  
Junior Member
Thanks Meter: 1
 
More
could someone show me a photograph to see how to do it? thx a lot.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes