FORUMS
Remove All Ads from XDA

[STOCK ROM] Xperia Z (C6603) 10.4.1.B.0.101 Rooted init.d & Dual Recovery

56 posts
Thanks Meter: 41
 
By rjhellel, Member on 11th February 2014, 01:56 AM
Post Reply Email Thread
STOCK ROM Xperia Z (C6603) 10.4.1.B.0.101 Generic UA (Unbranded Ukraine)


Hi all, this is my first take at creating a flashable zip which I tested and found working on my Unlocked Bootloader Xperia Z (C6603)


Stock ROM uploaded by @smardu http://forum.xda-developers.com/show...6&postcount=68

Created using @[NUT]'s DIY Guide http://forum.xda-developers.com/show....php?t=2307311 to create a flashable zip rooted with SuperSU, init.d & BusyBox built in with @[NUT]'s XZ Dual Recovery v 2.7.62

I have tested it on my Unlocked Bootloader Xperia Z (C6603) and found working. I have NOT tested on Locked Bootloader. If you are willing to try and let me know!


How I updated:

1. Make a nandroid backup just in case
2. Flash the flashable zip using PhilzTouch (only tested using PhilzTouch Recovery) - I am not sure if it will work on other recoveries
3. Once completed, do not restart your phone, power off the phone instead
4. Connect in Flashmode and Flash the Kernel
5. Reboot and once loaded into system, it should start showing Android is upgrading

I did not clear data or cache before flashing and so far it is working fine with me.

I have also included links to @[NUT]'s latest XZ Dual Recovery v 2.7.85-BETA.flashable as well as the working Xposed Installer Framework for 4.3.


DOWNLOADS:

GDrive Links:

ROM

KERNEL

XposedInstaller

xzdualrecovery2785

CREDITS:

@[NUT] for the DIY Guide and Dual Recovery
@smardu for the Stock ROM 10.4.1.B.0.101 Generic UA (Unbranded Ukraine)
@rovo89 for Xposed Framework
The Following 12 Users Say Thank You to rjhellel For This Useful Post: [ View ] Gift rjhellel Ad-Free
 
 
11th February 2014, 04:26 AM |#2  
Member
Thanks Meter: 5
 
More
Thanks!
tested and it works
11th February 2014, 06:54 AM |#3  
Account currently disabled
Flag straya kienttt
Thanks Meter: 476
 
More
does the zip contain the kernel too?
11th February 2014, 07:19 AM |#4  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by spazzy1912

does the zip contain the kernel too?

no you have to flash that with flashtools
11th February 2014, 08:31 AM |#5  
Account currently disabled
Flag straya kienttt
Thanks Meter: 476
 
More
google chrome says this is malware..
11th February 2014, 08:41 AM |#6  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by spazzy1912

google chrome says this is malware..

did just scan it all again with bitdefender total security 2014 and it did say is clean.
The Following User Says Thank You to RaZieLRaH For This Useful Post: [ View ] Gift RaZieLRaH Ad-Free
11th February 2014, 09:00 AM |#7  
Senior Member
Flag Ipoh
Thanks Meter: 99
 
More
Ive download it using idm and when its reach 99.8% its say "something has occured frm dropbox please download again" if this is not my wife laptop i swear to god ive smack it on the wall. It took me 2 hour to reach 99%..

Sent From My Sony Xperia Yuga
11th February 2014, 09:54 AM |#8  
OP Member
Flag London
Thanks Meter: 41
 
More
Quote:
Originally Posted by emeemisri

Ive download it using idm and when its reach 99.8% its say "something has occured frm dropbox please download again" if this is not my wife laptop i swear to god ive smack it on the wall. It took me 2 hour to reach 99%..

Sent From My Sony Xperia Yuga

Can you try downloading without IDM? I am currently uploading the files to Google Drive as well.
The Following User Says Thank You to rjhellel For This Useful Post: [ View ] Gift rjhellel Ad-Free
11th February 2014, 02:37 PM |#9  
Senior Member
Thanks Meter: 116
 
More
I got a weird issue after flashing this rom..when my phone booted up for 1st time i got this repair icon in my screen, with the loading blue bar on the bottom (1st time i see this on my phone)...after a few minutes it booted up normally, but the only issue i got is that i cannot install any app through my file explorer...only through playstore..when i try to install one app through es explorer eg. i get "sorry,no application error".
Also, xposed framework has issues too..i can view my mods and they are applied to my phone, but when i try to update those who need update, xposed is crashing...so i can only use mods that are already installed through my previous rom.
Anyone has any idea what i did or what maybe went wrong?
11th February 2014, 03:43 PM |#10  
OP Member
Flag London
Thanks Meter: 41
 
More
Quote:
Originally Posted by akisg

I got a weird issue after flashing this rom..when my phone booted up for 1st time i got this repair icon in my screen, with the loading blue bar on the bottom (1st time i see this on my phone)...after a few minutes it booted up normally, but the only issue i got is that i cannot install any app through my file explorer...only through playstore..when i try to install one app through es explorer eg. i get "sorry,no application error".
Also, xposed framework has issues too..i can view my mods and they are applied to my phone, but when i try to update those who need update, xposed is crashing...so i can only use mods that are already installed through my previous rom.
Anyone has any idea what i did or what maybe went wrong?

What ROM were you previously on? Was it Odexed or Deodexed? And did you wipe data/cache/dalvik before flashing or did you dirty flash? Might work if you do a clean install.
11th February 2014, 03:51 PM |#11  
Senior Member
Thanks Meter: 116
 
More
OK, i just figured out my mistake...
I did everything from scratch and everything works flawless now..so i can confirm it is working on a locked bootloader..
So for your interest if someone does the same mistake as i did, just when flashing the kernel .ftf don't exclude anything..that caused my issues i think

---------- Post added at 03:51 PM ---------- Previous post was at 03:46 PM ----------

Quote:
Originally Posted by rjhellel

What ROM were you previously on? Was it Odexed or Deodexed? And did you wipe data/cache/dalvik before flashing or did you dirty flash? Might work if you do a clean install.

I was on 4.3 odexed NCB stock, prerooted. I wiped only cache and dalvik before flashing. I messed up my system by trying another flashable rom that failed during flashing, and then i tried this method, zipped flashed fine, but i unchecked everything except kernel when flashing the .tft. Although i reflashed for 2nd time in a row the .tft, system still messed up. So i did everything from the beginning and now it works fine...
Glad i didn't had to wipe my data in the end...

Thanks for this rom/guide
The Following User Says Thank You to akisg For This Useful Post: [ View ] Gift akisg Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes