Remove All Ads from XDA

[Q] Need help making Z with broken screen usable

26 posts
Thanks Meter: 3
By oopled, Junior Member on 3rd April 2014, 12:02 AM
Post Reply Email Thread
I have a Z here with broken screen/digitizer. ADB is not enabled, I want to enable through any means and then config it via vnc or similar with the long term goal of turning it into a headless mediaplayer(xbmc).

I am able to control it using the painstaking method of plugging in a usb kbd or mouse, doing some blind movements and then swapping that out for an mhl/hdmi cable so I can see where I am at.

With that I have been able to disable the lock screen, start terminal emulator, get into developer options and some other things.

The phone had previously been rooted and had adb enabled but my SO had updated it to stock OTA 10.4.B.0.569 (4.3)before The Drop without my knowing so I lost both of those.

So, the problem...I cannot enable adb. I can get into the developer menu but the options are greyed out. I cannot select anything. I don't know why. I suspected it was because there was a usb device plugged in (either mouse/kbd or screen) but I have checked a Z tablet running 4.2 and a Z1, which is running 4.4.2 and you can enable usb debugging with a device plugged in on both those. I tried toggling dev options off/on, but no difference. Annoying.
Because I have lost root I cannot enable it via terminal either.

I unlocked the bootloader and installed a custom recovery (Advance Stock Kernel with Recovery v11 (FW:*10.4.B.0.569}*) from this this thread, linked from [HOW TO] Root 10.4.B.0.569 [ONLY UNLOCKED BOOTLOADER]
In doing this the phone was reset to defaults, but it made no difference to the Dev Options being disabled. I can get into it, but most options are still greyed out, so still no adb

So now I am stuck. With no screen, I have no idea what steps to take to flash the SuperSU zip file from recovery. This is where I need some help
I have no problem wiping the phone, installing custom roms etc. but I need to get root and adb working somehow.
  • Is there any reason why USB debugging, amongst others, in Developer Options might be disabled?
    Possibly a permissions problem? Fixable without root?
  • Could someone running the same recovery possibly detail the steps needed using the hardware buttons (up, up, power, down, power, etc) to flash supersu so I can get root?
    Assume blank external sdcard with only that zip on it
  • Could someone recommend a custom rom that is safe to install on that software version that has root and maybe adb enabled?
  • Would it be possible to flash that from fastboot?
    afaik, only stock/signed roms can be installed that way?
  • If I got adb working, could I sideload a rom/zip from that recovery or another non-touch recovery(swipe to proceed is definately out)?
  • Does anyone have any suggestions, ideas or alternative methods to attempt, in order to get control over the device?

thanks in advance to anyone that can help!
Post Reply Subscribe to Thread

adb, broken screen, recovery, root, xperia z

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes