FORUMS
Remove All Ads from XDA

[Q] problem with compass and gyroscope

296 posts
Thanks Meter: 11
 
By TF85, Senior Member on 17th April 2015, 09:04 PM
Post Reply Email Thread
Hello,
After replacing the screen of my xperia Z1 in a mobile store,the Z1 doesn’t find the compass hardware and the gyroscope doesn’t work yet. Is their a cable missed or some hardware is breackdown?
Thank you for help
 
 
19th April 2015, 07:03 AM |#2  
Junior Member
Thanks Meter: 1
 
More
I have also had same problem after my lcd change. I have solved my problem. Can you check and tell all the sensors are not working or only the compass and gyroscope.

Sent from my C6902 using XDA Free mobile app
19th April 2015, 09:55 AM |#3  
zevzek's Avatar
Member
Thanks Meter: 22
 
More
After having my lcd replaced I noticed my sensors stopped working. Well actually compass has stopped working completely but gyroscope, accelerometer, proximity, and light sensor sometimes stop working, and after a reboot sometimes they work for some time.
Also I noticed that in antutu benchmark app it says not supported for not working sensors, except for once when it showed me the right model for the magnetometer.

It'd be very helpful if you told us what you did so we can try the same
19th April 2015, 11:32 AM |#4  
Junior Member
Thanks Meter: 1
 
More
I also had the same problem which you described. In my case compass was the main problem. In my case Compass won't show any reading and other sensors will also stop working once I checked the compass.

The compass was in the main flux cable. Once I have replaced the cable my compass and others sensors also started fine. I suggest you to replace the main flux cable.

Sent from my C6902 using XDA Free mobile app
The Following User Says Thank You to vrajessh For This Useful Post: [ View ] Gift vrajessh Ad-Free
19th April 2015, 08:22 PM |#5  
OP Senior Member
Flag STRASBOURG
Thanks Meter: 11
 
More
Hello,
Thank you very much for your answers.
The main cable has dimension of the Xperia Z1 ?
The cable picture in ebay store :
http://i.ebayimg.com/00/s/MTIwMFgxNjAw/z/njcAAOxycgVTjKnW/$_57.JPG
Thanx
19th April 2015, 09:15 PM |#6  
Junior Member
Thanks Meter: 1
 
More
Yes that was the cable. Compass present on the opposite side of the keys area. You need to change the cable.

Sent from my C6902 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes