FORUMS

[ABANDONED][8/11][ROM][N] LineageOS 14.1 || UNOFFICIAL

1,126 posts
Thanks Meter: 2,380
 
By drakonizer, Retired Forum Moderator on 8th November 2016, 11:05 AM
Post Reply Email Thread
Code:
#include <std_disclaimer.h>
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */
LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOSGithub repo.

These are unofficial (and probably unstable) builds of CyanogenMod/LineageOS 14.1 (which is a work in progress) by me, using sonyxperiadev sources.

Features:
These builds are completely based on CyanogenMod/LineageOS sources, and contain no modification of framework from my end.

WORKING:
Mostly Everything
DEEP SLEEP

NOT WORKING/BUGGY:
Camera. It works well, but only in good lighting. New blobs will fix this.
Video recording is broken.

INSTRUCTIONS
-> Backup all important files
-> Boot into recovery
-> Wipe data/Factory Reset
-> Flash ROM
-> Flash GApps (optional) (I use OpenGApps)
-> Reboot

DOWNLOAD:
All builds can be downloaded from my AndroidFileHost folder linked below. LineageOS builds my markakash can be found in his post on this thread (use the search function for once).

ROM
GApps

CHANGELOG:
Code:
07-November-2016
-> Initial Release

SOURCES:

-> https://github.com/SonyCM
-> https://github.com/SonyAosp
-> https://github.com/sonyxperiadev

Credits to all the developers who have contributed to these projects including jerpelea, alviteri, munjeni and erikcas.



The best way to appreciate someone's work is by pressing that Thanks button


XDA:DevDB Information
LineageOS 14.1, ROM for the Sony Xperia Z1

Contributors
drakonizer, markakash
ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
ROM Firmware Required: Must have flashed the latest stock (.236) ROM at least once
Based On: LineageOS

Version Information
Status: Beta

Created 2016-11-08
Last Updated 2017-07-03
The Following 43 Users Say Thank You to drakonizer For This Useful Post: [ View ] Gift drakonizer Ad-Free
8th November 2016, 11:39 AM |#4  
Michael4407's Avatar
Member
Flag Hanoi
Thanks Meter: 5
 
More
Hot damn, time to get flashing! Nice work, man
8th November 2016, 11:44 AM |#5  
lm/\/trix's Avatar
Member
Flag Tehran
Thanks Meter: 14
 
More
which Gapps should we flash on this CM14 ROM?
8th November 2016, 12:10 PM |#6  
Member
Thanks Meter: 53
 
More
First of all,
Thanks a lot!!
Second, total views ram is 1,4 [try this fix ( https://github.com/SuperLamic/device...eb776017eed63b )]
8th November 2016, 12:52 PM |#7  
drakonizer's Avatar
OP Retired Forum Moderator
Flag Death Star
Thanks Meter: 2,380
 
Donate to Me
More
Quote:
Originally Posted by Masterblop

First of all,
Thanks a lot!!
Second, total views ram is 1,4 [try this fix ( https://github.com/SuperLamic/device...eb776017eed63b )]

Yeah I know about that. I forgot to add that. Next build will fix it. It will also include the Snap camera app, which works better in my opinion.
The Following 4 Users Say Thank You to drakonizer For This Useful Post: [ View ] Gift drakonizer Ad-Free
8th November 2016, 12:55 PM |#8  
santeria27's Avatar
Senior Member
Flag Recklinghausen
Thanks Meter: 48
 
More
Mega thx for cm14.1 i will testet

Sent from my Xperia Z1 using XDA-Developers mobile app
8th November 2016, 02:40 PM |#9  
monnett's Avatar
Senior Member
Flag bandung
Thanks Meter: 59
 
More
Awesome one . will try later
8th November 2016, 03:03 PM |#10  
Member
Thanks Meter: 34
 
More
Hello .. thank you so much for your work .. just a small report here .. i flashed the ROM as you instructed .. but i only get a black screen with no Sony logo or anything ... recovery's LED changing from pink to orange and then just a black screen .. the phone is working though i can lock and unlock it but with the black screen .. i tried to flash it with and without the modem (C6902) .. flashed with and without GApps .. and i tried to flash it on the top of CM12.1 clean and dirty ... but still the same issue ... a small advice would be so much appreciated .. Thank you
8th November 2016, 03:03 PM |#11  
brickhayabusa's Avatar
Senior Member
Flag Mexico, D.F
Thanks Meter: 23
 
More
https://github.com/sonyxperiadev/ker...75feec7a24e312
Do you add this?
I have too dark panel.
PD: Fix the black screen too.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes