FORUMS
Remove All Ads from XDA

[FIX] No HDCP error Miracast (Ezcast) while screen mirroring all apps fix

27 posts
Thanks Meter: 41
 
By themightydeity, Junior Member on 31st May 2015, 02:22 PM
Post Reply Email Thread
23rd July 2015, 09:33 AM |#11  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by zaryab360

How you do this any tutorial?
For adb

Edit: Got it!
Working flawlessly!


i also got error msg "device not found" while entering adb command ... can u plz me how to do it??
 
 
2nd August 2015, 02:21 AM |#12  
Member
Thanks Meter: 10
 
More
OMG, i waited this so long, thanks a lot
z1c 5.0
28th August 2015, 09:57 AM |#13  
Senior Member
Thanks Meter: 44
 
More
Hi, after doing everything OP described my phone went on to bootloop after restart. I restored everything from TWRP backup and tried again, same thing happened after changing the build.prop and rebooting (now I didn't even change wfdconfig.xml, so the changed build.prop must be causing the bootloop, right?). Am I doing something wrong?
28th August 2015, 06:06 PM |#14  
Senior Member
Flag Fukushima
Thanks Meter: 250
 
Donate to Me
More
adb shell chmod 644 /system/build.prop

Sent from my GT-I9305 using XDA Free mobile app
29th August 2015, 06:52 PM |#15  
Senior Member
Thanks Meter: 44
 
More
thanks a lot s107ken, that solved the bootloop problem, but still screen mirroring doesn't work properly and gives me HDCP error. I am on 5.1.1 btw... could that be the real issue here?
1st October 2015, 10:19 PM |#16  
Senior Member
Thanks Meter: 38
 
More
Work on Xperia M4 Aqua with unlocked bootloader!

Display mirroring on tv in 720p only, not in 1080p but I'm hapy

Thanks!
3rd October 2015, 09:04 AM |#17  
Abhi_Josh's Avatar
Member
DreamLand
Thanks Meter: 26
 
More
Followed steps as they are ... No difference running existenz premium 3.5v Z2
3rd October 2015, 10:03 AM |#18  
Senior Member
Thanks Meter: 38
 
More
Are there way to change resolution? I see some rows about resolution in wfdconfifg.xlm

Enviado desde mi E2303 mediante Tapatalk
17th October 2015, 06:39 AM |#19  
Junior Member
Thanks Meter: 0
 
More
Thanks, that works for me.
I skiped the last step, but it worked for me...
8th December 2015, 11:53 AM |#20  
Darastrixi's Avatar
Junior Member
Thanks Meter: 0
 
More
Fixed everything!
Can't believe it! That fixed everything!
Few things I want to note:
I did this on a Unlocked / Rooted Xperia Z4 LTE (v.260)
I followed all the steps listed in the original post and ended up in a bootloop.
Using the method @s107ken mentioned above ( adb shell chmod 644 /system/build.prop ) in TWRP fixed the bootloop.

Can confirm this is still working on the newer devices. Great to be able to cast to large screens again. Thanks @themightydeity and @s107ken
5th January 2016, 12:05 PM |#21  
Junior Member
Thanks Meter: 6
 
More
Sup all. Thanks for the original post, I'm gonna type out the procedure for Xperia M4 Aqua E2303 with unlocked bootloader and root, SW version 26.1.A.2.167.

I had to use "Kernel Adiutor" (not a typo) since I'm unable to directly edit the build.prop file; The kernel in this SW revision is compiled with secure flag 1 and i presume that's the primary issue with directly editing the files from "/system". Also, the rootkit for this phone uses SuperSU so I had to install BusyBox cause Kernel Adiutor uses that package to run root functions; Simply installed the apk then clicked "Install" in the app after the analysis completed.

I did this with "Unknown sources" in "Security" and USB debugging enabled. Also, the phone needs to be connected to your PC.
  1. In Kernel Adiutor use the "Build prop Editor", click the + icon, make a backup then add the "persist.debug.wfd.appmonitoring" for Key and "1" for Value.
  2. Type the following in your OS shell:
    • adb shell
    • su
    • chmod 644 /system/build.prop
  3. Done, reboot phone.

Should work
Post Reply Subscribe to Thread

Tags
fix, hdcp, miracast, mirror, xperia

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes