Remove All Ads from XDA

[Q] Headphones not working anymore

1 posts
Thanks Meter: 0
By radshark, Junior Member on 29th August 2014, 12:52 AM
Post Reply Email Thread
I got my z2 last Tuesday and my headphones (Logitech UE 350) were working perfectly until I tried using them today. For some reason they aren't being recognized anymore and the music just keeps playing through the phones speakers.
I tried plugging them into my old iphone and they work fine. I also tried plugging in another pair (Shure SE215) into both phones and they work fine. Except on the z2 it makes a clicking sound whenever I change songs now.
Does anybody know any way to fix this? Or could it be a faulty headphone jack?
29th August 2014, 01:17 AM |#2  
Devzz's Avatar
Senior Member
Thanks Meter: 28
Could be a number of things mate. Firstly, check and see the headphones are not physically damaged and even make sure that the microhpones in the in-ear pieces aren't affected by water exposure. Next check the headphones out by moving the wire around while they're plugged in and see how the sound comes out and if the phone reacts to any movements. When I used my phone in water even after hours of drying the headphone jack still wasn't dry so even the slightest movement switched tracks etc. Alternatively, it could be a headphone jack fault in the sense that it may be shorting? Or the 3.5mm 5pin connector on the headphones itself is damaged. It could also simply be a software glitch. Go into "Sounds" in your settings and change what kind of accessory it detects the headphones as. Try "Other", it may solve your problems. Alternatively take it into a Sony store or a phone shop and see if there's anywhere with a similar headset which you could test out.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes