FORUMS
Remove All Ads from XDA

Fix for bad sound recording in camcorder :)

42 posts
Thanks Meter: 9
 
By gavranpero, Member on 10th January 2016, 10:05 PM
Post Reply Email Thread
Hello there! Since I bought this phone I've always had sound problems while using camcorder. I used the first and, probably, the only method to fix it (change number ACDBID 545:2 to ACDBID 528:2), but it wasn't good enough. The sound was too quiet on records, and it wasn't really clear. For a while now I've been trying to fix it and I thought of trying to record sound by using only one microphone. The other microphone is no longer used. As a result, I got video records with clear and loud sound. Here is what I did. I changed this

Code:
SectionDevice
	Name "Camcorder Stereo"
	Comment "Dual MIC recording device"

	EnableSequence
		'SLIM_0_TX Channels':0:Two
		'SLIM TX7 MUX':0:DEC4
		'DEC4 MUX':0:ADC3
		'DEC4 Volume':1:66
		'SLIM TX8 MUX':0:DEC7
		'DEC7 MUX':0:ADC1
		'DEC7 Volume':1:85
		'ADC3 Volume':1:100
		'ADC1 Volume':1:100
	EndSequence

	DisableSequence
		'SLIM TX7 MUX':0:ZERO
		'DEC7 MUX':0:ZERO
		'SLIM TX8 MUX':0:ZERO
		'DEC3 MUX':0:ZERO
		'ADC3 Volume':1:0
		'ADC1 Volume':1:0
	EndSequence

	ACDBID 545:2
into this

Code:
SectionDevice
	Name "Camcorder Stereo"
	Comment "Dual MIC recording device"

	EnableSequence
		'SLIM_0_TX Channels':0: One
		'SLIM TX7 MUX':0:DEC7
      'DEC7 MUX':0:ADC1
		'DEC7 Volume':1:85
		'ADC1 Volume':1:100
	EndSequence

	DisableSequence
		'SLIM TX7 MUX':0:ZERO
		'DEC7 MUX':0:ZERO
		'ADC1 Volume':1:0
	EndSequence

	ACDBID 528:2
For some unknown reason, code line ''''SLIM_0_TX Channels':0: One'' is not displayed correctly inside the wrap code tags. So you need to move the word 'One' one space to the left to get the correct code line.

If you don't want to manually change code lines, you can download the whole file from these links

https://drive.google.com/file/d/0B0f...ew?usp=sharing

https://mega.nz/#!VwcyyBya!EmkmzPx2w...0U8KIwB7_tHtZU

and replace them with the existing file at the location system/etc/snd_soc_msm.

I hope this has been helpful.
The Following 5 Users Say Thank You to gavranpero For This Useful Post: [ View ] Gift gavranpero Ad-Free
17th February 2016, 11:10 AM |#2  
Junior Member
Thanks Meter: 0
 
More
I am very Happy with this
Thank you very much

I have been waiting for this since purchase.
I was not satisfy with sound while recording videos.
I went to Consumer Court and even won, but the problem still remain same.

Now I my phone is perfect, Thanks to you.

I can now record videos whenever I want.

Thank you
17th February 2016, 05:25 PM |#3  
Senior Member
Thanks Meter: 257
 
More
works also on CM12 or CM13? Can you make a flashable zip? (and with the original for recovery back to original just in case)

thx!!!!
19th February 2016, 12:00 PM |#4  
Daedroza's Avatar
Recognized Developer
Thanks Meter: 1,029
 
Donate to Me
More
Extraordinary. The same fix I think was also given by xenius9 long ago.
BTW combined this with volume boost
I can get good audio mic recording in camera and nice loud volume too!
5th March 2016, 01:49 AM |#5  
LaudaDev's Avatar
Member
Flag Novi Sad
Thanks Meter: 10
 
More
I tried this fix on .283 4.4.4 version and it doesn't work. I have no sound at all after this fix.
So this works only for LP?

Edit: It was my mistake...I forgot to remove the space for the word "One". Works fine now, thanks.
4th August 2019, 10:15 AM |#6  
Junior Member
Thanks Meter: 0
 
More
What apps do i need to do this? I have root.
14th September 2019, 10:13 PM |#7  
OP Member
Flag Banja Luka
Thanks Meter: 9
 
More
Root file manager or similar.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes