Remove All Ads from XDA

Android 9.0 uses xposed solutions

28 posts
Thanks Meter: 112
 
By xiaoxiaozy, Junior Member on 13th January 2019, 04:57 PM
Post Reply Email Thread
11th January 2020, 06:58 PM |#1081  
Question Hi 👋
After updating I get "Framework is installed but not active" error, it is active and modules are working.
In the description of the update written :"Hotfix: Disable minify to fix not active", but I can't find this option.
Can someone explain to me how to disable it?
Thanks
12th January 2020, 11:38 AM |#1082  
Senior Member
Thanks Meter: 242
 
More
Quote:
Originally Posted by D_Vovan_238

After updating I get "Framework is installed but not active" error, it is active and modules are working.
In the description of the update written :"Hotfix: Disable minify to fix not active", but I can't find this option.
Can someone explain to me how to disable it?
Thanks

It's disabled by default, there's no option afaik.
Have you tried a clean install?
12th January 2020, 11:54 AM |#1083  
Phone Hi 👋
Quote:
Originally Posted by Ænimal

It's disabled by default, there's no option afaik.
Have you tried a clean install?

Thank you for answer.
No I simply updated the app, always using latest framework beta.
But when I downgrade the app and reupdate everything is fine until I reboot the device.
12th January 2020, 07:27 PM |#1084  
Smile Now everything works fine.
After clean install everything works fine.
Thanks.

Edition:

After I rebooted 3 times my device the problem appeared other time, still get "Framework is installed but not activated " warning .
14th January 2020, 03:05 AM |#1085  
Rx8Driver's Avatar
Senior Member
Flag My City
Thanks Meter: 1,276
 
Donate to Me
More
Quote:
Originally Posted by freeza

Anyone getting optimizing apps almost every reboot on a Galaxy note 10+ Android 9.0?

It's only cuz of that garbage Note 10 lol


And good grief, they gave you RD around here since I been gone??? Oh boy, what's the world coming to??? hahaha....congrats brother!
The Following User Says Thank You to Rx8Driver For This Useful Post: [ View ] Gift Rx8Driver Ad-Free
14th January 2020, 02:12 PM |#1086  
stilflip's Avatar
Member
Thanks Meter: 6
 
More
Hello there,

I tried to install it on my Sony Xperia XZ2 Compact (I want installe XPrivacyLUA) following this tutorial and it failed. I succesfully installed Riru Core from Magisk, but after installing EdXposed, I get a bootloop

I used : magisk-EdXposed-SandHook-v0.4.6.0_beta.4471.-release.zip and i didn't try magisk-EdXposed-YAHFA-v0.4.6.0_beta.4471.-release.zip
Which is the difference between those two by the way ?

Do you have any idea about my problem please ?
14th January 2020, 02:48 PM |#1087  
Senior Member
Thanks Meter: 242
 
More
Quote:
Originally Posted by stilflip

Hello there,

I tried to install it on my Sony Xperia XZ2 Compact (I want installe XPrivacyLUA) following this tutorial and it failed. I succesfully installed Riru Core from Magisk, but after installing EdXposed, I get a bootloop

I used : magisk-EdXposed-SandHook-v0.4.6.0_beta.4471.-release.zip and i didn't try magisk-EdXposed-YAHFA-v0.4.6.0_beta.4471.-release.zip
Which is the difference between those two by the way ?

Do you have any idea about my problem please ?

Most likely your problem is sepolicy-related as well as it has been for many others (can't say for sure cause I don't know what Magisk version you're on).

Since you're planning to use XprivacyLua, you're better of with YAHFA. If you're using official Magisk 20.3 I'd suggest you try this Edxposed canary release, which should be working fine:
https://ci.appveyor.com/api/buildjob...wy-release.zip
The Following 2 Users Say Thank You to Ænimal For This Useful Post: [ View ] Gift Ænimal Ad-Free
14th January 2020, 02:56 PM |#1088  
stilflip's Avatar
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by Ænimal

Most likely your problem is sepolicy-related as well as it has been for many others (can't say for sure cause I don't know what Magisk version you're on).

Since you're planning to use XprivacyLua, you're better of with YAHFA. If you're using official Magisk 20.3 I'd suggest you try this Edxposed canary release, which should be working fine:
https://ci.appveyor.com/api/buildjob...wy-release.zip

Thanks for your quick answer !

I'm currently using Magisk 20.3 indeed. I'll give a shot this week. If I get a bootloop again, I'll try to uninstall EdXposed from TWRP I guess.

Thanks again !
14th January 2020, 04:38 PM |#1089  
pep086's Avatar
Member
Thanks Meter: 21
 
More
Canary 4497 yahfa works on Android 10 / s10 /magisk 20.2
The only issue is greenify stopped working xd
The Following User Says Thank You to pep086 For This Useful Post: [ View ] Gift pep086 Ad-Free
14th January 2020, 07:54 PM |#1090  
Rx8Driver's Avatar
Senior Member
Flag My City
Thanks Meter: 1,276
 
Donate to Me
More
Quote:
Originally Posted by D_Vovan_238

After clean install everything works fine.
Thanks.

Edition:

After I rebooted 3 times my device the problem appeared other time, still get "Framework is installed but not activated " warning .

I had this same things happen to me when installing on an old Galaxy Tab A, here's a little it of BG:


-Tab A was official with Android N 7.1.1
- ODIN flashed TWRP 3.2.1-0 lineage relase from the 15.1 thread
-first, flashed magisk 20.3 on stock rom to make sure it was going to work on my base version
- I found a TW-based ROM (Tab A is Samsung after all) that was 7.1.1 but the WiFi didn't work and I wasn't interested in spending much time on a Nougat based ROM, so I immediately went back to TWRP and flashed LineageOS 16.0 Pie based ROM (on top of my 7.1 baseband/bootloader) after a full wipe, ofc, and everything went very nicely, flashed Magisk right behind it for root, and then went searching for a solution for Xposed...I have been pretty out of the loop since Marshmallow, so I was totally unfamiliar with the current state of Xposed and the methods currently being employed to use it, so
- installed riru-core 19.6
- installed EdXposed .4.5.1 YAHFA <- This produced the same issue, Installed but not active, so

- installed EdXposed .4.6.1 YAHFA <- This produced a bootloop that starts to load Android then loops back to TWRP

- installed EdXposed .4.5.1 YAHFA AGAIN <- This time I got a freeze at Samsung logo initially then after a hard reboot Android booted and the framework is activated and has been activated after each subsequent reboot since. WHY this is the case, I cannot begin to explain, but after initially NOT being activated, after dirty flashing to .4.6.1 and back, it is now activated.
- I now am able to download and install any modules I like without issue.


I don't know if something here will help, but this is the process I took to reach a working active state on .4.5.1-beta with Magisk 20.3 on the Pie version of LineageOS 16.0....


Hope something here help!


EDIT: Note that the device does NOT pass SafetyNet checks....it initially did when I first got .4.5.1 activated, but I think it may be the addition of riru-core that for some reason broke SafetyNet. Although I cannot confirm this.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes