Remove All Ads from XDA

[Solved] Black Scr & Download/Recovery unreachable Galaxy S7 / Xposed + Magisk

7 posts
Thanks Meter: 1
 
By Raphaeldu68, Junior Member on 11th August 2017, 07:05 PM
Post Reply Email Thread
Hello everyone,

Here is the situation :
I just made a fresh install with full wipe of the latest SupermanRom without root in order to log in Snapchat, then I installed Magisk apk anf flashed Magisk V13.3. Until here, everythig was fine.
Then I wanted to try the unofficial Xposed framework : I installed the manager apk then downloaded the systemless Magisk compatible sdk 24 (SupermanRom 2.6 is Android 7.0) then reboot.

Here comes the problem : The phone (re)boots until the pin screen. This screen stays 2 or 3 seconds, then the screen goes of. I tried everything to type fast or anything, the phone doesn't react. When I press the power button to wake up the screen, nothing hapends.

So I thought, I just go back to full whipe and install the room again without Xposed, but I'm also unable to boot either in Recovery (Power + Home + Vol up) or Download (Power + Home + Vol down) mode !!!
The result without the SIM card is the same.

To sum up : Custom Rom + Magisk = OK phone working
But : Custom Rom + Magisk + Xposed = Unable to pin or boot in Recovery or Download mode.

During reboot, if i press the volume keys +/- the phone vibrates like in response... but nothing hapends. I never noticed it before...

Here I'm lost ! Does anyone have any idea of what I could do ? Is that a soft brick ? and how to get out of this situation ?

Please ask me for more information, and thank you in advance for those who will help me !
The Following User Says Thank You to Raphaeldu68 For This Useful Post: [ View ] Gift Raphaeldu68 Ad-Free
 
 
11th August 2017, 10:59 PM |#2  
Massi-X's Avatar
Senior Member
Thanks Meter: 289
 
More
It's practically impossible that flashing magisk or any other thing brick your phone. Maybe the recovery it's gone for some strange reason but the download mode will be always here. Follow the steps here: http://www.android.gs/enter-samsung-...download-mode/ (first result on Google...) to enter download mode and then use Odin to reflash it. If this doesn't work your phone is bricked but is very unlikely that it is caused by something you flashed.

EDIT: also because you say it power on until the PIN screen...
The Following User Says Thank You to Massi-X For This Useful Post: [ View ] Gift Massi-X Ad-Free
11th August 2017, 11:18 PM |#3  
Quote:
Originally Posted by Raphaeldu68

Hello everyone,

Here is the situation :
I just made a fresh install with full wipe of the latest SupermanRom without root in order to log in Snapchat, then I installed Magisk apk anf flashed Magisk V13.3. Until here, everythig was fine.
Then I wanted to try the unofficial Xposed framework : I installed the manager apk then downloaded the systemless Magisk compatible sdk 24 (SupermanRom 2.6 is Android 7.0) then reboot.

Here comes the problem : The phone (re)boots until the pin screen. This screen stays 2 or 3 seconds, then the screen goes of. I tried everything to type fast or anything, the phone doesn't react. When I press the power button to wake up the screen, nothing hapends.

So I thought, I just go back to full whipe and install the room again without Xposed, but I'm also unable to boot either in Recovery (Power + Home + Vol up) or Download (Power + Home + Vol down) mode !!!
The result without the SIM card is the same.

To sum up : Custom Rom + Magisk = OK phone working
But : Custom Rom + Magisk + Xposed = Unable to pin or boot in Recovery or Download mode.

During reboot, if i press the volume keys +/- the phone vibrates like in response... but nothing hapends. I never noticed it before...

Here I'm lost ! Does anyone have any idea of what I could do ? Is that a soft brick ? and how to get out of this situation ?

Please ask me for more information, and thank you in advance for those who will help me !

just keep (vol-) + (power) + (home key) more than 10 seconds and it goes to download mode just flash official firmware
The Following User Says Thank You to clau_la2 For This Useful Post: [ View ] Gift clau_la2 Ad-Free
12th August 2017, 01:01 PM |#4  
OP Junior Member
Thanks Meter: 1
 
More
Not Xposed but Magisk v13.3
Hello everyone,

After a good night - "La nuit porte conseil" (Sleep on it like the expression says) - I finally could go in TWRP (Recovery) again. Perhaps like clau_la2 says I didn't wait enough time pressing the buttons to get it boo in Recovery.

But as I thought it was Xposed was in cause, I got the problem again without Xposed, and I found that it was the combinaison with Magisk v13.3 who was unstable. So I downgraded to Magisk v13.1 and everything works fine now. I didn't try to reinstall Xposed for the moment. I'll do it later, when I'll have time on Holidays.

Massi-X That's what I tought, and you just confirmed this. I'm not a newbie in IT but Android is not my main subject, (Je travaille principalement dans les Réseaux & Télécoms) and I just was in panic because I couldn't even reach the Download mode to flash stock things through Odin.

So evrything works fine for the moment. I'll come back to post a feedback with Xposed when it'll be done.

Thanks for all guys, and have a nice weekend !
12th August 2017, 01:29 PM |#5  
Senior Member
Thanks Meter: 13
 
More
@Raphaeldu68

Do you play xposed systemless for Magisk version? Try to upload xposed classic version, on stock Nougat 7.0 S7 edge works xposed.
12th August 2017, 02:11 PM |#6  
OP Junior Member
Thanks Meter: 1
 
More
Yep I flashed the systemless Magisk compatible version. I'll try the stock one next time thanks for the feedback!

Envoyé de mon SM-G930F en utilisant Tapatalk
14th August 2017, 04:52 AM |#7  
Senior Member
Thanks Meter: 25
 
More
Xposed doesn't work well with Magisk, even on MM. I guess the problem lies in the Magisk root. Change to system Xposed and SuperSU, everything is working fine again. The only reason I need Magisk is to hide the root from Galaxy Gift app.
17th August 2017, 08:24 AM |#8  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by camapghe

Xposed doesn't work well with Magisk, even on MM. I guess the problem lies in the Magisk root. Change to system Xposed and SuperSU, everything is working fine again. The only reason I need Magisk is to hide the root from Galaxy Gift app.

@camapghe Thanks for your feedback, I guess so, but I'd like to keep Magisk to hide the root especially for banking apps and some others stuffs, so I'll try next week with the new Magisk beta 13.5 or 13.6 and come here to give a feedback.
17th August 2017, 08:35 AM |#9  
Senior Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by Raphaeldu68

@camapghe Thanks for your feedback, I guess so, but I'd like to keep Magisk to hide the root especially for banking apps and some others stuffs, so I'll try next week with the new Magisk beta 13.5 or 13.6 and come here to give a feedback.

I just tried the beta Magisk 13.6 few hours ago. Everything is fixed. There is also a modified version of Magisk Xposed that doesn't f*ck up the whole system.

In short, everything is 99% fixed.
The Following User Says Thank You to camapghe For This Useful Post: [ View ] Gift camapghe Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes