Remove All Ads from XDA
H10 Turbo

Bootloop after installing Xposed Framework v88

21 posts
Thanks Meter: 5
 
By f1reak, Junior Member on 10th July 2018, 10:47 AM
Post Reply Email Thread
TL,DR: My Sony Xperia E5803 Z5 Compact [MM 6.0.1] is stuck in a boot loop after I tried to downgrade/revert a “not active” Xposed Framework v89 [SDK23_v89.0_2017.12.17] to v88 [SDK23_v88.0_2017.10.08].

I tried getting into safemode as described here. I never got the phone to vibrate twice no matter how many times I pressed the Vol Up or Vol Down buttons.
Any help will be appreciated.

Status when everything was working fine:
Code:
Device: E5803 (Sony Xperia Z5 Compact)
Android version 6.0.1 (SDK 23)
ROM: 32.2.A.5.11 [E5803_Customized US_1298-3109_32.2.A.5.11_R4C]
Build fingerprint:  Sony/E5803/E5803:6.0.1/32.2.A.5.11/3656371468
Platform: arm64-v8a, 64-bit binary
Xposed Installer:  v 3.1.5 (was v3.0.1 by dvdandroid 26/11/16)
Xposed Framework: version 87 (SDK23_v87_2016.11.24, the modules were working fine)
TWRP: v3.0.2 (or maybe v3.1.0)
Attached:
Xposed error log 2018.07.09, 11.04 AM.log
Xposed error log 2018.07.09, 11.22 AM.log
Xposed error log 2018.07.09, 11.38 AM.log

Detail:
  1. I had a perfectly working Xposed Framework version 87
  2. I tried to update to Xposed Framework v89 from the Xposed Installer interface (direct DL via WiFi)
  3. I got “Parse error. There was a problem parsing the package.”
  4. I booted into TWRP recovery mode (from menu) and flashed xposed-v89-sdk23-arm64.zip [SDK23_v89.0_2017.12.17], rebooted
  5. I got “Xposed Framework version 89 is installed but not active. Please check the logs for details.”
  6. I booted into TWRP recovery and flashed the uninstaller “xposed-uninstaller-20180117-arm64.zip”
  7. I wiped the Dalvik cache and tapped Reboot, "Android is starting... Optimizing app 43 of 196." (This took about 15 minutes)
  8. I installed Xposed Framework v89 from the Xposed Installer interface itself
  9. Rebooted.
  10. Same “Xposed Framework version 89 is installed but not active”.
  11. I booted into recovery mode and flashed the uninstaller “xposed-uninstaller-20180117-arm64.zip”
  12. Rebooted into normal mode.
  13. I booted into recovery mode and flashed the “xposed-v88-sdk23-arm64.zip” SDK23_v88.0_2017.10.08
  14. Rebooting, LED flashed red 4 times, LED Light green, Sony logo, “Powered by android”, Rebooting, LED flashed red 4 times, > boot loop
  15. I hold Vol Up + Power to force shutdown, 3 vibrations, phone is off.
  16. I hold Vol Down + Power to boot into recovery, but it doesn’t.
  17. It just shows the Sony logo, screen goes black, Sony logo, screen goes black, Sony logo, LED flashed red 4 times, and repeat in a loop.

Thank you for your support
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes