Remove All Ads from XDA

Conused about Xposed on Touchwiz, Nova launcher, Marschmallow

9 posts
Thanks Meter: 0
 
By XtraWater, Junior Member on 13th April 2018, 02:12 PM
Post Reply Email Thread
Hello

I'm a little confused about xposed and modules on stock rom for Galaxy S5. May be someone can answer my questions.

I rooted my G900F, Marschmallow 6.0.1 and installed TWRP. Then I installed Xposed Framework V89. On my phone is the stock rom installed. I used Touchwiz UI, but changed to Nova launcher.

Now, I read warnings about bootloops while using Xposed with Samsung devices. I wonder if this affects my device too.

1. Since I use Nova Launcher, is Touchwiz still an possible issue?
2. Is Xposed by itself the 'danger' part or are it the modules? So far I installed one module. Everything works fine.
3. When I open Xposed Installer version 89 there is a warning: There seems to be a known Issue (Samsung Touchwiz Rom) with your Rom. Install Xposed might not work or lead to severe problems.

If my phone is affected, what is the best possible way to avoid potential issue? I red there are unofficial Xposed versions which are modified for samsung stock roms. But I couldn't find any.

Others say, newer version are fine for my phone.
 
 
13th April 2018, 02:28 PM |#2  
Senior Member
Flag Trento
Thanks Meter: 300
 
Donate to Me
More
Quote:
Originally Posted by XtraWater

1. Since I use Nova Launcher, is Touchwiz still an possible issue?
2. Is Xposed by itself the 'danger' part or are it the modules? So far I installed one module. Everything works fine.
3. When I open Xposed Installer version 89 there is a warning: There seems to be a known Issue (Samsung Touchwiz Rom) with your Rom. Install Xposed might not work or lead to severe problems.

If my phone is affected, what is the best possible way to avoid potential issue? I red there are unofficial Xposed versions which are modified for samsung stock roms. But I couldn't find any.

Nova launcher it's just a launcher, samsung phones ARE touchwiz, not the launcher itself.
Xposed it's the dangerous part, since it's something that edits your phone. Obliviously, if you install incompatible modules that hurts too, just pay attention to install compatible ones.
With a 5sec. search, you can find this thread.
I don't know if newer versions of official xposed are compatible with touchwiz roms, but in this thread there are the unofficial versions that are 100% compatible with yours, just read and download the correct zip.
The Following User Says Thank You to TENN3R For This Useful Post: [ View ] Gift TENN3R Ad-Free
13th April 2018, 02:29 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by TENN3R

Nova launcher it's just a launcher, samsung phones ARE touchwiz, not the launcher itself.
Xposed it's the dangerous part, since it's something that edits your phone. Obliviously, if you install incompatible modules that hurts too, just pay attention to install compatible ones.
With a 5sec. search, you can find this thread.
I don't know if newer versions of official xposed are compatible with touchwiz roms, but in this thread there are the unofficial versions that are 100% compatible with yours, just read and download the correct zip.

Thank you. Very helpful.

On the thread you linked is an download link. The latest version is xposed-v87.1-sdk23-arm-custom-build-by-wanam-20161125.zip

That's exactly the version I installed first. Later I updated it trough the xposed installer to version 89. Should I rather downgrade to the v87.1 version, or is the new installed 89version a custom build by wanam anyway?

I couldn't figure out which version (modified or not) is right now installed.
13th April 2018, 02:55 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by XtraWater

Thank you. Very helpful.

On the thread you linked is an download link. The latest version is xposed-v87.1-sdk23-arm-custom-build-by-wanam-20161125.zip

That's exactly the version I installed first. Later I updated it trough the xposed installer to version 89. Should I rather downgrade to the v87.1 version, or is the new installed 89version a custom build by wanam anyway?

Edit: Since couldn't find a newer version than xposed-v87.1-sdk23-arm-custom-build-by-wanam-20161125.zip, I downgraded back to this version. Now I leave it as it is.
I couldn't figure out which version (modified or not) is right now installed.

And the last questions. When I got the correct custom Xposed framework, can modules still screw up my phone?
13th April 2018, 04:20 PM |#5  
Senior Member
Flag Trento
Thanks Meter: 300
 
Donate to Me
More
Quote:
Originally Posted by XtraWater

And the last questions. When I got the correct custom Xposed framework, can modules still screw up my phone?

I'm not sure about the update. But the "normal" version should not even let your samsung phone boot up, so if it works it's ok.
Modules are not related to the official or unofficial version, I mean if you install for example gravitybox it explicitly says: "not try on touchwiz roms"
That's what I mean. Usually informations like this are in the description in the xda thread so you should be able to understand which is good for you and which not.
The Following User Says Thank You to TENN3R For This Useful Post: [ View ] Gift TENN3R Ad-Free
14th April 2018, 12:43 PM |#6  
marcdw's Avatar
Senior Member
Flag Baldwin Park
Thanks Meter: 2,080
 
More
To add to that, in the Xposed installer, Download section, you can do searches.
Search for touchwiz or samsung to get some results that may let you know if certain modules are for, compatible with, or not for your setup.
The module descriptions in the installer are similar to the OPs of the various module threads. Might make it a little easier initially to get an overview. Then you can go to various module threads if you have questions concerning them.


ZTE Axon 7 A2017U, AospExtended v4.6 ROM, microG (NoGapps), Multiboot, Tapatalk 4.9.5
The Following User Says Thank You to marcdw For This Useful Post: [ View ] Gift marcdw Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes