Remove All Ads from XDA
H10 Turbo

DEADLOCK - Xposed 3.1.5 doesn't help to root my device

1 posts
Thanks Meter: 0
 
By Morpheus_Neo, Junior Member on 10th July 2018, 04:22 PM
Post Reply Email Thread
Hi, I am using Samsung C9 Pro (SM-C9000) and I am on Nougat 7.1.1 (SDK 25). I need to root my device and use some xposed modules. As per advise in xda-developers I installed xposed 3.1.5. When i opened xposed it said xposed framework is not installed and suggested version 89. I tried both install and install via recovery. It keeps saying "Failed to get root access. Make sure your device is rooted properly and you have not blocked shell commands."
Now wondering what to do for this. Because I am installed xposed to root my device. But xposed itself is saying me "make sure your device is rooted properly". Its a deadlock. Also I tried iRoot, King Root, Root master, and various other root APKs and nothing worked so far. Need help to either root my device (with a verified solution for Nougat 7.1.1 - SDK 25) or to successfully install xposed framework/modules for rooting. Please throw in ireas for some verified and working solutions for Nougat 7.1.1. Thank you very much in advance
 
 
10th July 2018, 04:33 PM |#2  
aillez's Avatar
Senior Member
Flag Bangkok
Thanks Meter: 331
 
Donate to Me
More
first of all.
Xposed can't root your device. It's a framework that need root to install.
second... you might need to read as much as you can in your device forum about how to root your phone.
If you still trying like this (without trying to read carefully) it'll lead you to brick your phone.

Hopes this clarify something.


Sent from my Oneplus 5T
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes