Remove All Ads from XDA

[DISCUSSION] Xposed for Oreo

2,585 posts
Thanks Meter: 80,984
 
By rovo89, Senior Recognized Developer on 9th January 2018, 03:39 PM
Post Reply Email Thread
11th March 2018, 07:58 AM |#301  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 4,554
 
Donate to Me
More
Quote:
Originally Posted by lvbaal

@Didgeridoohan Okay, thanks for clarification and referal to didgeridoohan.com. This is a valuable resource.! So I booted to TWRP and tried to mount the Magisk image to remove the Xposed module manually. I've adb sideloaded Mount-Magisk,zip which reports an error: ¨Installing zip file Magisk mounter¨ ¨Magisk is not installed!¨ ¨Updater process ended with ERROR: 1¨. What could be the problem here you think? Neither Magisk Core Only Mode nor Magisk Hide are set to On. Nor does Rootchecker app report Superuser Binary files being installed. The Magisk manager v16.0 itself runs smoothly.

Now you're asking questions that are not for this thread... They never where really, since this is the official Xposed for Oreo thread and you're using systemless Xposed.

Go to the Magisk general support thread and provide whatever logs you can get your hands on.
 
 
12th March 2018, 04:44 PM |#302  
Member
Flag Bandung
Thanks Meter: 12
 
More
Hi guys,
Hmm so, I have a problem (but I don't know if it's from the modules or xposed framework itself.
I'm using LOS 15.1 Oreo 8.1 on my Mi5s

When I flash weekly LOS 15.1 Update, everything seems normal but then whenever I flash xposed installer oreo version 90-beta3, My phone is kind of laggy afterward, signal icon always has an "x" like it doesn't connected.
Modules I installed :
- AdBlocker Reborn
- Greenify
- Gravitybox Oreo

But, again I'm not sure if those problem are from xposed or not.
12th March 2018, 07:29 PM |#303  
Ibuprophen's Avatar
Senior Member
Flag Upstate New York
Thanks Meter: 3,577
 
Donate to Me
More
Quote:
Originally Posted by firmanperdi

Hi guys, Hmm so, I have a problem (but I don't know if it's from the modules or xposed framework itself...

The following post may be helpful for you regarding my thoughts for the dirty flashing order that may, hopefully, work for you.

https://forum.xda-developers.com/sho...ostcount=11908

Good Luck!

EDIT: My apologies... I just fixed the above link to the correct thread post.


~~~~~~~~~~~~~~~
I DO NOT provide support via PM unless asked/requested by myself. PLEASE keep it in the threads where everyone can share.
12th March 2018, 08:05 PM |#304  
Senior Member
Thanks Meter: 58
 
More
i got bootloop with ROM Oreo CRB7 when i install xposed framework.
Is there a solution?
Thanks
13th March 2018, 02:40 AM |#305  
NickosD's Avatar
Senior Member
Flag Amintaio - Divice: 1+1
Thanks Meter: 1,086
 
More
Anyone knows how to fix the flashlight not working with op3 and rr official? The flags in camera works, but not the flashlight
13th March 2018, 05:59 PM |#306  
Senior Member
Thanks Meter: 55
 
More
Does someome was able to get Xposed framework to works on latest Samsung Oreo 8.0 update (ERC4)?
13th March 2018, 06:40 PM |#307  
Ibuprophen's Avatar
Senior Member
Flag Upstate New York
Thanks Meter: 3,577
 
Donate to Me
More
Quote:
Originally Posted by goose2600

Does someome was able to get Xposed framework to works on latest Samsung Oreo 8.0 update (ERC4)?

I had to do a quick search to determine what device the ERC4 is specific to and I had located the following thread...

https://forum.xda-developers.com/sho....php?t=3754308

... I had also noticed that you had posted the exact same question there today...

https://forum.xda-developers.com/sho...&postcount=868

I, personally, would recommend/suggest that you wait at least a few days to give a member a chance to, hopefully, respond.

With that stated...

I did notice that specific development included "Pre-root with Magisk".

Hopefully someone can confirm or clarify the following...

Doesn't devices that are rooted/pre-rooted with Magisk also should be looking to the Magisk XPosed?


~~~~~~~~~~~~~~~
I DO NOT provide support via PM unless asked/requested by myself. PLEASE keep it in the threads where everyone can share.
13th March 2018, 08:16 PM |#308  
Senior Member
Thanks Meter: 55
 
More
Quote:
Originally Posted by Ibuprophen

I, personally, would recommend/suggest that you wait at least a few days to give a member a chance to, hopefully, respond.
[...]
Doesn't devices that are rooted/pre-rooted with Magisk also should be looking to the Magisk XPosed?
]

Thanks for reply.
I tested latest 8.0 Xposed, even the Magisk one... Of course I know I have to wait
14th March 2018, 12:14 AM |#309  
Ibuprophen's Avatar
Senior Member
Flag Upstate New York
Thanks Meter: 3,577
 
Donate to Me
More
Quote:
Originally Posted by goose2600

Thanks for reply. I tested latest 8.0 Xposed, even the Magisk one... Of course I know I have to wait

I just received some clarification regarding my Magisk question on my last post.

If a device has a Custom or Stock Firmware ROM installed, that is Rooted/Pre-Rooted with Magisk, it does not require the use of Magisk XPosed.

The only additional guidance that I can provide is for you to keep in mind that the XPosed Framework for Oreo is still in its "BETA" phase and may still be unstable for some/many devices.

All you can really do at this point is...

Hope that a member (on that Firmware Thread for your device) got it going and, hopefully, provide some guidance on it.

~AND/OR~

Just be patient for another Framework release by Rovo89 and keep your fingers crossed.

I do wish you the best of luck!


~~~~~~~~~~~~~~~
I DO NOT provide support via PM unless asked/requested by myself. PLEASE keep it in the threads where everyone can share.
The Following User Says Thank You to Ibuprophen For This Useful Post: [ View ] Gift Ibuprophen Ad-Free
14th March 2018, 08:08 AM |#310  
Senior Member
Thanks Meter: 37
 
More
My Xperia XZ just got bootloop today after upgrading to 41.3.A.2.99. being said this update includes 1 March 2018 Android security patch (other features remain unknown) so I'm not sure if this security patch is the culprit or it's because the systemless version ported by topjohnwu that I'm currently using.

This is just for references and I am patiently waiting for updates from rovo89 and topjohnwu. No rush. At all.

And again, thank you both for the great work I'm sure you'll never hear it enough
The Following 2 Users Say Thank You to alex.do For This Useful Post: [ View ] Gift alex.do Ad-Free
15th March 2018, 07:51 AM |#311  
manhong2112's Avatar
Junior Member
Thanks Meter: 5
 
More
My phone stuck at bootanimation after install systemless xposed 90.1-beta3. I am using MI5 with Android 8.1 AEX (03/06/2018).
Any help?
Attached Files
File Type: zip logcat.zip - [Click for QR Code] (156.2 KB, 6 views)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes