Remove All Ads from XDA

Can't login to Snapchat? Solved!

116 posts
Thanks Meter: 16
 
By Lewdog45, Senior Member on 28th January 2016, 09:32 AM
Post Reply Email Thread
Hi everyone!

If you are using a Custom ROM such as CyanogenMod, and are trying to login to Snapchat, you may encounter this error:

"Oh no! Your login temporarily failed, so please try again later. If your login continues to fail, please visit support.snapchat.com/a/failed-login".

The reason why Snapchat won't let you login is because your device has root access, or Xposed Framework installed! Yes! You heard right! Snapchat now blocks devices with root access and Xposed installed!


SOLUTION 1: (CyanogenMod Only)

1. Go into "Settings" and find "Developer Options".

2. Then find "Root Access" and change it to "Disabled".

3. Now attempt to login to Snapchat!

4. Now, if your login was successful, you can now re-enable "Root Access" in "Developer Options".

5. Done!


NOTE: There seems to be a problem with Snapchat force closing on Marshmallow/CM13 Based ROM's, so if this happens to you, I'm sorry I do not know how to fix this, as far as I know, there is no fix for this issue.


SOLUTION 2:

1. Download Xposed Uninstaller.zip from here:

http://forum.xda-developers.com/show....php?t=3034811

2. Boot your phone into recovery and flash the Xposed Uninstaller.zip

3. Reboot your phone

4. Done!


NOTE: Once you login to Snapchat, you can reinstall Xposed Framework and everything will work fine.


If you have any problems, please contact me and I will attempt to help you. Thanks everyone!
The Following 4 Users Say Thank You to Lewdog45 For This Useful Post: [ View ] Gift Lewdog45 Ad-Free
 
 
4th February 2016, 03:33 AM |#2  
Junior Member
Thanks Meter: 0
 
More
I can't find root access in my developer options
4th February 2016, 05:49 AM |#3  
OP Senior Member
Flag New Plymouth
Thanks Meter: 16
 
More
Hi Uzayr, Are you using CyanogenMod?
5th February 2016, 02:45 AM |#4  
Member
Thanks Meter: 7
 
More
Yeah... It keeps force closing... I'm using a rom based on CM13... Is there any way to fix this. I log in, but it force closes itself after I open the app
5th February 2016, 06:30 AM |#5  
OP Senior Member
Flag New Plymouth
Thanks Meter: 16
 
More
This seems to be a known problem with Marshmallow/CM13, So as far as I know there is no fix available.
The Following User Says Thank You to Lewdog45 For This Useful Post: [ View ] Gift Lewdog45 Ad-Free
6th February 2016, 05:33 PM |#6  
Junior Member
Thanks Meter: 0
 
More
No, Lewdog

---------- Post added at 05:33 PM ---------- Previous post was at 05:33 PM ----------

I used kingroot to root my device
6th February 2016, 10:08 PM |#7  
OP Senior Member
Flag New Plymouth
Thanks Meter: 16
 
More
Quote:
Originally Posted by Uzayr_

No, Lewdog

---------- Post added at 05:33 PM ---------- Previous post was at 05:33 PM ----------

I used kingroot to root my device

Try using RootCloak
11th February 2016, 03:34 PM |#8  
RaulGomez0912's Avatar
Senior Member
Flag Madrid
Thanks Meter: 51
 
More
Hey! I have one problem with Snapchat, but I think I've found something that could help to fix it. As many people have noticed in other posts, Snapchat in CM13 based ROMs has FCs, but last night when I powered off WiFi and network conection Snapchat worked and then, when I powered on WIFI and network again, the FCs reappeared. Could it be this relevant to finding a solution? Can it have something to do with the bug of the camera? It happens every time I power off WIFI and network on my phone. Thanks!
17th April 2016, 01:21 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Problem still there
Hi I tried using your way to uninstall xposed but the problem for snapchat is still there what do I do
27th May 2016, 12:16 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Salmanmalik

Hi I tried using your way to uninstall xposed but the problem for snapchat is still there what do I do

Yeah me too ! I have uninstalled the Xposed Framework and also the Root Access but nothing happens ! Still the same problem !
The Following User Says Thank You to Lolakis13 For This Useful Post: [ View ] Gift Lolakis13 Ad-Free
28th September 2016, 12:39 AM |#11  
OP Senior Member
Flag New Plymouth
Thanks Meter: 16
 
More
Make sure Xposed Framework is completely uninstalled, then uninstall Snapchat, make sure that you do not have SuperSU installed, reboot your device and reinstall Snapchat and see if that works, thanks.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes