Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[UNOFFICIAL] Material Design Xposed Installer [31/10/17]

440 posts
Thanks Meter: 3,387
 
By DVDandroid, Senior Member on 1st June 2015, 11:05 AM
Post Reply Email Thread
Announcement from DVDandroid: News about this Xposed Installer!
23rd June 2016, 08:42 PM |#931  
Alexey71's Avatar
Senior Member
Thanks Meter: 582
 
Donate to Me
More
@DVDandroid
Hi. add next build new Russian translate. And delete old arrays.xml
Attached Files
File Type: zip 23.06.2016-values-ru.zip - [Click for QR Code] (7.9 KB, 28 views)
 
 
23rd June 2016, 11:11 PM |#932  
Wiki Admin / Recognized Contributor
Thanks Meter: 1,644
 
More
Hello, could you move the existing framework/uninstaller download selector to an advanced menu/add some sort of option to hide the zips that dont apply to your current device?

Currently there are 11 different xposed variations available for download from within the app, but only 6 (or so) of them are valid for any single device. While I understand that the intention is so you can download it and flash it on a different device, being able to see all downloads by default only makes it more complicated for a new user. The same is true for the uninstallers.


What I see:
Downloads:
Quote:

  • xposed-v85-sdk23-arm
  • xposed-v85-sdk23-arm64
  • xposed-v85-sdk23-x86
  • xposed-v85.7-sdk23-systemless
  • xposed-v85.7-arm-alt-sdk23-systemless
  • xposed-v85.1-sdk23-arm-custom-build-by-wanam-20160528
  • xposed-v85.1-sdk23-arm64-custom-build-by-wanam-20160528
  • xposed-v85.1-alt-sdk23-arm-custom-build-by-wanam-20160528
  • xposed-v85-sdk23-arm-MIUI-edition-by-SolarWarez-20160609
  • xposed-v85-sdk23-arm64-MIUI-edition-by-SolarWarez-20160609
  • xposed-v85-sdk23-x86-MIUI-edition-by-SolarWarez-20160609

Info:
Quote:

Name: xposed-v85-sdk23-arm
SDK: 23
Architecture: arm
Version: 85

What I would like:
Basic Downloads: (for a device running AOSP 6.0 (sdk23) on arm)
Quote:

  • xposed-v85-sdk23-arm
  • xposed-v85.7-sdk23-systemless
  • xposed-v85.7-arm-alt-systemless
  • xposed-v85.1-sdk23-arm-custom-build-by-wanam-20160528
  • xposed-v85.1-alt-sdk23-arm-custom-build-by-wanam-20160528
  • xposed-v85-arm-MIUI-edition-by-SolarWarez-20160609

Downloads with "show all available installers" selected in settings:
Quote:

(Currently existing functionality)

Info:
Quote:

Name: xposed-v85-sdk23-arm
SDK: 23
Architecture: arm
Version: 85
Compatable: AOSP roms/most oem roms
Not compatable: Touchwiz roms / MIUI roms(?)

Quote:

Name: xposed-v85.7-sdk23-systemless
SDK: 23
Architecture: arm / arm64 / x86
Version: 85.7
Compatable: AOSP / most oem roms / touchwiz roms
Not compatable: MIUI roms(?)


"which version of xposed do I use?" is a common question, and the installer already knows exactly which sdk/arch any specific zip is already (and the device it self obviously).
TW/MIUI roms also make it more complicated since official xposed doesn't support them, and it's not as trivial to check for as it is to check sdk/arch.

This would make it so that a user installing xposed for the first time on the same device only needs to know if their rom is compatible (ie is it touchwiz or MIUI), instead of that in addition to their sdk and arch versions.
The Following 4 Users Say Thank You to TheManii For This Useful Post: [ View ] Gift TheManii Ad-Free
24th June 2016, 10:17 AM |#933  
terrorist96's Avatar
Senior Member
Thanks Meter: 102
 
More
@DVDandroid
crash log:
java.lang.RuntimeException: Unable to start activity ComponentInfo{de.robv.android.xposed.installer/de.robv.android.xposed.installer.SettingsActivity} : java.lang.NullPointerException: Attempt to invoke virtual method 'android.content.pm.PackageManager android.content.Context.getPackageManager()' on a null object reference
at android.app.ActivityThread.performLaunchActivity(A ctivityThread.java:2416)
at android.app.ActivityThread.handleLaunchActivity(Ac tivityThread.java:2476)
at android.app.ActivityThread.-wrap11(ActivityThread.java)
at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1344)
at android.os.Handler.dispatchMessage(Handler.java:10 2)
at android.os.Looper.loop(Looper.java:148)
at android.app.ActivityThread.main(ActivityThread.jav a:5422)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:616)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:132)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'android.content.pm.PackageManager android.content.Context.getPackageManager()' on a null object reference
at de.robv.android.xposed.installer.SettingsActivity$ SettingsFragment.onCreate(SettingsActivity.java:16 3)
at android.app.Fragment.performCreate(Fragment.java:2 198)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:942)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:1148)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:1130)
at android.app.FragmentManagerImpl.dispatchCreate(Fra gmentManager.java:1948)
at android.app.FragmentController.dispatchCreate(Frag mentController.java:141)
at android.app.Activity.onCreate(Activity.java:921)
at android.support.v4.app.BaseFragmentActivityDonut.o nCreate(BaseFragmentActivityDonut.java:39)
at android.support.v4.app.FragmentActivity.onCreate(F ragmentActivity.java:297)
at android.support.v7.app.AppCompatActivity.onCreate( AppCompatActivity.java:85)
at de.robv.android.xposed.installer.XposedBaseActivit y.onCreate(XposedBaseActivity.java:15)
at de.robv.android.xposed.installer.SettingsActivity. onCreate(SettingsActivity.java:38)
at android.app.Activity.performCreate(Activity.java:6 251)
at android.app.Instrumentation.callActivityOnCreate(I nstrumentation.java:1107)
at android.app.ActivityThread.performLaunchActivity(A ctivityThread.java:2369)
at android.app.ActivityThread.handleLaunchActivity(Ac tivityThread.java:2476)
at android.app.ActivityThread.-wrap11(ActivityThread.java)
at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1344)
at android.os.Handler.dispatchMessage(Handler.java:10 2)
at android.os.Looper.loop(Looper.java:148)
at android.app.ActivityThread.main(ActivityThread.jav a:5422)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:616)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:132)
24th June 2016, 10:32 AM |#934  
ahrion's Avatar
Forum Moderator / Recognized Developer
Thanks Meter: 4,437
 
More
This looks like a manifest error. Is the settings activity defined as .SettingsActivity absolute in the manifest?

Quote:
Originally Posted by terrorist96

@DVDandroid
crash log:

java.lang.RuntimeException: Unable to start activity ComponentInfo{de.robv.android.xposed.installer/de.robv.android.xposed.installer.SettingsActivity} : java.lang.NullPointerException: Attempt to invoke virtual method 'android.content.pm.PackageManager android.content.Context.getPackageManager()' on a null object reference
at android.app.ActivityThread.performLaunchActivity(A ctivityThread.java:2416)
at android.app.ActivityThread.handleLaunchActivity(Ac tivityThread.java:2476)
at android.app.ActivityThread.-wrap11(ActivityThread.java)
at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1344)
at android.os.Handler.dispatchMessage(Handler.java:10 2)
at android.os.Looper.loop(Looper.java:148)
at android.app.ActivityThread.main(ActivityThread.jav a:5422)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:616)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:132)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'android.content.pm.PackageManager android.content.Context.getPackageManager()' on a null object reference
at de.robv.android.xposed.installer.SettingsActivity$ SettingsFragment.onCreate(SettingsActivity.java:16 3)
at android.app.Fragment.performCreate(Fragment.java:2 198)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:942)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:1148)
at android.app.FragmentManagerImpl.moveToState(Fragme ntManager.java:1130)
at android.app.FragmentManagerImpl.dispatchCreate(Fra gmentManager.java:1948)
at android.app.FragmentController.dispatchCreate(Frag mentController.java:141)
at android.app.Activity.onCreate(Activity.java:921)
at android.support.v4.app.BaseFragmentActivityDonut.o nCreate(BaseFragmentActivityDonut.java:39)
at android.support.v4.app.FragmentActivity.onCreate(F ragmentActivity.java:297)
at android.support.v7.app.AppCompatActivity.onCreate( AppCompatActivity.java:85)
at de.robv.android.xposed.installer.XposedBaseActivit y.onCreate(XposedBaseActivity.java:15)
at de.robv.android.xposed.installer.SettingsActivity. onCreate(SettingsActivity.java:38)
at android.app.Activity.performCreate(Activity.java:6 251)
at android.app.Instrumentation.callActivityOnCreate(I nstrumentation.java:1107)
at android.app.ActivityThread.performLaunchActivity(A ctivityThread.java:2369)
at android.app.ActivityThread.handleLaunchActivity(Ac tivityThread.java:2476)
at android.app.ActivityThread.-wrap11(ActivityThread.java)
at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1344)
at android.os.Handler.dispatchMessage(Handler.java:10 2)
at android.os.Looper.loop(Looper.java:148)
at android.app.ActivityThread.main(ActivityThread.jav a:5422)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:616)
at de.robv.android.xposed.XposedBridge.main(XposedBri dge.java:132)

24th June 2016, 06:40 PM |#935  
terrorist96's Avatar
Senior Member
Thanks Meter: 102
 
More
I was sent a test version. No crashes so far.
24th June 2016, 10:25 PM |#936  
Junior Member
Thanks Meter: 4
 
More
I have installed framework sdk23 v85 arm64 on huawei p8 lite android 6.0 but.... he said what framework installed but not active.. how can i fix it.. please reply me if u know what can i do.. thanks

Sent from my ALE-L21 using XDA-Developers mobile app
25th June 2016, 02:49 AM |#937  
Sreyaz01's Avatar
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by DVDandroid

Are you connected to Internet? Is your connection fast? Do you have a firewall that blocks some urls?

Yes i m conected to internet, connection is fast and i m using AdAway but in older version was working fine

---------- Post added at 01:49 AM ---------- Previous post was at 01:37 AM ----------

Quote:
Originally Posted by DVDandroid

Are you connected to Internet? Is your connection fast? Do you have a firewall that blocks some urls?

Ohkey downloaded 23/06 Build and its working now
25th June 2016, 03:02 AM |#938  
Sjamaan's Avatar
Senior Member
Thanks Meter: 110
 
More
Quote:
Originally Posted by MyGalaxysIII

I have installed framework sdk23 v85 arm64 on huawei p8 lite android 6.0 but.... he said what framework installed but not active.. how can i fix it.. please reply me if u know what can i do.. thanks

Sent from my ALE-L21 using XDA-Developers mobile app

You need to install v85.1 sdk23 arm64 custom build by wanam.
25th June 2016, 03:48 AM |#939  
Junior Member
Thanks Meter: 4
 
More
Okay. I will try this.

Sent from my ALE-L21 using XDA-Developers mobile app

---------- Post added at 01:48 AM ---------- Previous post was at 01:47 AM ----------

Quote:
Originally Posted by Sjamaan

You need to install v85.1 sdk23 arm64 custom build by wanam.

Okay, i will try this..

Sent from my ALE-L21 using XDA-Developers mobile app
25th June 2016, 04:10 AM |#940  
Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by Sjamaan

You need to install v85.1 sdk23 arm64 custom build by wanam.

I install it but my phone doesn't turn on. When i uninstall it from twrp by xposed uninstaller, then phone turned on.. :/

Sent from my ALE-L21 using XDA-Developers mobile app

---------- Post added at 02:10 AM ---------- Previous post was at 02:09 AM ----------

Quote:
Originally Posted by Sjamaan

You need to install v85.1 sdk23 arm64 custom build by wanam.

I install it but my phone doesn't turn on.. when i uninstall it from twrp by xposed uninstaller, then my phone turned on.. :/

Sent from my ALE-L21 using XDA-Developers mobile app
25th June 2016, 09:18 AM |#941  
DVDandroid's Avatar
OP Senior Member
Flag Puglia
Thanks Meter: 3,387
 
More
Quote:
Originally Posted by Sander9847

@DVDandroid
Regarding the request of the previous post I made this mockup of how I think would be a good way to make it more clear to users which version they're installing. And in general be easier than that list.
The info buttons would show general info about which build they should install, what the difference with systemless is for example. And what the different architectures are.
Hope you could take some ideas from this!

Quote:
Originally Posted by TheManii

Hello, could you move the existing framework/uninstaller download selector to an advanced menu/add some sort of option to hide the zips that dont apply to your current device?

Now I'm implementing a navigation tabs to choose right file zip.
Small preview:




Quote:
Originally Posted by MyGalaxysIII

I have installed framework sdk23 v85 arm64 on huawei p8 lite android 6.0 but.... he said what framework installed but not active.. how can i fix it.. please reply me if u know what can i do.. thanks

You should install xposed-v85-sdk23-arm64-MIUI-edition-by-SolarWarez-20160609
The Following 13 Users Say Thank You to DVDandroid For This Useful Post: [ View ] Gift DVDandroid Ad-Free
Post Reply Subscribe to Thread

Tags
lollipop, marshmallow, material design, xposed

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes