Remove All Ads from XDA

[MM 6.0] Modules don't work even tho the installation was successful

2 posts
Thanks Meter: 0
 
By wambooo23, Junior Member on 16th April 2017, 01:55 PM
Thread Closed Email Thread
Hi all!

So I recently bought a Cubot Max but cant get any Xposed Modules to work!

Specs:
Cubot Max
Android 6.0
FW v11
arm64

I got the zip and apk off the official thread and used the latest sdk23 arm64 version obviously.

I mainly need the modules "Youtube Adawy" and "Youtube background playback".
But for the sake of testing if the issue is a result of incompatibility I also installed the modules
"PinNotif" and "SlideBack".
None of them worked.
The UI of "SlideBack" seemd to work properly while the UI of Youtube Adaway said that the app was not actived, even tho i tried it several times.

The log file read "cannot read log/data/data/de.robv.android.xposed.installer/log/error.log: open failed: ENOENT" so i created the missing txt file and gave it - rw rw permissions.

Does anyone has a clue what causes this problem?

greets
 
 
17th April 2017, 04:02 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by wambooo23

Hi all!

So I recently bought a Cubot Max but cant get any Xposed Modules to work!

Specs:
Cubot Max
Android 6.0
FW v11
arm64

I got the zip and apk off the official thread and used the latest sdk23 arm64 version obviously.

I mainly need the modules "Youtube Adawy" and "Youtube background playback".
But for the sake of testing if the issue is a result of incompatibility I also installed the modules
"PinNotif" and "SlideBack".
None of them worked.
The UI of "SlideBack" seemd to work properly while the UI of Youtube Adaway said that the app was not actived, even tho i tried it several times.

The log file read "cannot read log/data/data/de.robv.android.xposed.installer/log/error.log: open failed: ENOENT" so i created the missing txt file and gave it - rw rw permissions.

Does anyone has a clue what causes this problem?

greets

Exactly I am also facing the same problem.
12th July 2017, 08:13 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Same here
Can we have a thread to get the Cubot Max working with Xposed? A 500+ page general thread is difficult to follow. Thanks!
4th August 2017, 08:56 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Success!
I did it! This is what I did.

The problem is that there is a firmware error which affects a number of MTK6735 phones and stops Xposed from working. You have to install another module called grorkmod first, but this will not work if you have previously tried to install Xposed. So what I did was set the phone back to its initial state (after backing up data etc.).

1. Download the Custom TWRP and the Cubot Max official ROM from here:
mod edit: link removed

2. Unrar the official ROM, and, using SP Flash Tool, set to "Format and Download", Flash the ROM in full. You will now have an unrooted, untouched factory-set phone.

3. When I did this, the Firmware version (Build Number) was V04 — check this through your system settings as my phone originally arrived with Build Number V09. So, after unzipping the TWRP download, I had to use the older version of the Scatter file. So use SP Flash Tool again, and Flash TWRP and reboot the phone, you will have an unrooted phone but with TWRP installed. Do the usual stuff with becoming a developer and changing the necessary permissions.

4. Now you can transfer files to your phone's memory.
UPDATE-SuperSU-xxx,zip
grorkmod_v1.1+lite.zip
xposed-v87-sdk23-arm64.zip
XposedInstaller_3.1.1.apk

5. Boot to Recovery, and, from TWRP:
(a) Install UPDATE-SuperSU-xxx.zip but do not reboot.
(b) Clear Dalvik cache etc
(c) Install grorkmod do not reboot.
(d) Install xposed — this time reboot.

6. Run your file manager and attempt to install the .apk file. If you are diverted to give permission for this, change the settings and do it again.

Hope this helps.
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes