FORUMS
Remove All Ads from XDA

[APP][P][XPOSED] GravityBox v9.1.1 for Android 9 [14/06/2019]

7,595 posts
Thanks Meter: 23,738
 
By C3C076, Recognized Contributor on 8th March 2019, 12:26 PM
Post Reply Email Thread
8th March 2019, 02:49 PM |#11  
MaXAiRO's Avatar
Senior Member
Flag Mytilene, Lesvos
Thanks Meter: 88
 
More
Congratulations for your hard work!

When I updated from Nougat to Oreo I backed up and restored GB settings successfully. Have you tested if it's possible to do the same for Oreo - > Pie?

Sent from my OnePlus 5 using XDA Labs
The Following User Says Thank You to MaXAiRO For This Useful Post: [ View ] Gift MaXAiRO Ad-Free
 
 
8th March 2019, 03:18 PM |#12  
@srmahunt's Avatar
Senior Member
Thanks Meter: 75
 
More
Kudos to dev for this. Some of the problems i am facing:

Selecting battery bar to show at bottom edge shows just below the status bar.
https://drive.google.com/file/d/1fNz...w?usp=drivesdk

Data traffic monitor hiding status bar icons when selecting right as location.
https://drive.google.com/file/d/14ZQ...w?usp=drivesdk

On overriding navigation keys action for back and recents i lose vibration feedback.

Power key long press for torch on screen off doesn't work.

When i toggle system network speed indicator icon the system battery icon is flashed for a little bit and then cancelled.
https://drive.google.com/file/d/1_mG...w?usp=drivesdk


Some questions:
The location tile provides battery saver, devuce inly, high accuracy. But google has removed these types in android pie. Does the option work as their names suggest or they have all the same function??

Some requests:
Additonal quick settings row.
Separation of ring and notification volume.


Oneplus 5 Stock OOS
The Following 2 Users Say Thank You to @srmahunt For This Useful Post: [ View ] Gift @srmahunt Ad-Free
8th March 2019, 03:25 PM |#13  
mshinni80's Avatar
Senior Member
Thanks Meter: 322
 
More
Thanks again for your awesome work. It speaks for itself that so many people have been waiting for exactly this module to be ready for Pie, right @sjamie? So GB and XE are ready, are you?

Anyway, I have literally gone through almost each and every possible setting and I have to state, that GB has never worked so flawlessly before. Not even under Oreo with latest xposed.
I am running stock OOS (9.0.4), Magisk 18.1, latest EdXposed and latest riru and Pi Kernel.

At last, I'd be nice if you could add a PayPal link to the OP, so I can send another donation. Coz through the app the amount is limited to 3 euros and that is simply not enough!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190308-162050.jpg
Views:	1168
Size:	133.0 KB
ID:	4719166  
The Following 4 Users Say Thank You to mshinni80 For This Useful Post: [ View ] Gift mshinni80 Ad-Free
8th March 2019, 03:48 PM |#14  
Senior Member
Thanks Meter: 69
 
More
Wow… great efforts

One note
Advance reboot menue does not work. Nothing happen when activated

Thanks a lot
8th March 2019, 04:00 PM |#15  
whalesplaho's Avatar
Senior Member
Flag Treasure Island
Thanks Meter: 2,622
 
More
Thank you OP. This projects encourages lot of users to stick with android.
8th March 2019, 04:11 PM |#16  
Member
Flag Burlington
Thanks Meter: 21
 
More
No bugs thus far for what I'm using.
8th March 2019, 04:14 PM |#17  
Tchania's Avatar
Senior Member
Thanks Meter: 40
 
More
First of all, a big thank you for making this work on pie!
This is the one module that I had no hesitation getting the premium unlock. This is a must have, at least to me!

Okay so I gave it a try as soon as I saw the post of the first beta for pie, and as expected (for note 9) it was working partially. I'm not encluding any logs for now because I'm not expecting you to fix stuff for samsung at the moment or even afterwards (let me know in case you are thinking of supporting One UI someday down the road). So this is more about informing you how good it is on note 9 (korean version N960N), as a tester.

-when I have music visualization enabled and whenever I lock or unlock the screen, the sound effect of V4A stops and return as the visualization appears (poweramp playing music as I'm doing this). The same happens when toggling visualization for navbar; as I'm toggling it on and off the sound effect turns off very very briefly and comes back on. It's like a refresh thingy.
-advanced power menu is not working at all (even after reboots).
-circular battery is working but the percentage inside it looks weird sometimes and sometimes the stock battery icon appears alongside the circular one.
-data traffic indicator works without issues.
-status bar brightness control works only when adaptive brightness is turned off (I guess that's normal?).
-download progress seems to work only for google play downloads (I guess it's normal as well?).
-trusted Wi-Fi works like a charm.
-pie control works but I haven't tinkered will all the options. So far so good.
-one last thing, the color of icons/indicators from gb on status bar always look grey-ish? No matter the status bar color change. So sometimes they are hard to see.

That's all I have tested for now.

You are awesome!

Sent from my SM-N960N using XDA Labs
The Following 2 Users Say Thank You to Tchania For This Useful Post: [ View ] Gift Tchania Ad-Free
8th March 2019, 04:22 PM |#18  
Senior Member
Flag Bangalore
Thanks Meter: 304
 
More
Thanks, being beta bugs are to be expected. I started with what I use most frequently - will add as I check

Fingerprint actions not working on any of the 5 selected slots (be it apps/shortcuts) - "No app/ action assigned" toast message pops up. Toggle enabled and rebooted. Also disabled from Installer, enabled and rebooted. Didn't help

Stock MiA1 (Android one)

Dropbox 🔗 for EdXposed logs https://www.dropbox.com/s/8lg28md759...32340.log?dl=0. I can't see any logs in com. Solohosu....

If you need logs using laptop, it will take a few days

Edit : Same result with GB as only module

Installer log https://www.dropbox.com/s/07bqhhg15x...05557.log?dl=0

Edit 2: Surprisingly, quick tap action works for both shortcuts and apps so it's not a fingerprint issue

Edit 3: Toggling config-fingerprint-support-gestures from false to true and reboot didn't help
The Following 2 Users Say Thank You to beeshyams For This Useful Post: [ View ] Gift beeshyams Ad-Free
8th March 2019, 06:41 PM |#19  
Kuntitled's Avatar
Member
Thanks Meter: 30
 
More
Don't know if i'm doing something wrong but i can't get past the framework check at the beggining. Using EdXposed and Magisk 18.1
Moto G6Play
8th March 2019, 06:47 PM |#20  
Udzi's Avatar
Senior Member
Flag Black Forest
Thanks Meter: 285
 
More
Thank You!! GB is even working fine with v0.2.9.8-beta1
The only thing I miss is
"Swap Volume Buttons in Landscape"
Great Effort, you are a Genius
8th March 2019, 07:06 PM |#21  
Abolfazl's Avatar
Senior Member
Flag San Carlos, CA
Thanks Meter: 57
 
More
I have Pixel 3 XL running Magisk v18.2. When I install the apk and run, I am receiving an error message "GravityBox system framework not responding Exiting.".

What is the cause of this?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes