FORUMS
Remove All Ads from XDA

[MOD][Xposed][4.3] Fitbit Sync on all devices running 4.3

160 posts
Thanks Meter: 9
 
By stan23, Senior Member on 10th November 2013, 08:24 PM
Post Reply Email Thread
This Xposed mod allows Bluetooth 4 synchronisation with Fitbit trackers on all devices running Android 4.3 by patching the device detection.

Special thanks to dimfish for finding out how to patch the device detection.


Please remember to switch off "Background sync" in Fitbit app due to the 48 h problem mentioned here. Seems that the BT libraries on Google and hTC and other devices except Samsung are incomplete or have a bug, which causes the tracker battery to drain when it becomes undiscoverable.


Xposed repository
Source code

This is my first Xposed module and also my first app, so please be nice to me
Attached Files
File Type: apk XposedFitbitSync-0.1.2.apk - [Click for QR Code] (251.5 KB, 590 views)
The Following 5 Users Say Thank You to stan23 For This Useful Post: [ View ] Gift stan23 Ad-Free
 
 
14th November 2013, 08:29 PM |#2  
Senior Member
Flag Phoenix
Thanks Meter: 64
 
More
So I installed the module and activated it in Xposed. Rebooted and downloaded fitbit from the play store but it still doesn't allow me to sync. I went to dimfish and downloaded the app and it works but I don't think I need the module to use that one. I'm on a d2tmo on cm 11

Sent from my SGH-T999 using Tapatalk
17th November 2013, 08:40 PM |#3  
OP Senior Member
Flag Nürnberg
Thanks Meter: 9
 
More
Quote:
Originally Posted by hatdrc

So I installed the module and activated it in Xposed. Rebooted and downloaded fitbit from the play store but it still doesn't allow me to sync. I went to dimfish and downloaded the app and it works but I don't think I need the module to use that one. I'm on a d2tmo on cm 11

Hmm, my mod does the same change that dimfish has patched in his app.

Do you see anything about "Fitbit" in this file?
Code:
/data/data/de.robv.android.xposed.installer/log/debug.log
20th November 2013, 09:33 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Post Urgent Consult
Quote:
Originally Posted by stan23

Hmm, my mod does the same change that dimfish has patched in his app.

Do you see anything about "Fitbit" in this file?

Code:
/data/data/de.robv.android.xposed.installer/log/debug.log


Hi I use a headset Sony SBH50 and OS 4.3. running on a Samsung Galaxy S3, Sony makes the player loses all his functions, ie only hear if I touch the terminal play the camandos the headset do not work and neither headset screen shows me the screen. Consult this patch solves it? sorry for the question but I charge at least 6 times different rooms with 4.3.para see if any works and all feel the same, appreciate answer. thanks Ariel
22nd November 2013, 06:00 AM |#5  
OP Senior Member
Flag Nürnberg
Thanks Meter: 9
 
More
Quote:
Originally Posted by aefdj78

Hi I use a headset Sony SBH50 and OS 4.3. running on a Samsung Galaxy S3, Sony makes the player loses all his functions, ie only hear if I touch the terminal play the camandos the headset do not work and neither headset screen shows me the screen. Consult this patch solves it?

No, this mod has an influence only on the Fitbit app.
24th November 2013, 07:36 AM |#6  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by stan23

No, this mod has an influence only on the Fitbit app.

Hi, thanks a lot for your module, the Flex finally syncs with my Android device (Nexus 5). Just a question, how can I disable "Backgound sync"? I don't see such an option in the Fitbit app (1.8.2). Maybe you mean the "Use bluetooth" option under "Devices" menu?

F.
24th November 2013, 08:37 AM |#7  
OP Senior Member
Flag Nürnberg
Thanks Meter: 9
 
More
Quote:
Originally Posted by fbriolini

Just a question, how can I disable "Backgound sync"? I don't see such an option in the Fitbit app (1.8.2). Maybe you mean the "Use bluetooth" option under "Devices" menu?

"Use Bluetooth" must be selected.
In the devices menu, select the Flex (or the One) and then you see a screen like this:
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-11-24-09-08-45.png
Views:	4788
Size:	52.2 KB
ID:	2411529  
24th November 2013, 11:40 AM |#8  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by stan23

"Use Bluetooth" must be selected.
In the devices menu, select the Flex (or the One) and then you see a screen like this:

I found it! Thanks a lot.

F.
24th November 2013, 07:27 PM |#9  
Senior Member
Flag Phoenix
Thanks Meter: 64
 
More
Quote:
Originally Posted by stan23

Hmm, my mod does the same change that dimfish has patched in his app.

Do you see anything about "Fitbit" in this file?

Code:
/data/data/de.robv.android.xposed.installer/log/debug.log

Sorry I didn't get back to you. Turns out xposed wasn't working with Kit Kat but it does now. So far it appears to be work. Thank you for this module. Was the only thing keeping me on stock touch wiz

Sent from my SGH-T999 using Tapatalk
The Following User Says Thank You to hatdrc For This Useful Post: [ View ] Gift hatdrc Ad-Free
1st December 2013, 04:32 AM |#10  
KestrelX's Avatar
Senior Member
Thanks Meter: 139
 
More
Wow, was just reading up on Xposed and wondering if there was any reason for me to use it and came across your mod. Time to install Xposed and your mod methinks Thanks!
The Following User Says Thank You to KestrelX For This Useful Post: [ View ] Gift KestrelX Ad-Free
19th December 2013, 06:40 PM |#11  
TewFast's Avatar
Junior Member
Thanks Meter: 5
 
More
FYI if your using this module you may be interested in using the NFC LockScreenOff Enabler module.

I use my Fitbit Force [NFC Tag] to log into my phone that has a pattern lock.
The Following User Says Thank You to TewFast For This Useful Post: [ View ] Gift TewFast Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes