FORUMS
Remove All Ads from XDA

TaiChi:Using Xposed modules with/without Root/Unlock bootloader on Android 5.0~10.0

47 posts
Thanks Meter: 512
 
Post Reply Email Thread
Announcement from weishu: A framework to use Xposed modules with or without Root/Unlock bootloader, supportting Android 5.0 ~ 9.0.
16th March 2019, 12:39 PM |#11  
Senior Member
Thanks Meter: 189
 
More
Just tried Taichi today and it instantly bring the good old days for me with Xposed. I need to have certain Apps to run in different locale and Xposed module is to the only way to get this done! However Xposed also stopped Google pay so I have to stop using Xposed ever since.

With Taichi I can start use Xposed again and have Google Pay at the same time... Great solution!

Unfortunately with current international politics it immediately mark anything from China as insecure. I am not sure if TaiChi is secure or not, but I guess since the day I rooted my phone I am assuming all the risk inherited.

Anyway good work! Weishu! (Just donated)
The Following User Says Thank You to lssong99 For This Useful Post: [ View ] Gift lssong99 Ad-Free
GuestK00193
16th March 2019, 02:07 PM |#12  
Guest
Thanks Meter: 0
 
More
Hmm I must be high on something because I dont see the download link.
16th March 2019, 03:31 PM |#13  
Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by woomera

Hmm I must be high on something because I dont see the download link.

Check the magisk manager downloads section.
The Following User Says Thank You to dirtyreturn For This Useful Post: [ View ] Gift dirtyreturn Ad-Free
16th March 2019, 07:37 PM |#14  
Senior Member
Thanks Meter: 218
 
More
@weishu , I hope you can help. I've purchased xprivacylua pro from the google play store some time ago and reinstalled it on Pie. Xprivacylua pro does not seem to recognize xprivacylua is installed also. Do you have any suggestions?
17th March 2019, 12:03 AM |#15  
Depressed T.Bear's Avatar
Senior Member
Flag Berlin
Thanks Meter: 579
 
More
Quote:
Originally Posted by dirtyreturn

@weishu , I hope you can help. I've purchased xprivacylua pro from the google play store some time ago and reinstalled it on Pie. Xprivacylua pro does not seem to recognize xprivacylua is installed also. Do you have any suggestions?

It sounds like you misunderstood something. The "Pro" app from. Google Play is just a companion app, which enables the pro features you bought. It doesn't contain the actual xposed module (and app) of xprivacy Lua.
Simply download it through the xposed repo or get the latest apk directly from the xprivacy lua website.

Sent from my OnePlus 6 using XDA Labs
The Following User Says Thank You to Depressed T.Bear For This Useful Post: [ View ] Gift Depressed T.Bear Ad-Free
17th March 2019, 01:27 PM |#16  
Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by Depressed T.Bear

It sounds like you misunderstood something. The "Pro" app from. Google Play is just a companion app, which enables the pro features you bought. It doesn't contain the actual xposed module (and app) of xprivacy Lua.
Simply download it through the xposed repo or get the latest apk directly from the xprivacy lua website.

Thanks for the reply. I just assumed by my post it would make sense.

I do have the taichi magisk module installed, and from there I've installed xprivacylua. And from the google play store the pro companion app. @Depressed T.Bear - are you using xprivacylua on Pie? Does the pro app recognize the main app as installed for you?
The Following User Says Thank You to dirtyreturn For This Useful Post: [ View ] Gift dirtyreturn Ad-Free
17th March 2019, 01:49 PM |#17  
Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by Depressed T.Bear

It sounds like you misunderstood something. The "Pro" app from. Google Play is just a companion app, which enables the pro features you bought. It doesn't contain the actual xposed module (and app) of xprivacy Lua.
Simply download it through the xposed repo or get the latest apk directly from the xprivacy lua website.

Please see screenshots.
Attached Thumbnails
Click image for larger version

Name:	MyScreen_2019-03-17-08-45-52.png
Views:	718
Size:	137.8 KB
ID:	4725625   Click image for larger version

Name:	MyScreen_2019-03-17-08-46-10.png
Views:	714
Size:	76.4 KB
ID:	4725626   Click image for larger version

Name:	MyScreen_2019-03-17-08-46-35.png
Views:	702
Size:	94.2 KB
ID:	4725627  
17th March 2019, 02:16 PM |#18  
Depressed T.Bear's Avatar
Senior Member
Flag Berlin
Thanks Meter: 579
 
More
Quote:
Originally Posted by dirtyreturn

Thanks for the reply. I just assumed by my post it would make sense.

I do have the taichi magisk module installed, and from there I've installed xprivacylua. And from the google play store the pro companion app. @Depressed T.Bear - are you using xprivacylua on Pie? Does the pro app recognize the main app as installed for you?

Then it might be due to TaiChi.
Yes, I'm using XPrivacyLua on Pie - but with EdExposed and not with TaiChi. For one simple reason: TaiChi is not open source! EdExposed and RiruCore instead are.
So it would be absolute nonsense to use an app like XPrivacyLua to protect your privacy, while using a xposed version with is closed-source and nobody can tell what it actually does.

So, I can't help you with TaiChi. Only the developer can.
All I can say is that it works flawlessly with EdExposed.

Sent from my OnePlus 6 using XDA Labs
The Following 2 Users Say Thank You to Depressed T.Bear For This Useful Post: [ View ] Gift Depressed T.Bear Ad-Free
20th March 2019, 12:52 AM |#19  
Senior Member
Thanks Meter: 49
 
More
I have edxposed but I'm thinking of trying Taichi out to see if it's more stable. Will this work with modules such as xposed edge where the module doesnt target a specific app?
20th March 2019, 09:47 AM |#20  
Depressed T.Bear's Avatar
Senior Member
Flag Berlin
Thanks Meter: 579
 
More
Quote:
Originally Posted by Soumy1234

I have edxposed but I'm thinking of trying Taichi out to see if it's more stable. Will this work with modules such as xposed edge where the module doesnt target a specific app?

Your question is answered clearly in the first post

Sent from my OnePlus 6 using XDA Labs
30th March 2019, 03:16 PM |#21  
Senior Member
Thanks Meter: 72
 
More
Hi, what about WhatsApp Extensions and Amplify compatibility?

I will try TaiChi on stock Oreo without root.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes