FORUMS
Remove All Ads from XDA

XHangouts - The ultimate Google Hangouts extension.

456 posts
Thanks Meter: 781
 
Post Reply Email Thread
Announcement from Kevin M: v2.17 released! Check the first post for changelog.
3rd October 2014, 11:02 AM |#21  
Kevin M's Avatar
OP Recognized Developer
Thanks Meter: 781
 
Donate to Me
More
v1.2-8905918 has just been released. I've also just posted a NoMapTips mod that might be of some use to you gapps users.
Quote:
Originally Posted by Release Notes

Enter key behavior can now be tweaked! Check the settings page. The default action of the keyboard's enter/return key can be switched to one of the following: emoji selector (the default), newline, and send.

New icon by Adrian Babilinski!

Quote:
Originally Posted by dimm0k

nice little mod! possible to change the enter key to send instead of a new line?

Quote:
Originally Posted by Spikelangelo

Would you consider adding in a feature to replace the smiley key with a hard return key? Or would that be outside the scope of what you have in plan for the module?

Thanks

These have been added in v1.2!

Quote:
Originally Posted by benwalburn

If you're taking suggestions, I'd be ecstatic to see double-tapping the send button send the message and turn the screen off.

Sent from my OnePlus.

I'll take a look.
The Following 3 Users Say Thank You to Kevin M For This Useful Post: [ View ]
 
 
3rd October 2014, 01:51 PM |#22  
Senior Member
Thanks Meter: 534
 
More
@Kevin M nice, no more emoji... however if I choose send it only gives me newline... still better than the emoji though.
3rd October 2014, 07:44 PM |#23  
taxi333's Avatar
Member
Flag Tucson
Thanks Meter: 15
 
More
Pressing the enter when 'send it' enabled does not work on latest hangouts build
3rd October 2014, 10:14 PM |#24  
Senior Member
Flag Philadelphia
Thanks Meter: 50
 
More
The new line option works perfectly, thank you
4th October 2014, 12:33 AM |#25  
Kevin M's Avatar
OP Recognized Developer
Thanks Meter: 781
 
Donate to Me
More
Quote:
Originally Posted by taxi333

Pressing the enter when 'send it' enabled does not work on latest hangouts build

Hit the app switch button (dedicated or hold home button) and swipe away Hangouts. XHangouts reloads the configuration every time you enter into a conversation.
5th October 2014, 01:43 AM |#26  
ripv2's Avatar
Senior Member
Flag Newington, CT
Thanks Meter: 232
 
More
Great module, after closing out Hangouts from recent apps, and selecting the enter key send option it still creates a new line. Any ideas?
5th October 2014, 01:47 AM |#27  
Kevin M's Avatar
OP Recognized Developer
Thanks Meter: 781
 
Donate to Me
More
Quote:
Originally Posted by ripv2

Great module, after closing out Hangouts from recent apps, and selecting the enter key send option it still creates a new line. Any ideas?

Hmm. Go into the settings and post the version information for both XHangouts and Hangouts here. Also make certain that it says "Loaded." Select the default first option under enter key behavior and then select the send option. This should rewrite the entry into the preferences file. Give it a reboot, just to be safe, and try again.

If it's still not working then we'll need to do some more debugging. Which keyboard are you using? I've tested extensively with SwiftKey.
5th October 2014, 02:01 AM |#28  
ripv2's Avatar
Senior Member
Flag Newington, CT
Thanks Meter: 232
 
More
I'm using Google keyboard primarily. I just tried it with a few other ones I had installed. They all however work the same with changing the defualt (emoji) to the return key(new line). The sent just won't work. In the module settings it is displaying that it is "loaded". I will attach a screenshot of the versions I'm running. Thanks a lot for your help.
5th October 2014, 02:09 AM |#29  
ripv2's Avatar
Senior Member
Flag Newington, CT
Thanks Meter: 232
 
More
Here is the screenshot of the settings page for your module.
blackzigong
5th October 2014, 05:03 AM |#30  
Guest
Thanks Meter: 0
 
More
Could I request a new feature?
When I send a MMS, I can't pick a e-mail address from my contact and I have to enter it character by character.
So would you add an option to send a MMS in the contact tab?
5th October 2014, 10:08 AM |#31  
Kevin M's Avatar
OP Recognized Developer
Thanks Meter: 781
 
Donate to Me
More
Quote:
Originally Posted by ripv2

Here is the screenshot of the settings page for your module.

Android L? It could very well be something with that. It also appears that you're using a slightly outdated build of Hangouts, which could (but less likely) be a contributor (and could also be because you're running L). The Hangouts version on my Android 4.4.4 phone is 22037769.

Let's do a little more testing. Turn on debug mode and clear the Xposed log by opening Xposed Installer, click Logs, Menu, Clear log now. Give it a reboot and then open Hangouts. Go back to the Xposed log and screenshot what you see after "--- LOADING XHANGOUTS ---"
Post Reply Subscribe to Thread

Tags
google, hangouts, xposed

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes