FORUMS
Remove All Ads from XDA

[Xposed] Scoop - Catch the stack trace when an app crashes

1,209 posts
Thanks Meter: 4,933
 
Post Reply Email Thread
25th December 2016, 10:07 PM |#11  
KaMyKaSii's Avatar
Senior Member
Thanks Meter: 612
 
More
Quote:
Originally Posted by MrWasdennnoch

I said "not always"
I fixed it in v1.3.1. The fault was a misconfigured Proguard which removed more than it should have. I enabled Proguard for debug builds to avoid such issues in the future.

No more crashes, but the notification that Xposed is not installed persists. I updated the module, cleaned data and rebooted

Edit: Looking at this screenshot I recommend future features like search in the main screen, grouping of same app logs and individual exclusion
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2016-12-25-19-05-29.png
Views:	672
Size:	80.9 KB
ID:	3979777  
Attached Files
File Type: log xposed_error_20161225_190546.log - [Click for QR Code] (71.1 KB, 28 views)
25th December 2016, 11:05 PM |#12  
MrWasdennnoch's Avatar
OP Recognized Developer
Thanks Meter: 4,933
 
More
Quote:
Originally Posted by KaMyKaSii

No more crashes, but the notification that Xposed is not installed persists. I updated the module, cleaned data and rebooted
Looking at this screenshot I recommend future features like search in the main screen, grouping of same app logs and individual exclusion

Now it should be fixed. Problem is I can't test it because I updated to N and thus don't have Xposed anymore, so I had to try different ways. And of course it was Proguard again.
I'll add the search soon, I thought of only searching for different apps though and not searchin the short description. Not sure how I should approach the grouping but it's possible too. With exclusion you basically mean blacklisting?
The Following User Says Thank You to MrWasdennnoch For This Useful Post: [ View ]
26th December 2016, 02:42 PM |#13  
Member
Thanks Meter: 19
 
More
Xposed bridge version
Xposed installer tells me that I need Xposed bridge version 81. There are no updates for the XPosed bridge for me and the current version is 54, so I think that's a bug.
26th December 2016, 03:35 PM |#14  
MrWasdennnoch's Avatar
OP Recognized Developer
Thanks Meter: 4,933
 
More
Quote:
Originally Posted by Fabian R�ling

Xposed installer tells me that I need Xposed bridge version 81. There are no updates for the XPosed bridge for me and the current version is 54, so I think that's a bug.

The newest available version is 87, but I just remembered: 81 isn't available below LP, right? I'll fix that in the next release.
EDIT: Compatibility down to 52 added in v1.4.0
26th December 2016, 04:16 PM |#15  
Junior Member
Thanks Meter: 4
 
More
Compatibility down to 52 is very good, thanks.
The problem is in the image below
Click image for larger version

Name:	Screenshot_SmartSelect_2016-12-26-16-10-39.png
Views:	122
Size:	98.6 KB
ID:	3980424
Only version 1.1 works for me (n910f note 4 running marshmallow 6.0.1)
26th December 2016, 07:05 PM |#16  
KaMyKaSii's Avatar
Senior Member
Thanks Meter: 612
 
More
The bug of not having Xposed installed continues, but the app continues to intercept the crashes normally
Attached Files
File Type: log xposed_error_20161226_160539.log - [Click for QR Code] (120.2 KB, 4 views)
26th December 2016, 07:50 PM |#17  
MrWasdennnoch's Avatar
OP Recognized Developer
Thanks Meter: 4,933
 
More
Quote:
Originally Posted by MarioUnoDueTre

The problem is in the image below

Quote:
Originally Posted by KaMyKaSii

The bug of not having Xposed installed continues, but the app continues to intercept the crashes normally

That's really weird, it hould be working. I completely disabled the warning and will have a look again when Xposed for N is available.
26th December 2016, 08:09 PM |#18  
KaMyKaSii's Avatar
Senior Member
Thanks Meter: 612
 
More
Quote:
Originally Posted by MrWasdennnoch

That's really weird, it hould be working. I completely disabled the warning and will have a look again when Xposed for N is available.

I reported with version 1.3.2, although you talk about version 1.4.0, it was not available when I opened the Xposed Installer. I will update now

Edit: The new version is not working, no crash is being logged
Attached Files
File Type: zip Logs.zip - [Click for QR Code] (1.18 MB, 4 views)
27th December 2016, 03:36 PM |#19  
MrWasdennnoch's Avatar
OP Recognized Developer
Thanks Meter: 4,933
 
More
Quote:
Originally Posted by KaMyKaSii

I reported with version 1.3.2, although you talk about version 1.4.0, it was not available when I opened the Xposed Installer. I will update now

Edit: The new version is not working, no crash is being logged

1.4.2 should fix it... Really bad that I can't test it myself, it could've avoided many issues. But hey, at least I now know how to configure ProGuard properly. At least I hope so.
The Following User Says Thank You to MrWasdennnoch For This Useful Post: [ View ]
27th December 2016, 04:14 PM |#20  
KaMyKaSii's Avatar
Senior Member
Thanks Meter: 612
 
More
Quote:
Originally Posted by MrWasdennnoch

1.4.2 should fix it... Really bad that I can't test it myself, it could've avoided many issues. But hey, at least I now know how to configure ProGuard properly. At least I hope so.

Thanks, now it's working. Can you explain to me how the grouping that you implemented works? When I suggested, I wanted to say that after clicking on the crash group of the app, a list of all the crashs with information like date and time appears, and that they expand in the full log when they are clicked. And about the deletion, I'm talking about a button to clear any individual log after a long click on it. At this time it is only possible to clear all logs at once
27th December 2016, 04:23 PM |#21  
Junior Member
Thanks Meter: 4
 
More
Yes!
1.4.2 is working; good job, thanks a lot.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes