Remove All Ads from XDA

Snapchat on rooted phones with xposed

76 posts
Thanks Meter: 52
 
By mihailgreceanu, Member on 31st December 2015, 07:52 PM
Post Reply Email Thread
28th July 2017, 01:09 AM |#411  
Junior Member
Thanks Meter: 1
 
More
How do I make sure that the framework is totally gone and uninstalled? I am running a rooted Nougat rom.

Edit: This topic is totally false. The actual answer was listed but not on the 1st post. You absolutely need to unroot in order to login to snapchat. The first post should be edited and updated.
The Following User Says Thank You to fredfredfredfr For This Useful Post: [ View ] Gift fredfredfredfr Ad-Free
 
 
12th August 2017, 09:53 AM |#412  
Junior Member
Thanks Meter: 0
 
More
you don't need to unroot if you have a second phone or nox emulator
18th August 2017, 09:03 PM |#413  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Maurylucha

I found a work around for it my phone died and I signed into my sc from another device used it and logged off when I tried signing in on my phone I got temp login failure notice this is what I did to get back on:

On a second device, download latest version and sign into Snapchat

Once done, root second device and download titanium backup

Make a back up of Snapchat from second device and send the .tibkp back up or whatever to the first device

On first device download latest version of snapchat and titanium back up and restore the data only from the file you sent to the first device from the second device

Once done use sc like normal

Works fine unless you sign out from Snapchat on the second device so what I did is I froze Snapchat on the second device and erased the back up.

BTW I used a Samsung tablet as a second device and s6 edge for first device

Is the pro key required? When I start Titanium Backup it says that the Auto/App installation is not awailable since HyperShell is missing. So I backed up Snapchat from a rooted phone where I get access into my snapchat account so I am logged in. Then moved the backup files to the phone where I have troubles loggin in on snapchat. Then when I restore snapchat with Titanium backup it installs the app first and then restores the data. When I start Snapchat afterwards it is not logged in but asks me to login and the same error message appears... So does it only work with the Prokey?
11th September 2017, 10:59 PM |#414  
Junior Member
Panama
Thanks Meter: 2
 
More
Explanation...
Hi man, I'm not the you asked but I'll leave this post here in case anybody is as confused as I was...

First of all you don't need the pro key, just some understanding of this confusing matter.

When you make a snapchat backup using Titanium, you are basically taking a "session code" with you to the rooted phone, if you log out from that session in the un-rooted phone you will also be logged out from the rooted phone because they share "session code" I call them codes because each sessions seems to be unique, example, if you restore the backup on the rooted phone and use snapchat but then decide to logout, you will NOT be able to use the same restore because since you logged out from snapchat servers you will now need a new "session code" that can only be created from an un-rooted phone.. You can however, uninstall snapchat without logging out and install it again using the same restore file.. Why? Because you never officially ended the original session. Anyways, this piece of info solved my problem for good so I hope it helps someone else
Post Reply Subscribe to Thread

Tags
root, snapchat, xposed

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes